Message ID | 1427728773-29065-2-git-send-email-k.kozlowski@samsung.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On 03/31/2015 12:19 AM, Krzysztof Kozlowski wrote: > There are now no differences between RTC on Exynos3250 and S3C6410. > Merge everything into one so duplicated code could be removed. > > Signed-off-by: Krzysztof Kozlowski <k.kozlowski@samsung.com> > --- > drivers/rtc/rtc-s3c.c | 14 +------------- > 1 file changed, 1 insertion(+), 13 deletions(-) > > diff --git a/drivers/rtc/rtc-s3c.c b/drivers/rtc/rtc-s3c.c > index fb0c569765c6..5e162eaad277 100644 > --- a/drivers/rtc/rtc-s3c.c > +++ b/drivers/rtc/rtc-s3c.c > @@ -774,18 +774,6 @@ static struct s3c_rtc_data const s3c6410_rtc_data = { > .disable = s3c6410_rtc_disable, > }; > > -static struct s3c_rtc_data const exynos3250_rtc_data = { > - .max_user_freq = 32768, > - .needs_src_clk = true, > - .irq_handler = s3c6410_rtc_irq, > - .set_freq = s3c6410_rtc_setfreq, > - .enable_tick = s3c6410_rtc_enable_tick, > - .save_tick_cnt = s3c6410_rtc_save_tick_cnt, > - .restore_tick_cnt = s3c6410_rtc_restore_tick_cnt, > - .enable = s3c24xx_rtc_enable, > - .disable = s3c6410_rtc_disable, > -}; > - > static const struct of_device_id s3c_rtc_dt_match[] = { > { > .compatible = "samsung,s3c2410-rtc", > @@ -801,7 +789,7 @@ static const struct of_device_id s3c_rtc_dt_match[] = { > .data = (void *)&s3c6410_rtc_data, > }, { > .compatible = "samsung,exynos3250-rtc", > - .data = (void *)&exynos3250_rtc_data, > + .data = (void *)&s3c6410_rtc_data, > }, > { /* sentinel */ }, > }; > Looks good to me. Reviewd-by: Chanwoo Choi <cw00.choi@samsung.com> Thanks, Chanwoo Choi
nitpick: I would prefer rtc: rtc-s3c instead of drivers/rtc/rtc-s3c.c On 30/03/2015 at 17:19:32 +0200, Krzysztof Kozlowski wrote : > There are now no differences between RTC on Exynos3250 and S3C6410. > Merge everything into one so duplicated code could be removed. > > Signed-off-by: Krzysztof Kozlowski <k.kozlowski@samsung.com> Acked-by: Alexandre Belloni <alexandre.belloni@free-electrons.com> > --- > drivers/rtc/rtc-s3c.c | 14 +------------- > 1 file changed, 1 insertion(+), 13 deletions(-) > > diff --git a/drivers/rtc/rtc-s3c.c b/drivers/rtc/rtc-s3c.c > index fb0c569765c6..5e162eaad277 100644 > --- a/drivers/rtc/rtc-s3c.c > +++ b/drivers/rtc/rtc-s3c.c > @@ -774,18 +774,6 @@ static struct s3c_rtc_data const s3c6410_rtc_data = { > .disable = s3c6410_rtc_disable, > }; > > -static struct s3c_rtc_data const exynos3250_rtc_data = { > - .max_user_freq = 32768, > - .needs_src_clk = true, > - .irq_handler = s3c6410_rtc_irq, > - .set_freq = s3c6410_rtc_setfreq, > - .enable_tick = s3c6410_rtc_enable_tick, > - .save_tick_cnt = s3c6410_rtc_save_tick_cnt, > - .restore_tick_cnt = s3c6410_rtc_restore_tick_cnt, > - .enable = s3c24xx_rtc_enable, > - .disable = s3c6410_rtc_disable, > -}; > - > static const struct of_device_id s3c_rtc_dt_match[] = { > { > .compatible = "samsung,s3c2410-rtc", > @@ -801,7 +789,7 @@ static const struct of_device_id s3c_rtc_dt_match[] = { > .data = (void *)&s3c6410_rtc_data, > }, { > .compatible = "samsung,exynos3250-rtc", > - .data = (void *)&exynos3250_rtc_data, > + .data = (void *)&s3c6410_rtc_data, > }, > { /* sentinel */ }, > }; > -- > 1.9.1 >
Hello Alexandre, On Tue, Mar 31, 2015 at 2:27 AM, Alexandre Belloni <alexandre.belloni@free-electrons.com> wrote: > nitpick: I would prefer rtc: rtc-s3c instead of drivers/rtc/rtc-s3c.c > Yes but Krzysztof is following the convention used in drivers/rtc/ which I think is the correct thing to do even when it's different from what is used all over the kernel. > On 30/03/2015 at 17:19:32 +0200, Krzysztof Kozlowski wrote : >> There are now no differences between RTC on Exynos3250 and S3C6410. >> Merge everything into one so duplicated code could be removed. >> >> Signed-off-by: Krzysztof Kozlowski <k.kozlowski@samsung.com> > > Acked-by: Alexandre Belloni <alexandre.belloni@free-electrons.com> > Reviewed-by: Javier Martinez Canillas <javier.martinez@collabora.co.uk> Best regards, Javier
Hi, On 31/03/2015 at 08:49:39 +0200, Javier Martinez Canillas wrote : > Hello Alexandre, > > On Tue, Mar 31, 2015 at 2:27 AM, Alexandre Belloni > <alexandre.belloni@free-electrons.com> wrote: > > nitpick: I would prefer rtc: rtc-s3c instead of drivers/rtc/rtc-s3c.c > > > > Yes but Krzysztof is following the convention used in drivers/rtc/ > which I think is the correct thing to do even when it's different from > what is used all over the kernel. > Having a look at the git history, the first and most used prefix is actually 'rtc:' at some point, this started to change to 'drivers/rtc/'. We should probably start to get back to 'rtc:', like most subsystems.
2015-03-31 10:20 GMT+02:00 Alexandre Belloni <alexandre.belloni@free-electrons.com>: > Hi, > > On 31/03/2015 at 08:49:39 +0200, Javier Martinez Canillas wrote : >> Hello Alexandre, >> >> On Tue, Mar 31, 2015 at 2:27 AM, Alexandre Belloni >> <alexandre.belloni@free-electrons.com> wrote: >> > nitpick: I would prefer rtc: rtc-s3c instead of drivers/rtc/rtc-s3c.c >> > >> >> Yes but Krzysztof is following the convention used in drivers/rtc/ >> which I think is the correct thing to do even when it's different from >> what is used all over the kernel. >> > > Having a look at the git history, the first and most used prefix is > actually 'rtc:' at some point, this started to change to 'drivers/rtc/'. > We should probably start to get back to 'rtc:', like most subsystems. Yes, I used "rtc: driver_name:" before but I saw that Andrew changes them to full path when he picks the patch. So this time I wanted to reduce the overhead for him... Anyway I'll stick to one format ("rtc: rtc-s3c:") as you proposed. Best regards, Krzysztof
diff --git a/drivers/rtc/rtc-s3c.c b/drivers/rtc/rtc-s3c.c index fb0c569765c6..5e162eaad277 100644 --- a/drivers/rtc/rtc-s3c.c +++ b/drivers/rtc/rtc-s3c.c @@ -774,18 +774,6 @@ static struct s3c_rtc_data const s3c6410_rtc_data = { .disable = s3c6410_rtc_disable, }; -static struct s3c_rtc_data const exynos3250_rtc_data = { - .max_user_freq = 32768, - .needs_src_clk = true, - .irq_handler = s3c6410_rtc_irq, - .set_freq = s3c6410_rtc_setfreq, - .enable_tick = s3c6410_rtc_enable_tick, - .save_tick_cnt = s3c6410_rtc_save_tick_cnt, - .restore_tick_cnt = s3c6410_rtc_restore_tick_cnt, - .enable = s3c24xx_rtc_enable, - .disable = s3c6410_rtc_disable, -}; - static const struct of_device_id s3c_rtc_dt_match[] = { { .compatible = "samsung,s3c2410-rtc", @@ -801,7 +789,7 @@ static const struct of_device_id s3c_rtc_dt_match[] = { .data = (void *)&s3c6410_rtc_data, }, { .compatible = "samsung,exynos3250-rtc", - .data = (void *)&exynos3250_rtc_data, + .data = (void *)&s3c6410_rtc_data, }, { /* sentinel */ }, };
There are now no differences between RTC on Exynos3250 and S3C6410. Merge everything into one so duplicated code could be removed. Signed-off-by: Krzysztof Kozlowski <k.kozlowski@samsung.com> --- drivers/rtc/rtc-s3c.c | 14 +------------- 1 file changed, 1 insertion(+), 13 deletions(-)