Message ID | 1432209881-11842-1-git-send-email-animesh.manna@intel.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Thu, May 21, 2015 at 5:04 AM, Animesh Manna <animesh.manna@intel.com> wrote: > Naming convention of csr firmware will be - > <platform>_dmc_<api-version>_<minor-version>.bin > > Accordingly updated the same in code. > > Signed-off-by: Animesh Manna <animesh.manna@intel.com> > --- > drivers/gpu/drm/i915/intel_csr.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/gpu/drm/i915/intel_csr.c b/drivers/gpu/drm/i915/intel_csr.c > index fec2bc5..9bd05bf 100644 > --- a/drivers/gpu/drm/i915/intel_csr.c > +++ b/drivers/gpu/drm/i915/intel_csr.c > @@ -34,7 +34,7 @@ > * low-power state and comes back to normal. > */ > > -#define I915_CSR_SKL "i915/skl_dmc_ver4.bin" > +#define I915_CSR_SKL "i915/skl_dmc_1_4.bin" I believe in this case the install instructions should point to copy instead of linking it, but not hardcode the release version. So shouldn't it be i915/skl_dmc_ver1.bin then? or i915/skl_dmc_ver1_4.bin in worst case... > > MODULE_FIRMWARE(I915_CSR_SKL); > > -- > 2.0.2 > > _______________________________________________ > Intel-gfx mailing list > Intel-gfx@lists.freedesktop.org > http://lists.freedesktop.org/mailman/listinfo/intel-gfx
On Tue, May 26, 2015 at 05:21:56PM -0700, Rodrigo Vivi wrote: > On Thu, May 21, 2015 at 5:04 AM, Animesh Manna <animesh.manna@intel.com> wrote: > > Naming convention of csr firmware will be - > > <platform>_dmc_<api-version>_<minor-version>.bin > > > > Accordingly updated the same in code. > > > > Signed-off-by: Animesh Manna <animesh.manna@intel.com> > > --- > > drivers/gpu/drm/i915/intel_csr.c | 2 +- > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > diff --git a/drivers/gpu/drm/i915/intel_csr.c b/drivers/gpu/drm/i915/intel_csr.c > > index fec2bc5..9bd05bf 100644 > > --- a/drivers/gpu/drm/i915/intel_csr.c > > +++ b/drivers/gpu/drm/i915/intel_csr.c > > @@ -34,7 +34,7 @@ > > * low-power state and comes back to normal. > > */ > > > > -#define I915_CSR_SKL "i915/skl_dmc_ver4.bin" > > +#define I915_CSR_SKL "i915/skl_dmc_1_4.bin" > > I believe in this case the install instructions should point to copy > instead of linking it, but not hardcode the release version. > > So shouldn't it be i915/skl_dmc_ver1.bin then? > > or i915/skl_dmc_ver1_4.bin in worst case... While at it, can we perhaps _not_ hardcode the minor revision? Hardcoding the minor revision torpedoes the entire concept of even having a minor revision. If the firmware team can't do proper abi versioning, then imo we should just put one number for each and keep it at that. -Daniel > > > > > MODULE_FIRMWARE(I915_CSR_SKL); > > > > -- > > 2.0.2 > > > > _______________________________________________ > > Intel-gfx mailing list > > Intel-gfx@lists.freedesktop.org > > http://lists.freedesktop.org/mailman/listinfo/intel-gfx > > > > -- > Rodrigo Vivi > Blog: http://blog.vivi.eng.br > _______________________________________________ > Intel-gfx mailing list > Intel-gfx@lists.freedesktop.org > http://lists.freedesktop.org/mailman/listinfo/intel-gfx
On 27.05.2015 14:34, Daniel Vetter wrote: > On Tue, May 26, 2015 at 05:21:56PM -0700, Rodrigo Vivi wrote: >> On Thu, May 21, 2015 at 5:04 AM, Animesh Manna <animesh.manna@intel.com> wrote: >>> Naming convention of csr firmware will be - >>> <platform>_dmc_<api-version>_<minor-version>.bin >>> >>> Accordingly updated the same in code. >>> >>> Signed-off-by: Animesh Manna <animesh.manna@intel.com> >>> --- >>> drivers/gpu/drm/i915/intel_csr.c | 2 +- >>> 1 file changed, 1 insertion(+), 1 deletion(-) >>> >>> diff --git a/drivers/gpu/drm/i915/intel_csr.c b/drivers/gpu/drm/i915/intel_csr.c >>> index fec2bc5..9bd05bf 100644 >>> --- a/drivers/gpu/drm/i915/intel_csr.c >>> +++ b/drivers/gpu/drm/i915/intel_csr.c >>> @@ -34,7 +34,7 @@ >>> * low-power state and comes back to normal. >>> */ >>> >>> -#define I915_CSR_SKL "i915/skl_dmc_ver4.bin" >>> +#define I915_CSR_SKL "i915/skl_dmc_1_4.bin" >> >> I believe in this case the install instructions should point to copy >> instead of linking it, but not hardcode the release version. >> >> So shouldn't it be i915/skl_dmc_ver1.bin then? >> >> or i915/skl_dmc_ver1_4.bin in worst case... > > While at it, can we perhaps _not_ hardcode the minor revision? Hardcoding > the minor revision torpedoes the entire concept of even having a minor > revision. If the firmware team can't do proper abi versioning, then imo we > should just put one number for each and keep it at that. > -Daniel Can we please settle on something? I'd rather have the csr fw in linux-firmware quite soon, so that the driver wouldn't give an ugly assert when csr doesn't work.
diff --git a/drivers/gpu/drm/i915/intel_csr.c b/drivers/gpu/drm/i915/intel_csr.c index fec2bc5..9bd05bf 100644 --- a/drivers/gpu/drm/i915/intel_csr.c +++ b/drivers/gpu/drm/i915/intel_csr.c @@ -34,7 +34,7 @@ * low-power state and comes back to normal. */ -#define I915_CSR_SKL "i915/skl_dmc_ver4.bin" +#define I915_CSR_SKL "i915/skl_dmc_1_4.bin" MODULE_FIRMWARE(I915_CSR_SKL);
Naming convention of csr firmware will be - <platform>_dmc_<api-version>_<minor-version>.bin Accordingly updated the same in code. Signed-off-by: Animesh Manna <animesh.manna@intel.com> --- drivers/gpu/drm/i915/intel_csr.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)