diff mbox

[v2,1/8] introduce __sb_{acquire,release}_write() helpers

Message ID 20150811170358.GA26901@redhat.com (mailing list archive)
State New, archived
Headers show

Commit Message

Oleg Nesterov Aug. 11, 2015, 5:03 p.m. UTC
Preparation to hide the sb->s_writers internals from xfs and btrfs.
Add 2 trivial define's they can use rather than play with ->s_writers
directly. No changes in btrfs/transaction.o and xfs/xfs_aops.o.

Signed-off-by: Oleg Nesterov <oleg@redhat.com>
---
 fs/btrfs/transaction.c |    8 ++------
 fs/xfs/xfs_aops.c      |    6 ++----
 include/linux/fs.h     |    5 +++++
 3 files changed, 9 insertions(+), 10 deletions(-)

Comments

Jan Kara Aug. 13, 2015, 9:45 a.m. UTC | #1
On Tue 11-08-15 19:03:58, Oleg Nesterov wrote:
> Preparation to hide the sb->s_writers internals from xfs and btrfs.
> Add 2 trivial define's they can use rather than play with ->s_writers
> directly. No changes in btrfs/transaction.o and xfs/xfs_aops.o.
> 
> Signed-off-by: Oleg Nesterov <oleg@redhat.com>

Looks good. You can add:

Reviewed-by: Jan Kara <jack@suse.com>

								Honza

> ---
>  fs/btrfs/transaction.c |    8 ++------
>  fs/xfs/xfs_aops.c      |    6 ++----
>  include/linux/fs.h     |    5 +++++
>  3 files changed, 9 insertions(+), 10 deletions(-)
> 
> diff --git a/fs/btrfs/transaction.c b/fs/btrfs/transaction.c
> index 5628e25..6dca4e9 100644
> --- a/fs/btrfs/transaction.c
> +++ b/fs/btrfs/transaction.c
> @@ -1620,9 +1620,7 @@ static void do_async_commit(struct work_struct *work)
>  	 * Tell lockdep about it.
>  	 */
>  	if (ac->newtrans->type & __TRANS_FREEZABLE)
> -		rwsem_acquire_read(
> -		     &ac->root->fs_info->sb->s_writers.lock_map[SB_FREEZE_FS-1],
> -		     0, 1, _THIS_IP_);
> +		__sb_acquire_write(ac->root->fs_info->sb, SB_FREEZE_FS);
>  
>  	current->journal_info = ac->newtrans;
>  
> @@ -1661,9 +1659,7 @@ int btrfs_commit_transaction_async(struct btrfs_trans_handle *trans,
>  	 * async commit thread will be the one to unlock it.
>  	 */
>  	if (ac->newtrans->type & __TRANS_FREEZABLE)
> -		rwsem_release(
> -			&root->fs_info->sb->s_writers.lock_map[SB_FREEZE_FS-1],
> -			1, _THIS_IP_);
> +		__sb_release_write(root->fs_info->sb, SB_FREEZE_FS);
>  
>  	schedule_work(&ac->work);
>  
> diff --git a/fs/xfs/xfs_aops.c b/fs/xfs/xfs_aops.c
> index a56960d..8034c78 100644
> --- a/fs/xfs/xfs_aops.c
> +++ b/fs/xfs/xfs_aops.c
> @@ -119,8 +119,7 @@ xfs_setfilesize_trans_alloc(
>  	 * We may pass freeze protection with a transaction.  So tell lockdep
>  	 * we released it.
>  	 */
> -	rwsem_release(&ioend->io_inode->i_sb->s_writers.lock_map[SB_FREEZE_FS-1],
> -		      1, _THIS_IP_);
> +	__sb_release_write(ioend->io_inode->i_sb, SB_FREEZE_FS);
>  	/*
>  	 * We hand off the transaction to the completion thread now, so
>  	 * clear the flag here.
> @@ -171,8 +170,7 @@ xfs_setfilesize_ioend(
>  	 * Similarly for freeze protection.
>  	 */
>  	current_set_flags_nested(&tp->t_pflags, PF_FSTRANS);
> -	rwsem_acquire_read(&VFS_I(ip)->i_sb->s_writers.lock_map[SB_FREEZE_FS-1],
> -			   0, 1, _THIS_IP_);
> +	__sb_acquire_write(VFS_I(ip)->i_sb, SB_FREEZE_FS);
>  
>  	return xfs_setfilesize(ip, tp, ioend->io_offset, ioend->io_size);
>  }
> diff --git a/include/linux/fs.h b/include/linux/fs.h
> index 35ec87e..78ac768 100644
> --- a/include/linux/fs.h
> +++ b/include/linux/fs.h
> @@ -1362,6 +1362,11 @@ extern struct timespec current_fs_time(struct super_block *sb);
>  void __sb_end_write(struct super_block *sb, int level);
>  int __sb_start_write(struct super_block *sb, int level, bool wait);
>  
> +#define __sb_acquire_write(sb, lev)	\
> +	rwsem_acquire_read(&(sb)->s_writers.lock_map[(lev)-1], 0, 1, _THIS_IP_)
> +#define __sb_release_write(sb, lev)	\
> +	rwsem_release(&(sb)->s_writers.lock_map[(lev)-1], 1, _THIS_IP_)
> +
>  /**
>   * sb_end_write - drop write access to a superblock
>   * @sb: the super we wrote to
> -- 
> 1.5.5.1
>
Jan Kara Aug. 13, 2015, 9:56 a.m. UTC | #2
On Thu 13-08-15 11:45:52, Jan Kara wrote:
> On Tue 11-08-15 19:03:58, Oleg Nesterov wrote:
> > Preparation to hide the sb->s_writers internals from xfs and btrfs.
> > Add 2 trivial define's they can use rather than play with ->s_writers
> > directly. No changes in btrfs/transaction.o and xfs/xfs_aops.o.
> > 
> > Signed-off-by: Oleg Nesterov <oleg@redhat.com>
> 
> Looks good. You can add:
> 
> Reviewed-by: Jan Kara <jack@suse.com>

One comment when looking at other patches - I'd prefer somewhat better name
than __sb_acquire_write(). It doesn't tell that it's only a trylock
acquisition. Maybe something like

__sb_writers_acquire_nowait()

and then

__sb_writers_release()?

								Honza
> > ---
> >  fs/btrfs/transaction.c |    8 ++------
> >  fs/xfs/xfs_aops.c      |    6 ++----
> >  include/linux/fs.h     |    5 +++++
> >  3 files changed, 9 insertions(+), 10 deletions(-)
> > 
> > diff --git a/fs/btrfs/transaction.c b/fs/btrfs/transaction.c
> > index 5628e25..6dca4e9 100644
> > --- a/fs/btrfs/transaction.c
> > +++ b/fs/btrfs/transaction.c
> > @@ -1620,9 +1620,7 @@ static void do_async_commit(struct work_struct *work)
> >  	 * Tell lockdep about it.
> >  	 */
> >  	if (ac->newtrans->type & __TRANS_FREEZABLE)
> > -		rwsem_acquire_read(
> > -		     &ac->root->fs_info->sb->s_writers.lock_map[SB_FREEZE_FS-1],
> > -		     0, 1, _THIS_IP_);
> > +		__sb_acquire_write(ac->root->fs_info->sb, SB_FREEZE_FS);
> >  
> >  	current->journal_info = ac->newtrans;
> >  
> > @@ -1661,9 +1659,7 @@ int btrfs_commit_transaction_async(struct btrfs_trans_handle *trans,
> >  	 * async commit thread will be the one to unlock it.
> >  	 */
> >  	if (ac->newtrans->type & __TRANS_FREEZABLE)
> > -		rwsem_release(
> > -			&root->fs_info->sb->s_writers.lock_map[SB_FREEZE_FS-1],
> > -			1, _THIS_IP_);
> > +		__sb_release_write(root->fs_info->sb, SB_FREEZE_FS);
> >  
> >  	schedule_work(&ac->work);
> >  
> > diff --git a/fs/xfs/xfs_aops.c b/fs/xfs/xfs_aops.c
> > index a56960d..8034c78 100644
> > --- a/fs/xfs/xfs_aops.c
> > +++ b/fs/xfs/xfs_aops.c
> > @@ -119,8 +119,7 @@ xfs_setfilesize_trans_alloc(
> >  	 * We may pass freeze protection with a transaction.  So tell lockdep
> >  	 * we released it.
> >  	 */
> > -	rwsem_release(&ioend->io_inode->i_sb->s_writers.lock_map[SB_FREEZE_FS-1],
> > -		      1, _THIS_IP_);
> > +	__sb_release_write(ioend->io_inode->i_sb, SB_FREEZE_FS);
> >  	/*
> >  	 * We hand off the transaction to the completion thread now, so
> >  	 * clear the flag here.
> > @@ -171,8 +170,7 @@ xfs_setfilesize_ioend(
> >  	 * Similarly for freeze protection.
> >  	 */
> >  	current_set_flags_nested(&tp->t_pflags, PF_FSTRANS);
> > -	rwsem_acquire_read(&VFS_I(ip)->i_sb->s_writers.lock_map[SB_FREEZE_FS-1],
> > -			   0, 1, _THIS_IP_);
> > +	__sb_acquire_write(VFS_I(ip)->i_sb, SB_FREEZE_FS);
> >  
> >  	return xfs_setfilesize(ip, tp, ioend->io_offset, ioend->io_size);
> >  }
> > diff --git a/include/linux/fs.h b/include/linux/fs.h
> > index 35ec87e..78ac768 100644
> > --- a/include/linux/fs.h
> > +++ b/include/linux/fs.h
> > @@ -1362,6 +1362,11 @@ extern struct timespec current_fs_time(struct super_block *sb);
> >  void __sb_end_write(struct super_block *sb, int level);
> >  int __sb_start_write(struct super_block *sb, int level, bool wait);
> >  
> > +#define __sb_acquire_write(sb, lev)	\
> > +	rwsem_acquire_read(&(sb)->s_writers.lock_map[(lev)-1], 0, 1, _THIS_IP_)
> > +#define __sb_release_write(sb, lev)	\
> > +	rwsem_release(&(sb)->s_writers.lock_map[(lev)-1], 1, _THIS_IP_)
> > +
> >  /**
> >   * sb_end_write - drop write access to a superblock
> >   * @sb: the super we wrote to
> > -- 
> > 1.5.5.1
> > 
> -- 
> Jan Kara <jack@suse.com>
> SUSE Labs, CR
Oleg Nesterov Aug. 13, 2015, 1:17 p.m. UTC | #3
On 08/13, Jan Kara wrote:
>
> On Thu 13-08-15 11:45:52, Jan Kara wrote:
> > On Tue 11-08-15 19:03:58, Oleg Nesterov wrote:
> > > Preparation to hide the sb->s_writers internals from xfs and btrfs.
> > > Add 2 trivial define's they can use rather than play with ->s_writers
> > > directly. No changes in btrfs/transaction.o and xfs/xfs_aops.o.
> > >
> > > Signed-off-by: Oleg Nesterov <oleg@redhat.com>
> >
> > Looks good. You can add:
> >
> > Reviewed-by: Jan Kara <jack@suse.com>
>
> One comment when looking at other patches - I'd prefer somewhat better name
> than __sb_acquire_write().

Yes, __sb_acquire_write() doesn't look nice and I agree with any
naming.

> It doesn't tell that it's only a trylock
> acquisition. Maybe something like

But it is not actually "trylock"... This lock was already locked but
not by us. __sb_release_write + __sb_acquire_write is used to transfer
the ownership,

> __sb_writers_acquire_nowait()
>
> and then
>
> __sb_writers_release()?

so I agree with any naming, I'll update this patch... but perhaps
__sb_writers_acquire() without "_nowait" make more sense?

Oleg.

--
To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Jan Kara Aug. 13, 2015, 1:32 p.m. UTC | #4
On Thu 13-08-15 15:17:44, Oleg Nesterov wrote:
> On 08/13, Jan Kara wrote:
> >
> > On Thu 13-08-15 11:45:52, Jan Kara wrote:
> > > On Tue 11-08-15 19:03:58, Oleg Nesterov wrote:
> > > > Preparation to hide the sb->s_writers internals from xfs and btrfs.
> > > > Add 2 trivial define's they can use rather than play with ->s_writers
> > > > directly. No changes in btrfs/transaction.o and xfs/xfs_aops.o.
> > > >
> > > > Signed-off-by: Oleg Nesterov <oleg@redhat.com>
> > >
> > > Looks good. You can add:
> > >
> > > Reviewed-by: Jan Kara <jack@suse.com>
> >
> > One comment when looking at other patches - I'd prefer somewhat better name
> > than __sb_acquire_write().
> 
> Yes, __sb_acquire_write() doesn't look nice and I agree with any
> naming.
> 
> > It doesn't tell that it's only a trylock
> > acquisition. Maybe something like
> 
> But it is not actually "trylock"... This lock was already locked but
> not by us. __sb_release_write + __sb_acquire_write is used to transfer
> the ownership,
>
> > __sb_writers_acquire_nowait()
> >
> > and then
> >
> > __sb_writers_release()?
> 
> so I agree with any naming, I'll update this patch... but perhaps
> __sb_writers_acquire() without "_nowait" make more sense?

OK, drop _nowait - maybe:

__sb_writers_acquired()

(note the additional 'd' at the end) to suggest that we already hold the lock
and only want to tell lockdep about it?

								Honza
Oleg Nesterov Aug. 13, 2015, 1:37 p.m. UTC | #5
On 08/13, Jan Kara wrote:
>
> On Thu 13-08-15 15:17:44, Oleg Nesterov wrote:
> >
> > so I agree with any naming, I'll update this patch... but perhaps
> > __sb_writers_acquire() without "_nowait" make more sense?
>
> OK, drop _nowait - maybe:
>
> __sb_writers_acquired()
>
> (note the additional 'd' at the end) to suggest that we already hold the lock
> and only want to tell lockdep about it?

Agreed! Will do in v3.

Oleg.

--
To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/fs/btrfs/transaction.c b/fs/btrfs/transaction.c
index 5628e25..6dca4e9 100644
--- a/fs/btrfs/transaction.c
+++ b/fs/btrfs/transaction.c
@@ -1620,9 +1620,7 @@  static void do_async_commit(struct work_struct *work)
 	 * Tell lockdep about it.
 	 */
 	if (ac->newtrans->type & __TRANS_FREEZABLE)
-		rwsem_acquire_read(
-		     &ac->root->fs_info->sb->s_writers.lock_map[SB_FREEZE_FS-1],
-		     0, 1, _THIS_IP_);
+		__sb_acquire_write(ac->root->fs_info->sb, SB_FREEZE_FS);
 
 	current->journal_info = ac->newtrans;
 
@@ -1661,9 +1659,7 @@  int btrfs_commit_transaction_async(struct btrfs_trans_handle *trans,
 	 * async commit thread will be the one to unlock it.
 	 */
 	if (ac->newtrans->type & __TRANS_FREEZABLE)
-		rwsem_release(
-			&root->fs_info->sb->s_writers.lock_map[SB_FREEZE_FS-1],
-			1, _THIS_IP_);
+		__sb_release_write(root->fs_info->sb, SB_FREEZE_FS);
 
 	schedule_work(&ac->work);
 
diff --git a/fs/xfs/xfs_aops.c b/fs/xfs/xfs_aops.c
index a56960d..8034c78 100644
--- a/fs/xfs/xfs_aops.c
+++ b/fs/xfs/xfs_aops.c
@@ -119,8 +119,7 @@  xfs_setfilesize_trans_alloc(
 	 * We may pass freeze protection with a transaction.  So tell lockdep
 	 * we released it.
 	 */
-	rwsem_release(&ioend->io_inode->i_sb->s_writers.lock_map[SB_FREEZE_FS-1],
-		      1, _THIS_IP_);
+	__sb_release_write(ioend->io_inode->i_sb, SB_FREEZE_FS);
 	/*
 	 * We hand off the transaction to the completion thread now, so
 	 * clear the flag here.
@@ -171,8 +170,7 @@  xfs_setfilesize_ioend(
 	 * Similarly for freeze protection.
 	 */
 	current_set_flags_nested(&tp->t_pflags, PF_FSTRANS);
-	rwsem_acquire_read(&VFS_I(ip)->i_sb->s_writers.lock_map[SB_FREEZE_FS-1],
-			   0, 1, _THIS_IP_);
+	__sb_acquire_write(VFS_I(ip)->i_sb, SB_FREEZE_FS);
 
 	return xfs_setfilesize(ip, tp, ioend->io_offset, ioend->io_size);
 }
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 35ec87e..78ac768 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1362,6 +1362,11 @@  extern struct timespec current_fs_time(struct super_block *sb);
 void __sb_end_write(struct super_block *sb, int level);
 int __sb_start_write(struct super_block *sb, int level, bool wait);
 
+#define __sb_acquire_write(sb, lev)	\
+	rwsem_acquire_read(&(sb)->s_writers.lock_map[(lev)-1], 0, 1, _THIS_IP_)
+#define __sb_release_write(sb, lev)	\
+	rwsem_release(&(sb)->s_writers.lock_map[(lev)-1], 1, _THIS_IP_)
+
 /**
  * sb_end_write - drop write access to a superblock
  * @sb: the super we wrote to