diff mbox

btrfs: remove unneeded NULL initializer for struct fs_path

Message ID 20150926120519.GA1629@gmail.com (mailing list archive)
State New, archived
Headers show

Commit Message

Alexandru Moise Sept. 26, 2015, 12:05 p.m. UTC
fs_path_alloc() either returns an alloc'ed struct fs_path
or NULL, no need to initialize the pointer to NULL.

Signed-off-by: Alexandru Moise <00moses.alexander00@gmail.com>
---
 fs/btrfs/send.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

David Sterba Sept. 29, 2015, 12:32 p.m. UTC | #1
On Sat, Sep 26, 2015 at 12:05:19PM +0000, Alexandru Moise wrote:
> fs_path_alloc() either returns an alloc'ed struct fs_path
> or NULL, no need to initialize the pointer to NULL.
> 
> Signed-off-by: Alexandru Moise <00moses.alexander00@gmail.com>
> ---
>  fs/btrfs/send.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/fs/btrfs/send.c b/fs/btrfs/send.c
> index aa72bfd..0019c90 100644
> --- a/fs/btrfs/send.c
> +++ b/fs/btrfs/send.c
> @@ -2230,7 +2230,7 @@ static int get_cur_path(struct send_ctx *sctx, u64 ino, u64 gen,
>  			struct fs_path *dest)
>  {
>  	int ret = 0;
> -	struct fs_path *name = NULL;
> +	struct fs_path *name;

I'd rather see all such instances fixed in one patch. Quick grep
revealed a few more. OTOH this kind of extra initialization is harmless
and sometimes help readability, it's clear that he value is zeroed.
--
To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Alexandru Moise Sept. 29, 2015, 7:33 p.m. UTC | #2
On Tue, Sep 29, 2015 at 02:32:29PM +0200, David Sterba wrote:
> On Sat, Sep 26, 2015 at 12:05:19PM +0000, Alexandru Moise wrote:
> > fs_path_alloc() either returns an alloc'ed struct fs_path
> > or NULL, no need to initialize the pointer to NULL.
> > 
> > Signed-off-by: Alexandru Moise <00moses.alexander00@gmail.com>
> > ---
> >  fs/btrfs/send.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/fs/btrfs/send.c b/fs/btrfs/send.c
> > index aa72bfd..0019c90 100644
> > --- a/fs/btrfs/send.c
> > +++ b/fs/btrfs/send.c
> > @@ -2230,7 +2230,7 @@ static int get_cur_path(struct send_ctx *sctx, u64 ino, u64 gen,
> >  			struct fs_path *dest)
> >  {
> >  	int ret = 0;
> > -	struct fs_path *name = NULL;
> > +	struct fs_path *name;
> 
> I'd rather see all such instances fixed in one patch. Quick grep
> revealed a few more. OTOH this kind of extra initialization is harmless
> and sometimes help readability, it's clear that he value is zeroed.

When you put it like that, you are right, it's more important to make
things obvious than to fiercely abide by all the subtleties of our
coding style. I submit to your point of view and will not insist on
this kind of change in the future.
--
To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/fs/btrfs/send.c b/fs/btrfs/send.c
index aa72bfd..0019c90 100644
--- a/fs/btrfs/send.c
+++ b/fs/btrfs/send.c
@@ -2230,7 +2230,7 @@  static int get_cur_path(struct send_ctx *sctx, u64 ino, u64 gen,
 			struct fs_path *dest)
 {
 	int ret = 0;
-	struct fs_path *name = NULL;
+	struct fs_path *name;
 	u64 parent_inode = 0;
 	u64 parent_gen = 0;
 	int stop = 0;