Message ID | 1447740351-14246-9-git-send-email-pankaj.dubey@samsung.com (mailing list archive) |
---|---|
State | Not Applicable, archived |
Headers | show |
On Tue, Nov 17, 2015 at 11:35 AM, Pankaj Dubey <pankaj.dubey@samsung.com> wrote: > This patch moves exynos_sys_powerdown_conf function above all > static functions, to avoid confusion causing due to mixing of > static-nonstatic-static functions and to improve readability of this > driver. > > Signed-off-by: Pankaj Dubey <pankaj.dubey@samsung.com> > Suggested-by: Krzysztof Kozlowski <k.kozlowski@samsung.com> > Reviewed-by: Krzysztof Kozlowski <k.kozlowski@samsung.com> > --- > arch/arm/mach-exynos/pmu.c | 34 +++++++++++++++++----------------- > 1 file changed, 17 insertions(+), 17 deletions(-) > > diff --git a/arch/arm/mach-exynos/pmu.c b/arch/arm/mach-exynos/pmu.c > index 01cb649..a7741d4 100644 > --- a/arch/arm/mach-exynos/pmu.c > +++ b/arch/arm/mach-exynos/pmu.c > @@ -39,23 +39,6 @@ u32 pmu_raw_readl(u32 offset) > return readl_relaxed(pmu_base_addr + offset); > } > > -static void exynos_power_off(void) > -{ > - unsigned int tmp; > - > - pr_info("Power down.\n"); > - tmp = pmu_raw_readl(EXYNOS_PS_HOLD_CONTROL); > - tmp ^= (1 << 8); > - pmu_raw_writel(tmp, EXYNOS_PS_HOLD_CONTROL); > - > - /* Wait a little so we don't give a false warning below */ > - mdelay(100); > - > - pr_err("Power down failed, please power off system manually.\n"); > - while (1) > - ; > -} > - > void exynos_sys_powerdown_conf(enum sys_powerdown mode) > { > unsigned int i; > @@ -85,6 +68,23 @@ void exynos_sys_powerdown_conf(enum sys_powerdown mode) > } > } > > +static void exynos_power_off(void) > +{ > + unsigned int tmp; > + > + pr_info("Power down.\n"); > + tmp = pmu_raw_readl(EXYNOS_PS_HOLD_CONTROL); > + tmp ^= (1 << 8); Can we have some define over here? to operate this bit. > + pmu_raw_writel(tmp, EXYNOS_PS_HOLD_CONTROL); > + > + /* Wait a little so we don't give a false warning below */ > + mdelay(100); > + > + pr_err("Power down failed, please power off system manually.\n"); > + while (1) > + ; > +} > + > static int pmu_restart_notify(struct notifier_block *this, > unsigned long code, void *unused) > { > -- > 2.4.5 > > -- > To unsubscribe from this list: send the line "unsubscribe linux-pm" in > the body of a message to majordomo@vger.kernel.org > More majordomo info at http://vger.kernel.org/majordomo-info.html -- To unsubscribe from this list: send the line "unsubscribe linux-pm" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On 20.11.2015 13:46, Manish Badarkhe wrote: > On Tue, Nov 17, 2015 at 11:35 AM, Pankaj Dubey <pankaj.dubey@samsung.com> wrote: >> This patch moves exynos_sys_powerdown_conf function above all >> static functions, to avoid confusion causing due to mixing of >> static-nonstatic-static functions and to improve readability of this >> driver. >> >> Signed-off-by: Pankaj Dubey <pankaj.dubey@samsung.com> >> Suggested-by: Krzysztof Kozlowski <k.kozlowski@samsung.com> >> Reviewed-by: Krzysztof Kozlowski <k.kozlowski@samsung.com> >> --- >> arch/arm/mach-exynos/pmu.c | 34 +++++++++++++++++----------------- >> 1 file changed, 17 insertions(+), 17 deletions(-) >> >> diff --git a/arch/arm/mach-exynos/pmu.c b/arch/arm/mach-exynos/pmu.c >> index 01cb649..a7741d4 100644 >> --- a/arch/arm/mach-exynos/pmu.c >> +++ b/arch/arm/mach-exynos/pmu.c >> @@ -39,23 +39,6 @@ u32 pmu_raw_readl(u32 offset) >> return readl_relaxed(pmu_base_addr + offset); >> } >> >> -static void exynos_power_off(void) >> -{ >> - unsigned int tmp; >> - >> - pr_info("Power down.\n"); >> - tmp = pmu_raw_readl(EXYNOS_PS_HOLD_CONTROL); >> - tmp ^= (1 << 8); >> - pmu_raw_writel(tmp, EXYNOS_PS_HOLD_CONTROL); >> - >> - /* Wait a little so we don't give a false warning below */ >> - mdelay(100); >> - >> - pr_err("Power down failed, please power off system manually.\n"); >> - while (1) >> - ; >> -} >> - >> void exynos_sys_powerdown_conf(enum sys_powerdown mode) >> { >> unsigned int i; >> @@ -85,6 +68,23 @@ void exynos_sys_powerdown_conf(enum sys_powerdown mode) >> } >> } >> >> +static void exynos_power_off(void) >> +{ >> + unsigned int tmp; >> + >> + pr_info("Power down.\n"); >> + tmp = pmu_raw_readl(EXYNOS_PS_HOLD_CONTROL); >> + tmp ^= (1 << 8); > Can we have some define over here? to operate this bit. > 1. This will be removed by syscon-reboot/poweroff patches [0]. 2. This patch is only rename/move. Fixing stuff should go to separate patches. But IMHO fixing is not needed because of 1. [0] http://www.spinics.net/lists/devicetree/msg98858.html Best regards, Krzysztof -- To unsubscribe from this list: send the line "unsubscribe linux-pm" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/arch/arm/mach-exynos/pmu.c b/arch/arm/mach-exynos/pmu.c index 01cb649..a7741d4 100644 --- a/arch/arm/mach-exynos/pmu.c +++ b/arch/arm/mach-exynos/pmu.c @@ -39,23 +39,6 @@ u32 pmu_raw_readl(u32 offset) return readl_relaxed(pmu_base_addr + offset); } -static void exynos_power_off(void) -{ - unsigned int tmp; - - pr_info("Power down.\n"); - tmp = pmu_raw_readl(EXYNOS_PS_HOLD_CONTROL); - tmp ^= (1 << 8); - pmu_raw_writel(tmp, EXYNOS_PS_HOLD_CONTROL); - - /* Wait a little so we don't give a false warning below */ - mdelay(100); - - pr_err("Power down failed, please power off system manually.\n"); - while (1) - ; -} - void exynos_sys_powerdown_conf(enum sys_powerdown mode) { unsigned int i; @@ -85,6 +68,23 @@ void exynos_sys_powerdown_conf(enum sys_powerdown mode) } } +static void exynos_power_off(void) +{ + unsigned int tmp; + + pr_info("Power down.\n"); + tmp = pmu_raw_readl(EXYNOS_PS_HOLD_CONTROL); + tmp ^= (1 << 8); + pmu_raw_writel(tmp, EXYNOS_PS_HOLD_CONTROL); + + /* Wait a little so we don't give a false warning below */ + mdelay(100); + + pr_err("Power down failed, please power off system manually.\n"); + while (1) + ; +} + static int pmu_restart_notify(struct notifier_block *this, unsigned long code, void *unused) {