diff mbox

Replace '-' in kernel version with '_'

Message ID 20110503214543.GA25962@dev1756.snc6.facebook.com (mailing list archive)
State New, archived
Headers show

Commit Message

Arun Sharma May 3, 2011, 9:45 p.m. UTC
Removing the '-' results in hard to read filenames such as:
kernel-2.6.35.2000042g76e4caf-28.x86_64.rpm

kernel-2.6.35.2_000042_g76e4caf-28.x86_64.rpm is easier to
read.

Comments

Michal Marek May 4, 2011, 8:45 p.m. UTC | #1
On Tue, May 03, 2011 at 02:45:43PM -0700, Arun Sharma wrote:
> Removing the '-' results in hard to read filenames such as:
> kernel-2.6.35.2000042g76e4caf-28.x86_64.rpm
> 
> kernel-2.6.35.2_000042_g76e4caf-28.x86_64.rpm is easier to
> read.

This makes sense, but please sign off the patch as per
Documentation/SubmittingPatches.

Thanks,
Michal
--
To unsubscribe from this list: send the line "unsubscribe linux-kbuild" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/scripts/package/Makefile b/scripts/package/Makefile
index d0b931b..30b437f 100644
--- a/scripts/package/Makefile
+++ b/scripts/package/Makefile
@@ -26,7 +26,7 @@  RPM := $(shell if [ -x "/usr/bin/rpmbuild" ]; then echo rpmbuild; \
 	           else echo rpm; fi)
 
 # Remove hyphens since they have special meaning in RPM filenames
-KERNELPATH := kernel-$(subst -,,$(KERNELRELEASE))
+KERNELPATH := kernel-$(subst -,_,$(KERNELRELEASE))
 MKSPEC     := $(srctree)/scripts/package/mkspec
 PREV       := set -e; cd ..;
 
diff --git a/scripts/package/mkspec b/scripts/package/mkspec
index 65845b4..309a275 100755
--- a/scripts/package/mkspec
+++ b/scripts/package/mkspec
@@ -22,7 +22,7 @@  if [ "`grep CONFIG_DRM=y .config | cut -f2 -d\=`" = "y" ]; then
 fi
 
 PROVIDES="$PROVIDES kernel-$KERNELRELEASE"
-__KERNELRELEASE=`echo $KERNELRELEASE | sed -e "s/-//g"`
+__KERNELRELEASE=`echo $KERNELRELEASE | sed -e "s/-/_/g"`
 
 echo "Name: kernel"
 echo "Summary: The Linux Kernel"