Message ID | 1460768127-31822-10-git-send-email-viro@ZenIV.linux.org.uk (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Sat, 2016-04-16 at 01:55 +0100, Al Viro wrote: > From: Al Viro <viro@zeniv.linux.org.uk> > > Signed-off-by: Al Viro <viro@zeniv.linux.org.uk> > --- > fs/dcache.c | 14 +++++++++++--- > 1 file changed, 11 insertions(+), 3 deletions(-) > > diff --git a/fs/dcache.c b/fs/dcache.c > index e9de4d9..33cad8a 100644 > --- a/fs/dcache.c > +++ b/fs/dcache.c > @@ -2363,11 +2363,19 @@ EXPORT_SYMBOL(d_rehash); > > static inline void __d_add(struct dentry *dentry, struct inode *inode) > { > + spin_lock(&dentry->d_lock); > if (inode) { > - __d_instantiate(dentry, inode); > + unsigned add_flags = d_flags_for_inode(inode); > + hlist_add_head(&dentry->d_u.d_alias, &inode->i_dentry); > + raw_write_seqcount_begin(&dentry->d_seq); > + __d_set_inode_and_type(dentry, inode, add_flags); > + raw_write_seqcount_end(&dentry->d_seq); > + __fsnotify_d_instantiate(dentry); Should the above be a new __d_instantiate_locked instead of open-coding it? > + } > + _d_rehash(dentry); > + spin_unlock(&dentry->d_lock); > + if (inode) > spin_unlock(&inode->i_lock); > - } > - d_rehash(dentry); > } > > /**
On Sun, Apr 24, 2016 at 02:09:09PM -0400, Jeff Layton wrote: > Should the above be a new __d_instantiate_locked instead of open-coding > it? Nope - it gets rehash mashed into it a few commits later. In principle we could try to fish the common helper out of it and __d_instantiate() once the dust settles, but IMO there's not much point. -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/fs/dcache.c b/fs/dcache.c index e9de4d9..33cad8a 100644 --- a/fs/dcache.c +++ b/fs/dcache.c @@ -2363,11 +2363,19 @@ EXPORT_SYMBOL(d_rehash); static inline void __d_add(struct dentry *dentry, struct inode *inode) { + spin_lock(&dentry->d_lock); if (inode) { - __d_instantiate(dentry, inode); + unsigned add_flags = d_flags_for_inode(inode); + hlist_add_head(&dentry->d_u.d_alias, &inode->i_dentry); + raw_write_seqcount_begin(&dentry->d_seq); + __d_set_inode_and_type(dentry, inode, add_flags); + raw_write_seqcount_end(&dentry->d_seq); + __fsnotify_d_instantiate(dentry); + } + _d_rehash(dentry); + spin_unlock(&dentry->d_lock); + if (inode) spin_unlock(&inode->i_lock); - } - d_rehash(dentry); } /**