Message ID | 1467732272-23368-12-git-send-email-clord@redhat.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On 05.07.2016 17:24, Colin Lord wrote: > Isolate qed probe as part of the modularization process. > > Signed-off-by: Colin Lord <clord@redhat.com> > --- > block/Makefile.objs | 2 +- > block/probe/qed.c | 18 ++++++++++++++++++ > block/qed.c | 15 +-------------- > include/block/probe.h | 1 + > 4 files changed, 21 insertions(+), 15 deletions(-) > create mode 100644 block/probe/qed.c Reviewed-by: Max Reitz <mreitz@redhat.com> > diff --git a/include/block/probe.h b/include/block/probe.h > index f9dd36e..e3e9934 100644 > --- a/include/block/probe.h > +++ b/include/block/probe.h > @@ -9,5 +9,6 @@ int dmg_probe(const uint8_t *buf, int buf_size, const char *filename); > int parallels_probe(const uint8_t *buf, int buf_size, const char *filename); > int qcow_probe(const uint8_t *buf, int buf_size, const char *filename); > int qcow2_probe(const uint8_t *buf, int buf_size, const char *filename); > +int bdrv_qed_probe(const uint8_t *buf, int buf_size, const char *filename); Hmmm, maybe it would make sense to follow a consistent naming scheme here, i.e. either ${format}_probe() or bdrv_${format}_probe(). The latter is probably better, but the former is what most formats do, so... But maybe that is something that should be done in the "Separate X probe from its driver" patches. Max > > #endif >
diff --git a/block/Makefile.objs b/block/Makefile.objs index 23240d9..6ed2689 100644 --- a/block/Makefile.objs +++ b/block/Makefile.objs @@ -25,7 +25,7 @@ block-obj-y += write-threshold.o block-obj-y += crypto.o block-obj-y += probe/bochs.o probe/cloop.o probe/luks.o probe/dmg.o -block-obj-y += probe/parallels.o probe/qcow.o probe/qcow2.o +block-obj-y += probe/parallels.o probe/qcow.o probe/qcow2.o probe/qed.o common-obj-y += stream.o common-obj-y += commit.o diff --git a/block/probe/qed.c b/block/probe/qed.c new file mode 100644 index 0000000..c902489 --- /dev/null +++ b/block/probe/qed.c @@ -0,0 +1,18 @@ +#include "qemu/osdep.h" +#include "block/block_int.h" +#include "block/probe.h" +#include "block/qed.h" + +int bdrv_qed_probe(const uint8_t *buf, int buf_size, + const char *filename) +{ + const QEDHeader *header = (const QEDHeader *)buf; + + if (buf_size < sizeof(*header)) { + return 0; + } + if (le32_to_cpu(header->magic) != QED_MAGIC) { + return 0; + } + return 100; +} diff --git a/block/qed.c b/block/qed.c index 1206806..21d8982 100644 --- a/block/qed.c +++ b/block/qed.c @@ -16,6 +16,7 @@ #include "qapi/error.h" #include "qemu/timer.h" #include "qemu/bswap.h" +#include "block/probe.h" #include "trace.h" #include "qed.h" #include "qapi/qmp/qerror.h" @@ -26,20 +27,6 @@ static const AIOCBInfo qed_aiocb_info = { .aiocb_size = sizeof(QEDAIOCB), }; -static int bdrv_qed_probe(const uint8_t *buf, int buf_size, - const char *filename) -{ - const QEDHeader *header = (const QEDHeader *)buf; - - if (buf_size < sizeof(*header)) { - return 0; - } - if (le32_to_cpu(header->magic) != QED_MAGIC) { - return 0; - } - return 100; -} - /** * Check whether an image format is raw * diff --git a/include/block/probe.h b/include/block/probe.h index f9dd36e..e3e9934 100644 --- a/include/block/probe.h +++ b/include/block/probe.h @@ -9,5 +9,6 @@ int dmg_probe(const uint8_t *buf, int buf_size, const char *filename); int parallels_probe(const uint8_t *buf, int buf_size, const char *filename); int qcow_probe(const uint8_t *buf, int buf_size, const char *filename); int qcow2_probe(const uint8_t *buf, int buf_size, const char *filename); +int bdrv_qed_probe(const uint8_t *buf, int buf_size, const char *filename); #endif
Isolate qed probe as part of the modularization process. Signed-off-by: Colin Lord <clord@redhat.com> --- block/Makefile.objs | 2 +- block/probe/qed.c | 18 ++++++++++++++++++ block/qed.c | 15 +-------------- include/block/probe.h | 1 + 4 files changed, 21 insertions(+), 15 deletions(-) create mode 100644 block/probe/qed.c