diff mbox

[1/2] block: fix obvious coding style mitakes in block_int.h

Message ID 1491405505-31620-2-git-send-email-den@openvz.org (mailing list archive)
State New, archived
Headers show

Commit Message

Denis V. Lunev April 5, 2017, 3:18 p.m. UTC
From: Klim Kireev <proffk@virtuozzo.mipt.ru>

Signed-off-by: Klim Kireev <proffk@virtuozzo.mipt.ru>
Signed-off-by: Denis V. Lunev <den@openvz.org>
CC: Kevin Wolf <kwolf@redhat.com>
CC: Max Reitz <mreitz@redhat.com>
---
 include/block/block_int.h | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Eric Blake April 5, 2017, 3:35 p.m. UTC | #1
On 04/05/2017 10:18 AM, Denis V. Lunev wrote:
> From: Klim Kireev <proffk@virtuozzo.mipt.ru>

s/mitakes/mistakes/ in the subject

A blank commit message body doesn't help - the subject says what was
changed but not why (for example, output of checkpatch.pl without the
patch applied); and details may help in grepping past history when
looking for the change or even to justify that the change is not just churn.

> 
> Signed-off-by: Klim Kireev <proffk@virtuozzo.mipt.ru>
> Signed-off-by: Denis V. Lunev <den@openvz.org>
> CC: Kevin Wolf <kwolf@redhat.com>
> CC: Max Reitz <mreitz@redhat.com>
> ---
>  include/block/block_int.h | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 

At any rate, all of the changes (the fact that we prefer binding the
pointer operator * to the name on the right rather than the type on the
left) look sane.
Reviewed-by: Eric Blake <eblake@redhat.com>
Max Reitz April 13, 2017, 7:01 p.m. UTC | #2
On 05.04.2017 17:35, Eric Blake wrote:
> On 04/05/2017 10:18 AM, Denis V. Lunev wrote:
>> From: Klim Kireev <proffk@virtuozzo.mipt.ru>
> 
> s/mitakes/mistakes/ in the subject
> 
> A blank commit message body doesn't help - the subject says what was
> changed but not why (for example, output of checkpatch.pl without the
> patch applied); and details may help in grepping past history when
> looking for the change or even to justify that the change is not just churn.
> 
>>
>> Signed-off-by: Klim Kireev <proffk@virtuozzo.mipt.ru>
>> Signed-off-by: Denis V. Lunev <den@openvz.org>
>> CC: Kevin Wolf <kwolf@redhat.com>
>> CC: Max Reitz <mreitz@redhat.com>
>> ---
>>  include/block/block_int.h | 6 +++---
>>  1 file changed, 3 insertions(+), 3 deletions(-)
>>
> 
> At any rate, all of the changes (the fact that we prefer binding the
> pointer operator * to the name on the right rather than the type on the
> left) look sane.

I know someone who disagrees but that someone also knows that I will
support and accept this kind of patches gladly. O:-)

Max

> Reviewed-by: Eric Blake <eblake@redhat.com>
diff mbox

Patch

diff --git a/include/block/block_int.h b/include/block/block_int.h
index 59400bd..bf18c5f 100644
--- a/include/block/block_int.h
+++ b/include/block/block_int.h
@@ -252,7 +252,7 @@  struct BlockDriver {
      * Returns 0 for completed check, -errno for internal errors.
      * The check results are stored in result.
      */
-    int (*bdrv_check)(BlockDriverState* bs, BdrvCheckResult *result,
+    int (*bdrv_check)(BlockDriverState *bs, BdrvCheckResult *result,
         BdrvCheckMode fix);
 
     int (*bdrv_amend_options)(BlockDriverState *bs, QemuOpts *opts,
@@ -454,13 +454,13 @@  struct BdrvChildRole {
     /* Returns a name that is supposedly more useful for human users than the
      * node name for identifying the node in question (in particular, a BB
      * name), or NULL if the parent can't provide a better name. */
-    const char* (*get_name)(BdrvChild *child);
+    const char *(*get_name)(BdrvChild *child);
 
     /* Returns a malloced string that describes the parent of the child for a
      * human reader. This could be a node-name, BlockBackend name, qdev ID or
      * QOM path of the device owning the BlockBackend, job type and ID etc. The
      * caller is responsible for freeing the memory. */
-    char* (*get_parent_desc)(BdrvChild *child);
+    char *(*get_parent_desc)(BdrvChild *child);
 
     /*
      * If this pair of functions is implemented, the parent doesn't issue new