Message ID | 20170725115759.21895-22-anthony.perard@citrix.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Anthony PERARD writes ("[OSSTEST PATCH v13 21/24] Create a flight to test OpenStack with xen-unstable and libvirt"): > This patch creates a flight "openstack*", with those jobs: Do you mean it creates a "branch" ? But I don't think it does. I predict no changes to the output of mg-list-all-branches. You probably want to edit cr-for-branches. > build-amd64 > build-amd64-libvirt > build-amd64-pvops > build-amd64-xsm > build-arm64 > build-arm64-libvirt > build-arm64-pvops > build-arm64-xsm > build-armhf > build-armhf-libvirt > build-armhf-pvops > build-armhf-xsm > test-amd64-amd64-devstack > test-amd64-amd64-devstack-xsm > test-arm64-arm64-devstack > test-arm64-arm64-devstack-xsm > test-armhf-armhf-devstack > test-armhf-armhf-devstack-xsm Does it add these jobs to existing flights ? I think it probably does. Is that intentional ? I think it probably isn't. If it is you should explain it in the commit message - and also explain why this is OK despite you not keeping tested versions of all the input branches (ie, risking uncontrolled regressions in openstack components breaking the xen pushes...) You can see what it does with standalone-dump-all-flight-runvars (which is best run with eatmydata). Ian.
On Tue, Jul 25, 2017 at 07:09:06PM +0100, Ian Jackson wrote: > Anthony PERARD writes ("[OSSTEST PATCH v13 21/24] Create a flight to test OpenStack with xen-unstable and libvirt"): > > This patch creates a flight "openstack*", with those jobs: > > Do you mean it creates a "branch" ? But I don't think it does. I > predict no changes to the output of mg-list-all-branches. You > probably want to edit cr-for-branches. Maybe branch is the right word, but this patch does not change anything anymore. I've try to split changes in "make-fligh" from the on in ap-* and cr-*, but the description is just not clear enough. > > build-amd64 > > build-amd64-libvirt > > build-amd64-pvops > > build-amd64-xsm > > build-arm64 > > build-arm64-libvirt > > build-arm64-pvops > > build-arm64-xsm > > build-armhf > > build-armhf-libvirt > > build-armhf-pvops > > build-armhf-xsm > > test-amd64-amd64-devstack > > test-amd64-amd64-devstack-xsm > > test-arm64-arm64-devstack > > test-arm64-arm64-devstack-xsm > > test-armhf-armhf-devstack > > test-armhf-armhf-devstack-xsm > > Does it add these jobs to existing flights ? I think it probably > does. Is that intentional ? I think it probably isn't. If it is you > should explain it in the commit message - and also explain why this is > OK despite you not keeping tested versions of all the input branches > (ie, risking uncontrolled regressions in openstack components breaking > the xen pushes...) Last time I've check, by testing this patch with the next one, those jobs where only part of a branch names "openstack-ocata" and did not change anything else.
Anthony PERARD writes ("Re: [OSSTEST PATCH v13 21/24] Create a flight to test OpenStack with xen-unstable and libvirt"): > On Tue, Jul 25, 2017 at 07:09:06PM +0100, Ian Jackson wrote: > > Anthony PERARD writes ("[OSSTEST PATCH v13 21/24] Create a flight to test OpenStack with xen-unstable and libvirt"): > > > This patch creates a flight "openstack*", with those jobs: > > > > Do you mean it creates a "branch" ? But I don't think it does. I > > predict no changes to the output of mg-list-all-branches. You > > probably want to edit cr-for-branches. > > Maybe branch is the right word, but this patch does not change anything > anymore. I've try to split changes in "make-fligh" from the on in ap-* > and cr-*, but the description is just not clear enough. Maybe Subject: Create devstack jobs (on openstack branches only) blah blah blah The new jobs appear only in the branches openstack-*, which will be introduced in the next patch. So, for now, no overall functional change. ? > Last time I've check, by testing this patch with the next one, those > jobs where only part of a branch names "openstack-ocata" and did not > change anything else. Oh, good. You might mention having done this check, in the commit message. That would save me from being confused, at least. Ian.
diff --git a/make-flight b/make-flight index db124fe..e03aacc 100755 --- a/make-flight +++ b/make-flight @@ -183,6 +183,16 @@ job_create_test_filter_callback () { *) return 1;; esac ;; + openstack*) + case "$job" in + *-devstack) ;; + *-devstack-xsm) ;; + *) return 1;; + esac + case $dom0arch in + i386) return 1 ;; + esac + ;; *) case "$job" in *-qemuu-*) @@ -216,7 +226,13 @@ arch_branch_filter_callback () { ovmf) return 1;; esac ;; - i386|amd64) + i386) + case "$branch" in + linux-arm-xen) return 1;; + openstack*) return 1;; + esac + ;; + amd64) case "$branch" in linux-arm-xen) return 1;; esac @@ -680,6 +696,33 @@ do_examine_one () { all_hostflags=$most_hostflags } +do_openstack_tests () { + local xsms=$(xenbranch_xsm_variants) + local openstack_trees=(cinder devstack glance keystone neutron nova + requirements tempest) + + case "$branch" in + openstack*) ;; + *) return ;; + esac + + local openstack_runvars="" + for tree in "${openstack_trees[@]}"; do + tree="openstack_$tree" + eval "openstack_runvars+=\" tree_$tree=\${TREE_${tree^^}}\"" + eval "openstack_runvars+=\" revision_$tree=\${REVISION_${tree^^}}\"" + done + + for xsm in $xsms ; do + job_create_test test-$xenarch$kern-$dom0arch-devstack \ + test-devstack libvirt $xenarch $dom0arch \ + $openstack_runvars \ + dom0_mem=4000 \ + enable_xsm=$xsm \ + all_hostflags=$most_hostflags + done +} + test_matrix_do_one () { do_pv_debian_tests @@ -700,6 +743,7 @@ test_matrix_do_one () { do_rtds_tests do_credit2_tests + do_openstack_tests do_examine_one
This patch creates a flight "openstack*", with those jobs: build-amd64 build-amd64-libvirt build-amd64-pvops build-amd64-xsm build-arm64 build-arm64-libvirt build-arm64-pvops build-arm64-xsm build-armhf build-armhf-libvirt build-armhf-pvops build-armhf-xsm test-amd64-amd64-devstack test-amd64-amd64-devstack-xsm test-arm64-arm64-devstack test-arm64-arm64-devstack-xsm test-armhf-armhf-devstack test-armhf-armhf-devstack-xsm This would be a flight to test a stable release of OpenStack against Xen. Signed-off-by: Anthony PERARD <anthony.perard@citrix.com> --- Notes: Changes in V13: - split changes in ap-* and cr-* into a different patch - rename os_* to openstack_* - rename target_cmd_subunit to target_subunit_cmd make-flight | 46 +++++++++++++++++++++++++++++++++++++++++++++- 1 file changed, 45 insertions(+), 1 deletion(-)