diff mbox

[2/3] xfs: rename xfs_defer_join to xfs_defer_join_inode

Message ID 20170813144216.11192-3-hch@lst.de (mailing list archive)
State New, archived
Headers show

Commit Message

Christoph Hellwig Aug. 13, 2017, 2:42 p.m. UTC
Signed-off-by: Christoph Hellwig <hch@lst.de>
---
 fs/xfs/libxfs/xfs_bmap.c  | 2 +-
 fs/xfs/libxfs/xfs_defer.c | 4 ++--
 fs/xfs/libxfs/xfs_defer.h | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)

Comments

Dave Chinner Aug. 15, 2017, 1:37 a.m. UTC | #1
On Sun, Aug 13, 2017 at 04:42:15PM +0200, Christoph Hellwig wrote:
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
>  fs/xfs/libxfs/xfs_bmap.c  | 2 +-
>  fs/xfs/libxfs/xfs_defer.c | 4 ++--
>  fs/xfs/libxfs/xfs_defer.h | 2 +-
>  3 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/fs/xfs/libxfs/xfs_bmap.c b/fs/xfs/libxfs/xfs_bmap.c
> index c09c16b1ad3b..24eba36ef818 100644
> --- a/fs/xfs/libxfs/xfs_bmap.c
> +++ b/fs/xfs/libxfs/xfs_bmap.c
> @@ -6452,7 +6452,7 @@ __xfs_bmap_add(
>  	bi->bi_whichfork = whichfork;
>  	bi->bi_bmap = *bmap;
>  
> -	error = xfs_defer_join(dfops, bi->bi_owner);
> +	error = xfs_defer_join_inode(dfops, bi->bi_owner);
>  	if (error) {
>  		kmem_free(bi);
>  		return error;
> diff --git a/fs/xfs/libxfs/xfs_defer.c b/fs/xfs/libxfs/xfs_defer.c
> index 87169bf56a09..043844f00f6e 100644
> --- a/fs/xfs/libxfs/xfs_defer.c
> +++ b/fs/xfs/libxfs/xfs_defer.c
> @@ -281,7 +281,7 @@ xfs_defer_has_unfinished_work(
>   * to xfs_defer_finish().
>   */
>  int
> -xfs_defer_join(
> +xfs_defer_join_inode(
>  	struct xfs_defer_ops		*dop,
>  	struct xfs_inode		*ip)
>  {
> @@ -324,7 +324,7 @@ xfs_defer_finish(
>  
>  	trace_xfs_defer_finish((*tp)->t_mountp, dop);
>  
> -	xfs_defer_join(dop, ip);
> +	xfs_defer_join_inode(dop, ip);
>  
>  	/* Until we run out of pending work to finish... */
>  	while (xfs_defer_has_unfinished_work(dop)) {
> diff --git a/fs/xfs/libxfs/xfs_defer.h b/fs/xfs/libxfs/xfs_defer.h
> index f6e93ef0bffe..4632c798ea2b 100644
> --- a/fs/xfs/libxfs/xfs_defer.h
> +++ b/fs/xfs/libxfs/xfs_defer.h
> @@ -77,7 +77,7 @@ int xfs_defer_finish(struct xfs_trans **tp, struct xfs_defer_ops *dop,
>  void xfs_defer_cancel(struct xfs_defer_ops *dop);
>  void xfs_defer_init(struct xfs_defer_ops *dop, xfs_fsblock_t *fbp);
>  bool xfs_defer_has_unfinished_work(struct xfs_defer_ops *dop);
> -int xfs_defer_join(struct xfs_defer_ops *dop, struct xfs_inode *ip);
> +int xfs_defer_join_inode(struct xfs_defer_ops *dop, struct xfs_inode *ip);

Looks good.

Reviewed-by: Dave Chinner <dchinner@redhat.com>
Darrick J. Wong Aug. 16, 2017, 5:21 p.m. UTC | #2
On Sun, Aug 13, 2017 at 04:42:15PM +0200, Christoph Hellwig wrote:
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
>  fs/xfs/libxfs/xfs_bmap.c  | 2 +-
>  fs/xfs/libxfs/xfs_defer.c | 4 ++--
>  fs/xfs/libxfs/xfs_defer.h | 2 +-
>  3 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/fs/xfs/libxfs/xfs_bmap.c b/fs/xfs/libxfs/xfs_bmap.c
> index c09c16b1ad3b..24eba36ef818 100644
> --- a/fs/xfs/libxfs/xfs_bmap.c
> +++ b/fs/xfs/libxfs/xfs_bmap.c
> @@ -6452,7 +6452,7 @@ __xfs_bmap_add(
>  	bi->bi_whichfork = whichfork;
>  	bi->bi_bmap = *bmap;
>  
> -	error = xfs_defer_join(dfops, bi->bi_owner);
> +	error = xfs_defer_join_inode(dfops, bi->bi_owner);

/me wonders if this should be named xfs_defer_ijoin to be more
consistent with xfs_trans_ijoin, or if we should rename the other one to
xfs_trans_join_inode instead?

Other than that,
Reviewed-by: Darrick J. Wong <darrick.wong@oracle.com>

--D

>  	if (error) {
>  		kmem_free(bi);
>  		return error;
> diff --git a/fs/xfs/libxfs/xfs_defer.c b/fs/xfs/libxfs/xfs_defer.c
> index 87169bf56a09..043844f00f6e 100644
> --- a/fs/xfs/libxfs/xfs_defer.c
> +++ b/fs/xfs/libxfs/xfs_defer.c
> @@ -281,7 +281,7 @@ xfs_defer_has_unfinished_work(
>   * to xfs_defer_finish().
>   */
>  int
> -xfs_defer_join(
> +xfs_defer_join_inode(
>  	struct xfs_defer_ops		*dop,
>  	struct xfs_inode		*ip)
>  {
> @@ -324,7 +324,7 @@ xfs_defer_finish(
>  
>  	trace_xfs_defer_finish((*tp)->t_mountp, dop);
>  
> -	xfs_defer_join(dop, ip);
> +	xfs_defer_join_inode(dop, ip);
>  
>  	/* Until we run out of pending work to finish... */
>  	while (xfs_defer_has_unfinished_work(dop)) {
> diff --git a/fs/xfs/libxfs/xfs_defer.h b/fs/xfs/libxfs/xfs_defer.h
> index f6e93ef0bffe..4632c798ea2b 100644
> --- a/fs/xfs/libxfs/xfs_defer.h
> +++ b/fs/xfs/libxfs/xfs_defer.h
> @@ -77,7 +77,7 @@ int xfs_defer_finish(struct xfs_trans **tp, struct xfs_defer_ops *dop,
>  void xfs_defer_cancel(struct xfs_defer_ops *dop);
>  void xfs_defer_init(struct xfs_defer_ops *dop, xfs_fsblock_t *fbp);
>  bool xfs_defer_has_unfinished_work(struct xfs_defer_ops *dop);
> -int xfs_defer_join(struct xfs_defer_ops *dop, struct xfs_inode *ip);
> +int xfs_defer_join_inode(struct xfs_defer_ops *dop, struct xfs_inode *ip);
>  
>  /* Description of a deferred type. */
>  struct xfs_defer_op_type {
> -- 
> 2.11.0
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-xfs" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe linux-xfs" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Christoph Hellwig Aug. 17, 2017, 7:44 a.m. UTC | #3
On Wed, Aug 16, 2017 at 10:21:30AM -0700, Darrick J. Wong wrote:
> On Sun, Aug 13, 2017 at 04:42:15PM +0200, Christoph Hellwig wrote:
> > Signed-off-by: Christoph Hellwig <hch@lst.de>
> > ---
> >  fs/xfs/libxfs/xfs_bmap.c  | 2 +-
> >  fs/xfs/libxfs/xfs_defer.c | 4 ++--
> >  fs/xfs/libxfs/xfs_defer.h | 2 +-
> >  3 files changed, 4 insertions(+), 4 deletions(-)
> > 
> > diff --git a/fs/xfs/libxfs/xfs_bmap.c b/fs/xfs/libxfs/xfs_bmap.c
> > index c09c16b1ad3b..24eba36ef818 100644
> > --- a/fs/xfs/libxfs/xfs_bmap.c
> > +++ b/fs/xfs/libxfs/xfs_bmap.c
> > @@ -6452,7 +6452,7 @@ __xfs_bmap_add(
> >  	bi->bi_whichfork = whichfork;
> >  	bi->bi_bmap = *bmap;
> >  
> > -	error = xfs_defer_join(dfops, bi->bi_owner);
> > +	error = xfs_defer_join_inode(dfops, bi->bi_owner);
> 
> /me wonders if this should be named xfs_defer_ijoin to be more
> consistent with xfs_trans_ijoin, or if we should rename the other one to
> xfs_trans_join_inode instead?

Sure.  I'll resend with the __ prefix removed from __xfs_trans_roll
and this renamed to _ijoin.

Should I also rename xfs_trans_roll_inode to xfs_trans_roll_ijoin?
--
To unsubscribe from this list: send the line "unsubscribe linux-xfs" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Darrick J. Wong Aug. 17, 2017, 4:22 p.m. UTC | #4
On Thu, Aug 17, 2017 at 09:44:22AM +0200, Christoph Hellwig wrote:
> On Wed, Aug 16, 2017 at 10:21:30AM -0700, Darrick J. Wong wrote:
> > On Sun, Aug 13, 2017 at 04:42:15PM +0200, Christoph Hellwig wrote:
> > > Signed-off-by: Christoph Hellwig <hch@lst.de>
> > > ---
> > >  fs/xfs/libxfs/xfs_bmap.c  | 2 +-
> > >  fs/xfs/libxfs/xfs_defer.c | 4 ++--
> > >  fs/xfs/libxfs/xfs_defer.h | 2 +-
> > >  3 files changed, 4 insertions(+), 4 deletions(-)
> > > 
> > > diff --git a/fs/xfs/libxfs/xfs_bmap.c b/fs/xfs/libxfs/xfs_bmap.c
> > > index c09c16b1ad3b..24eba36ef818 100644
> > > --- a/fs/xfs/libxfs/xfs_bmap.c
> > > +++ b/fs/xfs/libxfs/xfs_bmap.c
> > > @@ -6452,7 +6452,7 @@ __xfs_bmap_add(
> > >  	bi->bi_whichfork = whichfork;
> > >  	bi->bi_bmap = *bmap;
> > >  
> > > -	error = xfs_defer_join(dfops, bi->bi_owner);
> > > +	error = xfs_defer_join_inode(dfops, bi->bi_owner);
> > 
> > /me wonders if this should be named xfs_defer_ijoin to be more
> > consistent with xfs_trans_ijoin, or if we should rename the other one to
> > xfs_trans_join_inode instead?
> 
> Sure.  I'll resend with the __ prefix removed from __xfs_trans_roll
> and this renamed to _ijoin.
> 
> Should I also rename xfs_trans_roll_inode to xfs_trans_roll_ijoin?

Ok.

--D

> --
> To unsubscribe from this list: send the line "unsubscribe linux-xfs" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe linux-xfs" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/fs/xfs/libxfs/xfs_bmap.c b/fs/xfs/libxfs/xfs_bmap.c
index c09c16b1ad3b..24eba36ef818 100644
--- a/fs/xfs/libxfs/xfs_bmap.c
+++ b/fs/xfs/libxfs/xfs_bmap.c
@@ -6452,7 +6452,7 @@  __xfs_bmap_add(
 	bi->bi_whichfork = whichfork;
 	bi->bi_bmap = *bmap;
 
-	error = xfs_defer_join(dfops, bi->bi_owner);
+	error = xfs_defer_join_inode(dfops, bi->bi_owner);
 	if (error) {
 		kmem_free(bi);
 		return error;
diff --git a/fs/xfs/libxfs/xfs_defer.c b/fs/xfs/libxfs/xfs_defer.c
index 87169bf56a09..043844f00f6e 100644
--- a/fs/xfs/libxfs/xfs_defer.c
+++ b/fs/xfs/libxfs/xfs_defer.c
@@ -281,7 +281,7 @@  xfs_defer_has_unfinished_work(
  * to xfs_defer_finish().
  */
 int
-xfs_defer_join(
+xfs_defer_join_inode(
 	struct xfs_defer_ops		*dop,
 	struct xfs_inode		*ip)
 {
@@ -324,7 +324,7 @@  xfs_defer_finish(
 
 	trace_xfs_defer_finish((*tp)->t_mountp, dop);
 
-	xfs_defer_join(dop, ip);
+	xfs_defer_join_inode(dop, ip);
 
 	/* Until we run out of pending work to finish... */
 	while (xfs_defer_has_unfinished_work(dop)) {
diff --git a/fs/xfs/libxfs/xfs_defer.h b/fs/xfs/libxfs/xfs_defer.h
index f6e93ef0bffe..4632c798ea2b 100644
--- a/fs/xfs/libxfs/xfs_defer.h
+++ b/fs/xfs/libxfs/xfs_defer.h
@@ -77,7 +77,7 @@  int xfs_defer_finish(struct xfs_trans **tp, struct xfs_defer_ops *dop,
 void xfs_defer_cancel(struct xfs_defer_ops *dop);
 void xfs_defer_init(struct xfs_defer_ops *dop, xfs_fsblock_t *fbp);
 bool xfs_defer_has_unfinished_work(struct xfs_defer_ops *dop);
-int xfs_defer_join(struct xfs_defer_ops *dop, struct xfs_inode *ip);
+int xfs_defer_join_inode(struct xfs_defer_ops *dop, struct xfs_inode *ip);
 
 /* Description of a deferred type. */
 struct xfs_defer_op_type {