Message ID | 1519315332-26852-2-git-send-email-poza@codeaurora.org (mailing list archive) |
---|---|
State | New, archived |
Delegated to: | Bjorn Helgaas |
Headers | show |
On Thu, Feb 22, 2018 at 09:32:06PM +0530, Oza Pawandeep wrote: > This patch renames error recovery to generic name with pci prefix > > Signed-off-by: Oza Pawandeep <poza@codeaurora.org> > > diff --git a/drivers/pci/pcie/aer/aerdrv_core.c b/drivers/pci/pcie/aer/aerdrv_core.c > index a4bfea5..306bf2f 100644 > --- a/drivers/pci/pcie/aer/aerdrv_core.c > +++ b/drivers/pci/pcie/aer/aerdrv_core.c > @@ -478,7 +478,7 @@ static pci_ers_result_t reset_link(struct pci_dev *dev) > } > > /** > - * do_recovery - handle nonfatal/fatal error recovery process > + * pci_do_recovery - handle nonfatal/fatal error recovery process > * @dev: pointer to a pci_dev data structure of agent detecting an error > * @severity: error severity type > * > @@ -486,7 +486,7 @@ static pci_ers_result_t reset_link(struct pci_dev *dev) > * error detected message to all downstream drivers within a hierarchy in > * question and return the returned code. > */ > -static void do_recovery(struct pci_dev *dev, int severity) > +static void pci_do_recovery(struct pci_dev *dev, int severity) Maybe pcie_do_recovery? Otherwise looks fine: Reviewed-by: Christoph Hellwig <hch@lst.de>
On 2018-02-23 00:04, Christoph Hellwig wrote: > On Thu, Feb 22, 2018 at 09:32:06PM +0530, Oza Pawandeep wrote: >> This patch renames error recovery to generic name with pci prefix >> >> Signed-off-by: Oza Pawandeep <poza@codeaurora.org> >> >> diff --git a/drivers/pci/pcie/aer/aerdrv_core.c >> b/drivers/pci/pcie/aer/aerdrv_core.c >> index a4bfea5..306bf2f 100644 >> --- a/drivers/pci/pcie/aer/aerdrv_core.c >> +++ b/drivers/pci/pcie/aer/aerdrv_core.c >> @@ -478,7 +478,7 @@ static pci_ers_result_t reset_link(struct pci_dev >> *dev) >> } >> >> /** >> - * do_recovery - handle nonfatal/fatal error recovery process >> + * pci_do_recovery - handle nonfatal/fatal error recovery process >> * @dev: pointer to a pci_dev data structure of agent detecting an >> error >> * @severity: error severity type >> * >> @@ -486,7 +486,7 @@ static pci_ers_result_t reset_link(struct pci_dev >> *dev) >> * error detected message to all downstream drivers within a >> hierarchy in >> * question and return the returned code. >> */ >> -static void do_recovery(struct pci_dev *dev, int severity) >> +static void pci_do_recovery(struct pci_dev *dev, int severity) > > Maybe pcie_do_recovery? > sure will take care. Thanks. > Otherwise looks fine: > > Reviewed-by: Christoph Hellwig <hch@lst.de>
diff --git a/drivers/pci/pcie/aer/aerdrv_core.c b/drivers/pci/pcie/aer/aerdrv_core.c index a4bfea5..306bf2f 100644 --- a/drivers/pci/pcie/aer/aerdrv_core.c +++ b/drivers/pci/pcie/aer/aerdrv_core.c @@ -478,7 +478,7 @@ static pci_ers_result_t reset_link(struct pci_dev *dev) } /** - * do_recovery - handle nonfatal/fatal error recovery process + * pci_do_recovery - handle nonfatal/fatal error recovery process * @dev: pointer to a pci_dev data structure of agent detecting an error * @severity: error severity type * @@ -486,7 +486,7 @@ static pci_ers_result_t reset_link(struct pci_dev *dev) * error detected message to all downstream drivers within a hierarchy in * question and return the returned code. */ -static void do_recovery(struct pci_dev *dev, int severity) +static void pci_do_recovery(struct pci_dev *dev, int severity) { pci_ers_result_t status, result = PCI_ERS_RESULT_RECOVERED; enum pci_channel_state state; @@ -566,7 +566,7 @@ static void handle_error_source(struct pcie_device *aerdev, pci_write_config_dword(dev, pos + PCI_ERR_COR_STATUS, info->status); } else - do_recovery(dev, info->severity); + pci_do_recovery(dev, info->severity); } #ifdef CONFIG_ACPI_APEI_PCIEAER @@ -631,7 +631,7 @@ static void aer_recover_work_func(struct work_struct *work) } cper_print_aer(pdev, entry.severity, entry.regs); if (entry.severity != AER_CORRECTABLE) - do_recovery(pdev, entry.severity); + pci_do_recovery(pdev, entry.severity); pci_dev_put(pdev); } }
This patch renames error recovery to generic name with pci prefix Signed-off-by: Oza Pawandeep <poza@codeaurora.org>