Message ID | 20180614194712.102134-2-mka@chromium.org (mailing list archive) |
---|---|
State | Not Applicable, archived |
Headers | show |
Hi, On Thu, Jun 14, 2018 at 12:47:01PM -0700, Matthias Kaehlcke wrote: > Commit ab8f58ad72c4 ("PM / devfreq: Set min/max_freq when adding > the devfreq device") introduced the initialization of the user > limits min/max_freq from the lowest/highest available OPPs. Later > commit f1d981eaecf8 ("PM / devfreq: Use the available min/max > frequency") added scaling_min/max_freq, which actually represent > the frequencies of the lowest/highest available OPP. scaling_min/ > max_freq are initialized with the values from min/max_freq, which > is totally correct in the context, but a bit awkward to read. > > Swap the initialization and assign scaling_min/max_freq with the > OPP freqs and then the user limts min/max_freq with scaling_min/ > max_freq. > > Needless to say that this change is a NOP, intended to improve > readability. > --- BTW, putting the '---' here means that stuff below it usually gets dropped when applied (e.g., with git-am). So it'll drop your Signed-off-by and Reviewed-by. Not a huge problem if the maintainers look out for that. > Signed-off-by: Matthias Kaehlcke <mka@chromium.org> > Reviewed-by: Chanwoo Choi <cw00.choi@samsung.com> Reviewed-by: Brian Norris <briannorris@chromium.org> > > Changes in v3: > - none > > Changes in v2: > - added 'Reviewed-by: Chanwoo Choi <cw00.choi@samsung.com>' tag > > drivers/devfreq/devfreq.c | 12 ++++++------ > 1 file changed, 6 insertions(+), 6 deletions(-) > > diff --git a/drivers/devfreq/devfreq.c b/drivers/devfreq/devfreq.c > index fe2af6aa88fc..0057ef5b0a98 100644 > --- a/drivers/devfreq/devfreq.c > +++ b/drivers/devfreq/devfreq.c > @@ -604,21 +604,21 @@ struct devfreq *devfreq_add_device(struct device *dev, > mutex_lock(&devfreq->lock); > } > > - devfreq->min_freq = find_available_min_freq(devfreq); > - if (!devfreq->min_freq) { > + devfreq->scaling_min_freq = find_available_min_freq(devfreq); > + if (!devfreq->scaling_min_freq) { > mutex_unlock(&devfreq->lock); > err = -EINVAL; > goto err_dev; > } > - devfreq->scaling_min_freq = devfreq->min_freq; > + devfreq->min_freq = devfreq->scaling_min_freq; > > - devfreq->max_freq = find_available_max_freq(devfreq); > - if (!devfreq->max_freq) { > + devfreq->scaling_max_freq = find_available_max_freq(devfreq); > + if (!devfreq->scaling_max_freq) { > mutex_unlock(&devfreq->lock); > err = -EINVAL; > goto err_dev; > } > - devfreq->scaling_max_freq = devfreq->max_freq; > + devfreq->max_freq = devfreq->scaling_max_freq; > > dev_set_name(&devfreq->dev, "devfreq%d", > atomic_inc_return(&devfreq_no)); > -- > 2.18.0.rc1.242.g61856ae69a-goog >
On Fri, Jun 15, 2018 at 02:06:21PM -0700, Brian Norris wrote: > Hi, > > On Thu, Jun 14, 2018 at 12:47:01PM -0700, Matthias Kaehlcke wrote: > > Commit ab8f58ad72c4 ("PM / devfreq: Set min/max_freq when adding > > the devfreq device") introduced the initialization of the user > > limits min/max_freq from the lowest/highest available OPPs. Later > > commit f1d981eaecf8 ("PM / devfreq: Use the available min/max > > frequency") added scaling_min/max_freq, which actually represent > > the frequencies of the lowest/highest available OPP. scaling_min/ > > max_freq are initialized with the values from min/max_freq, which > > is totally correct in the context, but a bit awkward to read. > > > > Swap the initialization and assign scaling_min/max_freq with the > > OPP freqs and then the user limts min/max_freq with scaling_min/ > > max_freq. > > > > Needless to say that this change is a NOP, intended to improve > > readability. > > --- > > BTW, putting the '---' here means that stuff below it usually gets > dropped when applied (e.g., with git-am). So it'll drop your > Signed-off-by and Reviewed-by. Not a huge problem if the maintainers > look out for that. It wasn't intended and is related with my current workflow: To keep easily track of deltas in my tree and have the changelog ready when sending the patches I currently keep the changelog in the commit message and manually move it below '---' when doing 'git send-email'. Seems I got it wrong in this case :( > > Signed-off-by: Matthias Kaehlcke <mka@chromium.org> > > Reviewed-by: Chanwoo Choi <cw00.choi@samsung.com> > > Reviewed-by: Brian Norris <briannorris@chromium.org> Thanks!
diff --git a/drivers/devfreq/devfreq.c b/drivers/devfreq/devfreq.c index fe2af6aa88fc..0057ef5b0a98 100644 --- a/drivers/devfreq/devfreq.c +++ b/drivers/devfreq/devfreq.c @@ -604,21 +604,21 @@ struct devfreq *devfreq_add_device(struct device *dev, mutex_lock(&devfreq->lock); } - devfreq->min_freq = find_available_min_freq(devfreq); - if (!devfreq->min_freq) { + devfreq->scaling_min_freq = find_available_min_freq(devfreq); + if (!devfreq->scaling_min_freq) { mutex_unlock(&devfreq->lock); err = -EINVAL; goto err_dev; } - devfreq->scaling_min_freq = devfreq->min_freq; + devfreq->min_freq = devfreq->scaling_min_freq; - devfreq->max_freq = find_available_max_freq(devfreq); - if (!devfreq->max_freq) { + devfreq->scaling_max_freq = find_available_max_freq(devfreq); + if (!devfreq->scaling_max_freq) { mutex_unlock(&devfreq->lock); err = -EINVAL; goto err_dev; } - devfreq->scaling_max_freq = devfreq->max_freq; + devfreq->max_freq = devfreq->scaling_max_freq; dev_set_name(&devfreq->dev, "devfreq%d", atomic_inc_return(&devfreq_no));