Message ID | 1538566780-30794-1-git-send-email-yamada.masahiro@socionext.com (mailing list archive) |
---|---|
State | Under Review |
Delegated to: | Geert Uytterhoeven |
Headers | show |
Series | mmc: renesas_sdhi: rename DTRAN_MODE_BUS_WID_TH to DTRAN_MODE_BUS_WIDTH | expand |
On 10/03/2018 02:39 PM, Masahiro Yamada wrote: > Socionext UniPhier SoCs use the almost the same internal DMAC. > My datasheet says 'BUS_WIDTH' instead of 'BUS_WID_TH'. I suspect > this is a typo. > > Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com> Already fixed, see: https://git.kernel.org/pub/scm/linux/kernel/git/ulfh/mmc.git/commit/?h=devel&id=652c517c6828a830b71db4b1439a0229c98d9b9e MBR, Sergei
On Wed, Oct 03, 2018 at 08:39:40PM +0900, Masahiro Yamada wrote: > Socionext UniPhier SoCs use the almost the same internal DMAC. > My datasheet says 'BUS_WIDTH' instead of 'BUS_WID_TH'. I suspect > this is a typo. > > Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com> Already fixed in mmc/next.
diff --git a/drivers/mmc/host/renesas_sdhi_internal_dmac.c b/drivers/mmc/host/renesas_sdhi_internal_dmac.c index ca0b439..8d04eea 100644 --- a/drivers/mmc/host/renesas_sdhi_internal_dmac.c +++ b/drivers/mmc/host/renesas_sdhi_internal_dmac.c @@ -36,7 +36,7 @@ /* DM_CM_DTRAN_MODE */ #define DTRAN_MODE_CH_NUM_CH0 0 /* "downstream" = for write commands */ #define DTRAN_MODE_CH_NUM_CH1 BIT(16) /* "uptream" = for read commands */ -#define DTRAN_MODE_BUS_WID_TH (BIT(5) | BIT(4)) +#define DTRAN_MODE_BUS_WIDTH (BIT(5) | BIT(4)) #define DTRAN_MODE_ADDR_MODE BIT(0) /* 1 = Increment address */ /* DM_CM_DTRAN_CTRL */ @@ -174,7 +174,7 @@ renesas_sdhi_internal_dmac_start_dma(struct tmio_mmc_host *host, struct mmc_data *data) { struct scatterlist *sg = host->sg_ptr; - u32 dtran_mode = DTRAN_MODE_BUS_WID_TH | DTRAN_MODE_ADDR_MODE; + u32 dtran_mode = DTRAN_MODE_BUS_WIDTH | DTRAN_MODE_ADDR_MODE; if (!dma_map_sg(&host->pdev->dev, sg, host->sg_len, mmc_get_dma_dir(data)))
Socionext UniPhier SoCs use the almost the same internal DMAC. My datasheet says 'BUS_WIDTH' instead of 'BUS_WID_TH'. I suspect this is a typo. Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com> --- drivers/mmc/host/renesas_sdhi_internal_dmac.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)