Message ID | 20181017000834.GA21330@WindFlash (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Adds -Wshadow=local on KBUILD_HOSTCFLAGS | expand |
Hi Leonardo, Thanks for the patch, just some small comments below. Please, check previous log messages with git log arch/x86/entry/vdso/vdso2c.h, you will see that most patches had the prefix "x86/vdso:" in the commit message. On 10/16/18 9:08 PM, Leonardo Brás wrote: > Renames the char variable to avoid shadowing a variable previously > declared on this function. > > Signed-off-by: Leonardo Brás <leobras.c@gmail.com> > --- > arch/x86/entry/vdso/vdso2c.h | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/arch/x86/entry/vdso/vdso2c.h b/arch/x86/entry/vdso/vdso2c.h > index fa847a620f40..9466998d0f28 100644 > --- a/arch/x86/entry/vdso/vdso2c.h > +++ b/arch/x86/entry/vdso/vdso2c.h > @@ -93,11 +93,11 @@ static void BITSFUNC(go)(void *raw_addr, size_t raw_len, > int k; > ELF(Sym) *sym = raw_addr + GET_LE(&symtab_hdr->sh_offset) + > GET_LE(&symtab_hdr->sh_entsize) * i; > - const char *name = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > + const char *name2 = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > GET_LE(&sym->st_name); Could you please use a more meaningful name instead of name2 please? I believe sym_name should be fine. > > for (k = 0; k < NSYMS; k++) { > - if (!strcmp(name, required_syms[k].name)) { > + if (!strcmp(name2, required_syms[k].name)) { > if (syms[k]) { > fail("duplicate symbol %s\n", > required_syms[k].name); > Regards Helen
* Leonardo Brás <leobras.c@gmail.com> wrote: > Renames the char variable to avoid shadowing a variable previously > declared on this function. > > Signed-off-by: Leonardo Brás <leobras.c@gmail.com> > --- > arch/x86/entry/vdso/vdso2c.h | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/arch/x86/entry/vdso/vdso2c.h b/arch/x86/entry/vdso/vdso2c.h > index fa847a620f40..9466998d0f28 100644 > --- a/arch/x86/entry/vdso/vdso2c.h > +++ b/arch/x86/entry/vdso/vdso2c.h > @@ -93,11 +93,11 @@ static void BITSFUNC(go)(void *raw_addr, size_t raw_len, > int k; > ELF(Sym) *sym = raw_addr + GET_LE(&symtab_hdr->sh_offset) + > GET_LE(&symtab_hdr->sh_entsize) * i; > - const char *name = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > + const char *name2 = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > GET_LE(&sym->st_name); > > for (k = 0; k < NSYMS; k++) { > - if (!strcmp(name, required_syms[k].name)) { > + if (!strcmp(name2, required_syms[k].name)) { > if (syms[k]) { > fail("duplicate symbol %s\n", > required_syms[k].name); NAK. Please read and understand the code and rename both variables to meaningful names, not just a mindless name/name2 ... Thanks, Ingo
On Tue, Oct 16, 2018 at 11:01 PM Ingo Molnar <mingo@kernel.org> wrote: > > > * Leonardo Brás <leobras.c@gmail.com> wrote: > > > Renames the char variable to avoid shadowing a variable previously > > declared on this function. > > > > Signed-off-by: Leonardo Brás <leobras.c@gmail.com> > > --- > > arch/x86/entry/vdso/vdso2c.h | 4 ++-- > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > diff --git a/arch/x86/entry/vdso/vdso2c.h b/arch/x86/entry/vdso/vdso2c.h > > index fa847a620f40..9466998d0f28 100644 > > --- a/arch/x86/entry/vdso/vdso2c.h > > +++ b/arch/x86/entry/vdso/vdso2c.h > > @@ -93,11 +93,11 @@ static void BITSFUNC(go)(void *raw_addr, size_t raw_len, > > int k; > > ELF(Sym) *sym = raw_addr + GET_LE(&symtab_hdr->sh_offset) + > > GET_LE(&symtab_hdr->sh_entsize) * i; > > - const char *name = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > > + const char *name2 = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > > GET_LE(&sym->st_name); > > > > for (k = 0; k < NSYMS; k++) { > > - if (!strcmp(name, required_syms[k].name)) { > > + if (!strcmp(name2, required_syms[k].name)) { > > if (syms[k]) { > > fail("duplicate symbol %s\n", > > required_syms[k].name); > > NAK. > > Please read and understand the code and rename both variables to > meaningful names, not just a mindless name/name2 ... > Maybe image_name and sym_name? --Andy
Hello Helen, Thanks for the suggestions! On Tue, Oct 16, 2018 at 11:57 PM Helen Koike <helen@koikeco.de> wrote: > > Hi Leonardo, > > Thanks for the patch, just some small comments below. > > Please, check previous log messages with git log > arch/x86/entry/vdso/vdso2c.h, you will see that most patches had the > prefix "x86/vdso:" in the commit message. Ok, added! This change will be available on v2. > > On 10/16/18 9:08 PM, Leonardo Brás wrote: > > Renames the char variable to avoid shadowing a variable previously > > declared on this function. > > > > Signed-off-by: Leonardo Brás <leobras.c@gmail.com> > > --- > > arch/x86/entry/vdso/vdso2c.h | 4 ++-- > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > diff --git a/arch/x86/entry/vdso/vdso2c.h b/arch/x86/entry/vdso/vdso2c.h > > index fa847a620f40..9466998d0f28 100644 > > --- a/arch/x86/entry/vdso/vdso2c.h > > +++ b/arch/x86/entry/vdso/vdso2c.h > > @@ -93,11 +93,11 @@ static void BITSFUNC(go)(void *raw_addr, size_t raw_len, > > int k; > > ELF(Sym) *sym = raw_addr + GET_LE(&symtab_hdr->sh_offset) + > > GET_LE(&symtab_hdr->sh_entsize) * i; > > - const char *name = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > > + const char *name2 = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > > GET_LE(&sym->st_name); > > Could you please use a more meaningful name instead of name2 please? I > believe sym_name should be fine. Ok, I renamed as you suggested. Also, I renamed the "name" variable to "image_name" as Andy suggested. This change will be available on v2. > > > > > for (k = 0; k < NSYMS; k++) { > > - if (!strcmp(name, required_syms[k].name)) { > > + if (!strcmp(name2, required_syms[k].name)) { > > if (syms[k]) { > > fail("duplicate symbol %s\n", > > required_syms[k].name); > > > > Regards > Helen Regards, Leonardo Bras
Thanks Ingo, On Wed, Oct 17, 2018 at 3:01 AM Ingo Molnar <mingo@kernel.org> wrote: > > > * Leonardo Brás <leobras.c@gmail.com> wrote: > > > Renames the char variable to avoid shadowing a variable previously > > declared on this function. > > > > Signed-off-by: Leonardo Brás <leobras.c@gmail.com> > > --- > > arch/x86/entry/vdso/vdso2c.h | 4 ++-- > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > diff --git a/arch/x86/entry/vdso/vdso2c.h b/arch/x86/entry/vdso/vdso2c.h > > index fa847a620f40..9466998d0f28 100644 > > --- a/arch/x86/entry/vdso/vdso2c.h > > +++ b/arch/x86/entry/vdso/vdso2c.h > > @@ -93,11 +93,11 @@ static void BITSFUNC(go)(void *raw_addr, size_t raw_len, > > int k; > > ELF(Sym) *sym = raw_addr + GET_LE(&symtab_hdr->sh_offset) + > > GET_LE(&symtab_hdr->sh_entsize) * i; > > - const char *name = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > > + const char *name2 = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > > GET_LE(&sym->st_name); > > > > for (k = 0; k < NSYMS; k++) { > > - if (!strcmp(name, required_syms[k].name)) { > > + if (!strcmp(name2, required_syms[k].name)) { > > if (syms[k]) { > > fail("duplicate symbol %s\n", > > required_syms[k].name); > > NAK. > > Please read and understand the code and rename both variables to > meaningful names, not just a mindless name/name2 ... > It's changed! This change will be available on v2. > Thanks, > > Ingo Regards, Leonardo
Hello Andy, Thanks for the suggestion. I renamed them as suggested and it will be available on v2. Regards, Leonardo On Wed, Oct 17, 2018 at 2:54 PM Andy Lutomirski <luto@kernel.org> wrote: > > On Tue, Oct 16, 2018 at 11:01 PM Ingo Molnar <mingo@kernel.org> wrote: > > > > > > * Leonardo Brás <leobras.c@gmail.com> wrote: > > > > > Renames the char variable to avoid shadowing a variable previously > > > declared on this function. > > > > > > Signed-off-by: Leonardo Brás <leobras.c@gmail.com> > > > --- > > > arch/x86/entry/vdso/vdso2c.h | 4 ++-- > > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > > > diff --git a/arch/x86/entry/vdso/vdso2c.h b/arch/x86/entry/vdso/vdso2c.h > > > index fa847a620f40..9466998d0f28 100644 > > > --- a/arch/x86/entry/vdso/vdso2c.h > > > +++ b/arch/x86/entry/vdso/vdso2c.h > > > @@ -93,11 +93,11 @@ static void BITSFUNC(go)(void *raw_addr, size_t raw_len, > > > int k; > > > ELF(Sym) *sym = raw_addr + GET_LE(&symtab_hdr->sh_offset) + > > > GET_LE(&symtab_hdr->sh_entsize) * i; > > > - const char *name = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > > > + const char *name2 = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > > > GET_LE(&sym->st_name); > > > > > > for (k = 0; k < NSYMS; k++) { > > > - if (!strcmp(name, required_syms[k].name)) { > > > + if (!strcmp(name2, required_syms[k].name)) { > > > if (syms[k]) { > > > fail("duplicate symbol %s\n", > > > required_syms[k].name); > > > > NAK. > > > > Please read and understand the code and rename both variables to > > meaningful names, not just a mindless name/name2 ... > > > > Maybe image_name and sym_name? > > --Andy
* Leonardo Bras <leobras.c@gmail.com> wrote: > Thanks Ingo, > On Wed, Oct 17, 2018 at 3:01 AM Ingo Molnar <mingo@kernel.org> wrote: > > > > > > * Leonardo Brás <leobras.c@gmail.com> wrote: > > > > > Renames the char variable to avoid shadowing a variable previously > > > declared on this function. > > > > > > Signed-off-by: Leonardo Brás <leobras.c@gmail.com> > > > --- > > > arch/x86/entry/vdso/vdso2c.h | 4 ++-- > > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > > > diff --git a/arch/x86/entry/vdso/vdso2c.h b/arch/x86/entry/vdso/vdso2c.h > > > index fa847a620f40..9466998d0f28 100644 > > > --- a/arch/x86/entry/vdso/vdso2c.h > > > +++ b/arch/x86/entry/vdso/vdso2c.h > > > @@ -93,11 +93,11 @@ static void BITSFUNC(go)(void *raw_addr, size_t raw_len, > > > int k; > > > ELF(Sym) *sym = raw_addr + GET_LE(&symtab_hdr->sh_offset) + > > > GET_LE(&symtab_hdr->sh_entsize) * i; > > > - const char *name = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > > > + const char *name2 = raw_addr + GET_LE(&strtab_hdr->sh_offset) + > > > GET_LE(&sym->st_name); > > > > > > for (k = 0; k < NSYMS; k++) { > > > - if (!strcmp(name, required_syms[k].name)) { > > > + if (!strcmp(name2, required_syms[k].name)) { > > > if (syms[k]) { > > > fail("duplicate symbol %s\n", > > > required_syms[k].name); > > > > NAK. > > > > Please read and understand the code and rename both variables to > > meaningful names, not just a mindless name/name2 ... > > > > It's changed! This change will be available on v2. Thanks! Ingo
diff --git a/arch/x86/entry/vdso/vdso2c.h b/arch/x86/entry/vdso/vdso2c.h index fa847a620f40..9466998d0f28 100644 --- a/arch/x86/entry/vdso/vdso2c.h +++ b/arch/x86/entry/vdso/vdso2c.h @@ -93,11 +93,11 @@ static void BITSFUNC(go)(void *raw_addr, size_t raw_len, int k; ELF(Sym) *sym = raw_addr + GET_LE(&symtab_hdr->sh_offset) + GET_LE(&symtab_hdr->sh_entsize) * i; - const char *name = raw_addr + GET_LE(&strtab_hdr->sh_offset) + + const char *name2 = raw_addr + GET_LE(&strtab_hdr->sh_offset) + GET_LE(&sym->st_name); for (k = 0; k < NSYMS; k++) { - if (!strcmp(name, required_syms[k].name)) { + if (!strcmp(name2, required_syms[k].name)) { if (syms[k]) { fail("duplicate symbol %s\n", required_syms[k].name);
Renames the char variable to avoid shadowing a variable previously declared on this function. Signed-off-by: Leonardo Brás <leobras.c@gmail.com> --- arch/x86/entry/vdso/vdso2c.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)