mbox series

[00/11] qla2xxx patches for kernel v5.2

Message ID 20190404194448.121489-1-bvanassche@acm.org (mailing list archive)
Headers show
Series qla2xxx patches for kernel v5.2 | expand

Message

Bart Van Assche April 4, 2019, 7:44 p.m. UTC
Hi Martin,

This is a series with mostly source code cleanup patches for the qla2xxx
driver. Please consider this patch series for kernel v5.2.

Thanks,

Bart.

Bart Van Assche (11):
  Declare wwn_to_u64() argument const
  qla2xxx: Change a stack variable into a static const variable
  qla2xxx: Remove a comment that refers to the SCSI host lock
  qla2xxx: Use ARRAY_SIZE() in the definition of QLA_LAST_SPEED
  qla2xxx: Declare local symbols static
  qla2xxx: Reduce the number of forward declarations
  qla2xxx: Make qla2x00_process_response_queue() easier to read
  qla2xxx: Use get/put_unaligned where appropriate
  qla2xxx: Unregister chrdev if module initialization fails
  qla2xxx: Unregister resources in the opposite order of the
    registration order
  tcm_qla2xxx: Minimize #include directives

 drivers/scsi/qla2xxx/qla_attr.c    |   5 +-
 drivers/scsi/qla2xxx/qla_bsg.c     |   2 +-
 drivers/scsi/qla2xxx/qla_iocb.c    |  21 ++---
 drivers/scsi/qla2xxx/qla_isr.c     |  87 +++++++++++---------
 drivers/scsi/qla2xxx/qla_nvme.c    |   4 +-
 drivers/scsi/qla2xxx/qla_os.c      | 127 ++++++++++++++---------------
 drivers/scsi/qla2xxx/tcm_qla2xxx.c |   7 --
 include/scsi/scsi_transport_fc.h   |   2 +-
 8 files changed, 123 insertions(+), 132 deletions(-)

Comments

Martin K. Petersen April 9, 2019, 2:17 a.m. UTC | #1
Bart,

> This is a series with mostly source code cleanup patches for the
> qla2xxx driver. Please consider this patch series for kernel v5.2.

Applied to 5.2/scsi-queue, thanks!