Message ID | 20190606094722.23816-1-anders.roxell@linaro.org (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | None | expand |
On 10/06/2019 14:03, Anders Roxell wrote: > On Thu, 6 Jun 2019 at 12:13, Hans Verkuil <hverkuil@xs4all.nl> wrote: >> >> On 6/6/19 11:47 AM, Anders Roxell wrote: >>> When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as >>> loadable modules, we see the following warning: >>> >>> warning: same module names found: >>> fs/coda/coda.ko >>> drivers/media/platform/coda/coda.ko >>> >>> Rework so media coda matches the config fragment. Leaving CODA_FS as is >>> since thats a well known module. >>> >>> Signed-off-by: Anders Roxell <anders.roxell@linaro.org> >>> --- >>> drivers/media/platform/coda/Makefile | 4 ++-- >>> 1 file changed, 2 insertions(+), 2 deletions(-) >>> >>> diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile >>> index 54e9a73a92ab..588e6bf7c190 100644 >>> --- a/drivers/media/platform/coda/Makefile >>> +++ b/drivers/media/platform/coda/Makefile >>> @@ -1,6 +1,6 @@ >>> # SPDX-License-Identifier: GPL-2.0-only >>> >>> -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o >>> +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o >>> >>> -obj-$(CONFIG_VIDEO_CODA) += coda.o >>> +obj-$(CONFIG_VIDEO_CODA) += video-coda.o >> >> How about imx-coda? video-coda suggests it is part of the video subsystem, >> which it isn't. > > I'll resend a v2 shortly with imx-coda instead. What about other vendor SoCs implementing the Coda IP block which are not an imx? I'd prefer a more generic name - maybe media-coda. Thanks, Matt > > > Cheers, > Anders > >> >> Regards, >> >> Hans >> >>> obj-$(CONFIG_VIDEO_IMX_VDOA) += imx-vdoa.o >>> >>
Hi, On Mon, 2019-06-10 at 13:14 +0000, Matt Redfearn wrote: > > On 10/06/2019 14:03, Anders Roxell wrote: > > On Thu, 6 Jun 2019 at 12:13, Hans Verkuil <hverkuil@xs4all.nl> wrote: > > > > > > On 6/6/19 11:47 AM, Anders Roxell wrote: > > > > When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as > > > > loadable modules, we see the following warning: > > > > > > > > warning: same module names found: > > > > fs/coda/coda.ko > > > > drivers/media/platform/coda/coda.ko > > > > > > > > Rework so media coda matches the config fragment. Leaving CODA_FS as is > > > > since thats a well known module. > > > > > > > > Signed-off-by: Anders Roxell <anders.roxell@linaro.org> > > > > --- > > > > drivers/media/platform/coda/Makefile | 4 ++-- > > > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > > > > > diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile > > > > index 54e9a73a92ab..588e6bf7c190 100644 > > > > --- a/drivers/media/platform/coda/Makefile > > > > +++ b/drivers/media/platform/coda/Makefile > > > > @@ -1,6 +1,6 @@ > > > > # SPDX-License-Identifier: GPL-2.0-only > > > > > > > > -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > > > > +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > > > > > > > > -obj-$(CONFIG_VIDEO_CODA) += coda.o > > > > +obj-$(CONFIG_VIDEO_CODA) += video-coda.o > > > > > > How about imx-coda? video-coda suggests it is part of the video subsystem, > > > which it isn't. > > > > I'll resend a v2 shortly with imx-coda instead. I'd be in favor of calling it "coda-vpu" instead. > What about other vendor SoCs implementing the Coda IP block which are > not an imx? I'd prefer a more generic name - maybe media-coda. Right, this driver can be used on other SoCs [1]. [1] https://www.mail-archive.com/linux-media@vger.kernel.org/msg146498.html regards Philipp
On 6/11/19 10:15 AM, Philipp Zabel wrote: > Hi, > > On Mon, 2019-06-10 at 13:14 +0000, Matt Redfearn wrote: >> >> On 10/06/2019 14:03, Anders Roxell wrote: >>> On Thu, 6 Jun 2019 at 12:13, Hans Verkuil <hverkuil@xs4all.nl> wrote: >>>> >>>> On 6/6/19 11:47 AM, Anders Roxell wrote: >>>>> When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as >>>>> loadable modules, we see the following warning: >>>>> >>>>> warning: same module names found: >>>>> fs/coda/coda.ko >>>>> drivers/media/platform/coda/coda.ko >>>>> >>>>> Rework so media coda matches the config fragment. Leaving CODA_FS as is >>>>> since thats a well known module. >>>>> >>>>> Signed-off-by: Anders Roxell <anders.roxell@linaro.org> >>>>> --- >>>>> drivers/media/platform/coda/Makefile | 4 ++-- >>>>> 1 file changed, 2 insertions(+), 2 deletions(-) >>>>> >>>>> diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile >>>>> index 54e9a73a92ab..588e6bf7c190 100644 >>>>> --- a/drivers/media/platform/coda/Makefile >>>>> +++ b/drivers/media/platform/coda/Makefile >>>>> @@ -1,6 +1,6 @@ >>>>> # SPDX-License-Identifier: GPL-2.0-only >>>>> >>>>> -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o >>>>> +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o >>>>> >>>>> -obj-$(CONFIG_VIDEO_CODA) += coda.o >>>>> +obj-$(CONFIG_VIDEO_CODA) += video-coda.o >>>> >>>> How about imx-coda? video-coda suggests it is part of the video subsystem, >>>> which it isn't. >>> >>> I'll resend a v2 shortly with imx-coda instead. > > I'd be in favor of calling it "coda-vpu" instead. Fine by me! > >> What about other vendor SoCs implementing the Coda IP block which are >> not an imx? I'd prefer a more generic name - maybe media-coda. > > Right, this driver can be used on other SoCs [1]. Good point. Regards, Hans > > [1] https://www.mail-archive.com/linux-media@vger.kernel.org/msg146498.html > > regards > Philipp >
On Tue, 11 Jun 2019 at 10:21, Hans Verkuil <hverkuil@xs4all.nl> wrote: > > On 6/11/19 10:15 AM, Philipp Zabel wrote: > > Hi, > > > > On Mon, 2019-06-10 at 13:14 +0000, Matt Redfearn wrote: > >> > >> On 10/06/2019 14:03, Anders Roxell wrote: > >>> On Thu, 6 Jun 2019 at 12:13, Hans Verkuil <hverkuil@xs4all.nl> wrote: > >>>> > >>>> On 6/6/19 11:47 AM, Anders Roxell wrote: > >>>>> When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as > >>>>> loadable modules, we see the following warning: > >>>>> > >>>>> warning: same module names found: > >>>>> fs/coda/coda.ko > >>>>> drivers/media/platform/coda/coda.ko > >>>>> > >>>>> Rework so media coda matches the config fragment. Leaving CODA_FS as is > >>>>> since thats a well known module. > >>>>> > >>>>> Signed-off-by: Anders Roxell <anders.roxell@linaro.org> > >>>>> --- > >>>>> drivers/media/platform/coda/Makefile | 4 ++-- > >>>>> 1 file changed, 2 insertions(+), 2 deletions(-) > >>>>> > >>>>> diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile > >>>>> index 54e9a73a92ab..588e6bf7c190 100644 > >>>>> --- a/drivers/media/platform/coda/Makefile > >>>>> +++ b/drivers/media/platform/coda/Makefile > >>>>> @@ -1,6 +1,6 @@ > >>>>> # SPDX-License-Identifier: GPL-2.0-only > >>>>> > >>>>> -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > >>>>> +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > >>>>> > >>>>> -obj-$(CONFIG_VIDEO_CODA) += coda.o > >>>>> +obj-$(CONFIG_VIDEO_CODA) += video-coda.o > >>>> > >>>> How about imx-coda? video-coda suggests it is part of the video subsystem, > >>>> which it isn't. > >>> > >>> I'll resend a v2 shortly with imx-coda instead. > > > > I'd be in favor of calling it "coda-vpu" instead. > > Fine by me! > > > > >> What about other vendor SoCs implementing the Coda IP block which are > >> not an imx? I'd prefer a more generic name - maybe media-coda. > > > > Right, this driver can be used on other SoCs [1]. > > Good point. OK, so I'll change it to 'media-coda'. Cheers, Anders > > Regards, > > Hans > > > > > [1] https://www.mail-archive.com/linux-media@vger.kernel.org/msg146498.html > > > > regards > > Philipp > > >
On Tue, Jun 11, 2019, 1:01 PM Anders Roxell <anders.roxell@linaro.org> wrote: > On Tue, 11 Jun 2019 at 10:21, Hans Verkuil <hverkuil@xs4all.nl> wrote: > > > > On 6/11/19 10:15 AM, Philipp Zabel wrote: > > > Hi, > > > > > > On Mon, 2019-06-10 at 13:14 +0000, Matt Redfearn wrote: > > >> > > >> On 10/06/2019 14:03, Anders Roxell wrote: > > >>> On Thu, 6 Jun 2019 at 12:13, Hans Verkuil <hverkuil@xs4all.nl> > wrote: > > >>>> > > >>>> On 6/6/19 11:47 AM, Anders Roxell wrote: > > >>>>> When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as > > >>>>> loadable modules, we see the following warning: > > >>>>> > > >>>>> warning: same module names found: > > >>>>> fs/coda/coda.ko > > >>>>> drivers/media/platform/coda/coda.ko > > >>>>> > > >>>>> Rework so media coda matches the config fragment. Leaving CODA_FS > as is > > >>>>> since thats a well known module. > > >>>>> > > >>>>> Signed-off-by: Anders Roxell <anders.roxell@linaro.org> > > >>>>> --- > > >>>>> drivers/media/platform/coda/Makefile | 4 ++-- > > >>>>> 1 file changed, 2 insertions(+), 2 deletions(-) > > >>>>> > > >>>>> diff --git a/drivers/media/platform/coda/Makefile > b/drivers/media/platform/coda/Makefile > > >>>>> index 54e9a73a92ab..588e6bf7c190 100644 > > >>>>> --- a/drivers/media/platform/coda/Makefile > > >>>>> +++ b/drivers/media/platform/coda/Makefile > > >>>>> @@ -1,6 +1,6 @@ > > >>>>> # SPDX-License-Identifier: GPL-2.0-only > > >>>>> > > >>>>> -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o > coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > > >>>>> +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o > coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > > >>>>> > > >>>>> -obj-$(CONFIG_VIDEO_CODA) += coda.o > > >>>>> +obj-$(CONFIG_VIDEO_CODA) += video-coda.o > > >>>> > > >>>> How about imx-coda? video-coda suggests it is part of the video > subsystem, > > >>>> which it isn't. > > >>> > > >>> I'll resend a v2 shortly with imx-coda instead. > > > > > > I'd be in favor of calling it "coda-vpu" instead. > > > > Fine by me! > > > > > > > >> What about other vendor SoCs implementing the Coda IP block which are > > >> not an imx? I'd prefer a more generic name - maybe media-coda. > > > > > > Right, this driver can be used on other SoCs [1]. > > > > Good point. > > OK, so I'll change it to 'media-coda'. > > > > As suggested by Philipp, coda-vpu seems the most accurate name. Thanks, Ezequiel Cheers, > Anders > > > > > Regards, > > > > Hans > > > > > > > > [1] > https://www.mail-archive.com/linux-media@vger.kernel.org/msg146498.html > > > > > > regards > > > Philipp > > > > > > <div dir="auto"><div><br><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Tue, Jun 11, 2019, 1:01 PM Anders Roxell <<a href="mailto:anders.roxell@linaro.org" target="_blank" rel="noreferrer">anders.roxell@linaro.org</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">On Tue, 11 Jun 2019 at 10:21, Hans Verkuil <<a href="mailto:hverkuil@xs4all.nl" rel="noreferrer noreferrer" target="_blank">hverkuil@xs4all.nl</a>> wrote:<br> ><br> > On 6/11/19 10:15 AM, Philipp Zabel wrote:<br> > > Hi,<br> > ><br> > > On Mon, 2019-06-10 at 13:14 +0000, Matt Redfearn wrote:<br> > >><br> > >> On 10/06/2019 14:03, Anders Roxell wrote:<br> > >>> On Thu, 6 Jun 2019 at 12:13, Hans Verkuil <<a href="mailto:hverkuil@xs4all.nl" rel="noreferrer noreferrer" target="_blank">hverkuil@xs4all.nl</a>> wrote:<br> > >>>><br> > >>>> On 6/6/19 11:47 AM, Anders Roxell wrote:<br> > >>>>> When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as<br> > >>>>> loadable modules, we see the following warning:<br> > >>>>><br> > >>>>> warning: same module names found:<br> > >>>>> fs/coda/coda.ko<br> > >>>>> drivers/media/platform/coda/coda.ko<br> > >>>>><br> > >>>>> Rework so media coda matches the config fragment. Leaving CODA_FS as is<br> > >>>>> since thats a well known module.<br> > >>>>><br> > >>>>> Signed-off-by: Anders Roxell <<a href="mailto:anders.roxell@linaro.org" rel="noreferrer noreferrer" target="_blank">anders.roxell@linaro.org</a>><br> > >>>>> ---<br> > >>>>> drivers/media/platform/coda/Makefile | 4 ++--<br> > >>>>> 1 file changed, 2 insertions(+), 2 deletions(-)<br> > >>>>><br> > >>>>> diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile<br> > >>>>> index 54e9a73a92ab..588e6bf7c190 100644<br> > >>>>> --- a/drivers/media/platform/coda/Makefile<br> > >>>>> +++ b/drivers/media/platform/coda/Makefile<br> > >>>>> @@ -1,6 +1,6 @@<br> > >>>>> # SPDX-License-Identifier: GPL-2.0-only<br> > >>>>><br> > >>>>> -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o<br> > >>>>> +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o<br> > >>>>><br> > >>>>> -obj-$(CONFIG_VIDEO_CODA) += coda.o<br> > >>>>> +obj-$(CONFIG_VIDEO_CODA) += video-coda.o<br> > >>>><br> > >>>> How about imx-coda? video-coda suggests it is part of the video subsystem,<br> > >>>> which it isn't.<br> > >>><br> > >>> I'll resend a v2 shortly with imx-coda instead.<br> > ><br> > > I'd be in favor of calling it "coda-vpu" instead.<br> ><br> > Fine by me!<br> ><br> > ><br> > >> What about other vendor SoCs implementing the Coda IP block which are<br> > >> not an imx? I'd prefer a more generic name - maybe media-coda.<br> > ><br> > > Right, this driver can be used on other SoCs [1].<br> ><br> > Good point.<br> <br> OK, so I'll change it to 'media-coda'.<br><br><br><br></blockquote></div></div><div dir="auto"><br></div><div dir="auto">As suggested by Philipp, coda-vpu seems the most accurate name.</div><div dir="auto"><br></div><div dir="auto">Thanks,</div><div dir="auto">Ezequiel</div><div dir="auto"><br></div><div dir="auto"><br></div><div dir="auto"><br></div><div dir="auto"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"> Cheers,<br> Anders<br> <br> ><br> > Regards,<br> ><br> > Hans<br> ><br> > ><br> > > [1] <a href="https://www.mail-archive.com/linux-media@vger.kernel.org/msg146498.html" rel="noreferrer noreferrer noreferrer" target="_blank">https://www.mail-archive.com/linux-media@vger.kernel.org/msg146498.html</a><br> > ><br> > > regards<br> > > Philipp<br> > ><br> ><br> </blockquote></div></div></div>
On Tue, 11 Jun 2019 at 18:18, Ezequiel Garcia <ezequiel@vanguardiasur.com.ar> wrote: > > > > On Tue, Jun 11, 2019, 1:01 PM Anders Roxell <anders.roxell@linaro.org> wrote: >> >> On Tue, 11 Jun 2019 at 10:21, Hans Verkuil <hverkuil@xs4all.nl> wrote: >> > >> > On 6/11/19 10:15 AM, Philipp Zabel wrote: >> > > Hi, >> > > >> > > On Mon, 2019-06-10 at 13:14 +0000, Matt Redfearn wrote: >> > >> >> > >> On 10/06/2019 14:03, Anders Roxell wrote: >> > >>> On Thu, 6 Jun 2019 at 12:13, Hans Verkuil <hverkuil@xs4all.nl> wrote: >> > >>>> >> > >>>> On 6/6/19 11:47 AM, Anders Roxell wrote: >> > >>>>> When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as >> > >>>>> loadable modules, we see the following warning: >> > >>>>> >> > >>>>> warning: same module names found: >> > >>>>> fs/coda/coda.ko >> > >>>>> drivers/media/platform/coda/coda.ko >> > >>>>> >> > >>>>> Rework so media coda matches the config fragment. Leaving CODA_FS as is >> > >>>>> since thats a well known module. >> > >>>>> >> > >>>>> Signed-off-by: Anders Roxell <anders.roxell@linaro.org> >> > >>>>> --- >> > >>>>> drivers/media/platform/coda/Makefile | 4 ++-- >> > >>>>> 1 file changed, 2 insertions(+), 2 deletions(-) >> > >>>>> >> > >>>>> diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile >> > >>>>> index 54e9a73a92ab..588e6bf7c190 100644 >> > >>>>> --- a/drivers/media/platform/coda/Makefile >> > >>>>> +++ b/drivers/media/platform/coda/Makefile >> > >>>>> @@ -1,6 +1,6 @@ >> > >>>>> # SPDX-License-Identifier: GPL-2.0-only >> > >>>>> >> > >>>>> -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o >> > >>>>> +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o >> > >>>>> >> > >>>>> -obj-$(CONFIG_VIDEO_CODA) += coda.o >> > >>>>> +obj-$(CONFIG_VIDEO_CODA) += video-coda.o >> > >>>> >> > >>>> How about imx-coda? video-coda suggests it is part of the video subsystem, >> > >>>> which it isn't. >> > >>> >> > >>> I'll resend a v2 shortly with imx-coda instead. >> > > >> > > I'd be in favor of calling it "coda-vpu" instead. >> > >> > Fine by me! >> > >> > > >> > >> What about other vendor SoCs implementing the Coda IP block which are >> > >> not an imx? I'd prefer a more generic name - maybe media-coda. >> > > >> > > Right, this driver can be used on other SoCs [1]. >> > >> > Good point. >> >> OK, so I'll change it to 'media-coda'. >> >> >> > > As suggested by Philipp, coda-vpu seems the most accurate name. urgh, that correct. Thanks, Anders > > Thanks, > Ezequiel > > > >> Cheers, >> Anders >> >> > >> > Regards, >> > >> > Hans >> > >> > > >> > > [1] https://www.mail-archive.com/linux-media@vger.kernel.org/msg146498.html >> > > >> > > regards >> > > Philipp >> > > >> >
diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile index 54e9a73a92ab..588e6bf7c190 100644 --- a/drivers/media/platform/coda/Makefile +++ b/drivers/media/platform/coda/Makefile @@ -1,6 +1,6 @@ # SPDX-License-Identifier: GPL-2.0-only -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o -obj-$(CONFIG_VIDEO_CODA) += coda.o +obj-$(CONFIG_VIDEO_CODA) += video-coda.o obj-$(CONFIG_VIDEO_IMX_VDOA) += imx-vdoa.o
When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as loadable modules, we see the following warning: warning: same module names found: fs/coda/coda.ko drivers/media/platform/coda/coda.ko Rework so media coda matches the config fragment. Leaving CODA_FS as is since thats a well known module. Signed-off-by: Anders Roxell <anders.roxell@linaro.org> --- drivers/media/platform/coda/Makefile | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)