Message ID | 20190606094722.23816-1-anders.roxell@linaro.org (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | fix warnings for same module names | expand |
On 6/6/19 11:47 AM, Anders Roxell wrote: > When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as > loadable modules, we see the following warning: > > warning: same module names found: > fs/coda/coda.ko > drivers/media/platform/coda/coda.ko > > Rework so media coda matches the config fragment. Leaving CODA_FS as is > since thats a well known module. > > Signed-off-by: Anders Roxell <anders.roxell@linaro.org> > --- > drivers/media/platform/coda/Makefile | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile > index 54e9a73a92ab..588e6bf7c190 100644 > --- a/drivers/media/platform/coda/Makefile > +++ b/drivers/media/platform/coda/Makefile > @@ -1,6 +1,6 @@ > # SPDX-License-Identifier: GPL-2.0-only > > -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > > -obj-$(CONFIG_VIDEO_CODA) += coda.o > +obj-$(CONFIG_VIDEO_CODA) += video-coda.o How about imx-coda? video-coda suggests it is part of the video subsystem, which it isn't. Regards, Hans > obj-$(CONFIG_VIDEO_IMX_VDOA) += imx-vdoa.o >
On Thu, 6 Jun 2019 at 12:13, Hans Verkuil <hverkuil@xs4all.nl> wrote: > > On 6/6/19 11:47 AM, Anders Roxell wrote: > > When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as > > loadable modules, we see the following warning: > > > > warning: same module names found: > > fs/coda/coda.ko > > drivers/media/platform/coda/coda.ko > > > > Rework so media coda matches the config fragment. Leaving CODA_FS as is > > since thats a well known module. > > > > Signed-off-by: Anders Roxell <anders.roxell@linaro.org> > > --- > > drivers/media/platform/coda/Makefile | 4 ++-- > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile > > index 54e9a73a92ab..588e6bf7c190 100644 > > --- a/drivers/media/platform/coda/Makefile > > +++ b/drivers/media/platform/coda/Makefile > > @@ -1,6 +1,6 @@ > > # SPDX-License-Identifier: GPL-2.0-only > > > > -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > > +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > > > > -obj-$(CONFIG_VIDEO_CODA) += coda.o > > +obj-$(CONFIG_VIDEO_CODA) += video-coda.o > > How about imx-coda? video-coda suggests it is part of the video subsystem, > which it isn't. I'll resend a v2 shortly with imx-coda instead. Cheers, Anders > > Regards, > > Hans > > > obj-$(CONFIG_VIDEO_IMX_VDOA) += imx-vdoa.o > > >
On 10/06/2019 14:03, Anders Roxell wrote: > On Thu, 6 Jun 2019 at 12:13, Hans Verkuil <hverkuil@xs4all.nl> wrote: >> >> On 6/6/19 11:47 AM, Anders Roxell wrote: >>> When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as >>> loadable modules, we see the following warning: >>> >>> warning: same module names found: >>> fs/coda/coda.ko >>> drivers/media/platform/coda/coda.ko >>> >>> Rework so media coda matches the config fragment. Leaving CODA_FS as is >>> since thats a well known module. >>> >>> Signed-off-by: Anders Roxell <anders.roxell@linaro.org> >>> --- >>> drivers/media/platform/coda/Makefile | 4 ++-- >>> 1 file changed, 2 insertions(+), 2 deletions(-) >>> >>> diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile >>> index 54e9a73a92ab..588e6bf7c190 100644 >>> --- a/drivers/media/platform/coda/Makefile >>> +++ b/drivers/media/platform/coda/Makefile >>> @@ -1,6 +1,6 @@ >>> # SPDX-License-Identifier: GPL-2.0-only >>> >>> -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o >>> +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o >>> >>> -obj-$(CONFIG_VIDEO_CODA) += coda.o >>> +obj-$(CONFIG_VIDEO_CODA) += video-coda.o >> >> How about imx-coda? video-coda suggests it is part of the video subsystem, >> which it isn't. > > I'll resend a v2 shortly with imx-coda instead. What about other vendor SoCs implementing the Coda IP block which are not an imx? I'd prefer a more generic name - maybe media-coda. Thanks, Matt > > > Cheers, > Anders > >> >> Regards, >> >> Hans >> >>> obj-$(CONFIG_VIDEO_IMX_VDOA) += imx-vdoa.o >>> >>
Hi, On Mon, 2019-06-10 at 13:14 +0000, Matt Redfearn wrote: > > On 10/06/2019 14:03, Anders Roxell wrote: > > On Thu, 6 Jun 2019 at 12:13, Hans Verkuil <hverkuil@xs4all.nl> wrote: > > > > > > On 6/6/19 11:47 AM, Anders Roxell wrote: > > > > When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as > > > > loadable modules, we see the following warning: > > > > > > > > warning: same module names found: > > > > fs/coda/coda.ko > > > > drivers/media/platform/coda/coda.ko > > > > > > > > Rework so media coda matches the config fragment. Leaving CODA_FS as is > > > > since thats a well known module. > > > > > > > > Signed-off-by: Anders Roxell <anders.roxell@linaro.org> > > > > --- > > > > drivers/media/platform/coda/Makefile | 4 ++-- > > > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > > > > > diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile > > > > index 54e9a73a92ab..588e6bf7c190 100644 > > > > --- a/drivers/media/platform/coda/Makefile > > > > +++ b/drivers/media/platform/coda/Makefile > > > > @@ -1,6 +1,6 @@ > > > > # SPDX-License-Identifier: GPL-2.0-only > > > > > > > > -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > > > > +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > > > > > > > > -obj-$(CONFIG_VIDEO_CODA) += coda.o > > > > +obj-$(CONFIG_VIDEO_CODA) += video-coda.o > > > > > > How about imx-coda? video-coda suggests it is part of the video subsystem, > > > which it isn't. > > > > I'll resend a v2 shortly with imx-coda instead. I'd be in favor of calling it "coda-vpu" instead. > What about other vendor SoCs implementing the Coda IP block which are > not an imx? I'd prefer a more generic name - maybe media-coda. Right, this driver can be used on other SoCs [1]. [1] https://www.mail-archive.com/linux-media@vger.kernel.org/msg146498.html regards Philipp
On 6/11/19 10:15 AM, Philipp Zabel wrote: > Hi, > > On Mon, 2019-06-10 at 13:14 +0000, Matt Redfearn wrote: >> >> On 10/06/2019 14:03, Anders Roxell wrote: >>> On Thu, 6 Jun 2019 at 12:13, Hans Verkuil <hverkuil@xs4all.nl> wrote: >>>> >>>> On 6/6/19 11:47 AM, Anders Roxell wrote: >>>>> When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as >>>>> loadable modules, we see the following warning: >>>>> >>>>> warning: same module names found: >>>>> fs/coda/coda.ko >>>>> drivers/media/platform/coda/coda.ko >>>>> >>>>> Rework so media coda matches the config fragment. Leaving CODA_FS as is >>>>> since thats a well known module. >>>>> >>>>> Signed-off-by: Anders Roxell <anders.roxell@linaro.org> >>>>> --- >>>>> drivers/media/platform/coda/Makefile | 4 ++-- >>>>> 1 file changed, 2 insertions(+), 2 deletions(-) >>>>> >>>>> diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile >>>>> index 54e9a73a92ab..588e6bf7c190 100644 >>>>> --- a/drivers/media/platform/coda/Makefile >>>>> +++ b/drivers/media/platform/coda/Makefile >>>>> @@ -1,6 +1,6 @@ >>>>> # SPDX-License-Identifier: GPL-2.0-only >>>>> >>>>> -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o >>>>> +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o >>>>> >>>>> -obj-$(CONFIG_VIDEO_CODA) += coda.o >>>>> +obj-$(CONFIG_VIDEO_CODA) += video-coda.o >>>> >>>> How about imx-coda? video-coda suggests it is part of the video subsystem, >>>> which it isn't. >>> >>> I'll resend a v2 shortly with imx-coda instead. > > I'd be in favor of calling it "coda-vpu" instead. Fine by me! > >> What about other vendor SoCs implementing the Coda IP block which are >> not an imx? I'd prefer a more generic name - maybe media-coda. > > Right, this driver can be used on other SoCs [1]. Good point. Regards, Hans > > [1] https://www.mail-archive.com/linux-media@vger.kernel.org/msg146498.html > > regards > Philipp >
On Tue, 11 Jun 2019 at 10:21, Hans Verkuil <hverkuil@xs4all.nl> wrote: > > On 6/11/19 10:15 AM, Philipp Zabel wrote: > > Hi, > > > > On Mon, 2019-06-10 at 13:14 +0000, Matt Redfearn wrote: > >> > >> On 10/06/2019 14:03, Anders Roxell wrote: > >>> On Thu, 6 Jun 2019 at 12:13, Hans Verkuil <hverkuil@xs4all.nl> wrote: > >>>> > >>>> On 6/6/19 11:47 AM, Anders Roxell wrote: > >>>>> When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as > >>>>> loadable modules, we see the following warning: > >>>>> > >>>>> warning: same module names found: > >>>>> fs/coda/coda.ko > >>>>> drivers/media/platform/coda/coda.ko > >>>>> > >>>>> Rework so media coda matches the config fragment. Leaving CODA_FS as is > >>>>> since thats a well known module. > >>>>> > >>>>> Signed-off-by: Anders Roxell <anders.roxell@linaro.org> > >>>>> --- > >>>>> drivers/media/platform/coda/Makefile | 4 ++-- > >>>>> 1 file changed, 2 insertions(+), 2 deletions(-) > >>>>> > >>>>> diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile > >>>>> index 54e9a73a92ab..588e6bf7c190 100644 > >>>>> --- a/drivers/media/platform/coda/Makefile > >>>>> +++ b/drivers/media/platform/coda/Makefile > >>>>> @@ -1,6 +1,6 @@ > >>>>> # SPDX-License-Identifier: GPL-2.0-only > >>>>> > >>>>> -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > >>>>> +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o > >>>>> > >>>>> -obj-$(CONFIG_VIDEO_CODA) += coda.o > >>>>> +obj-$(CONFIG_VIDEO_CODA) += video-coda.o > >>>> > >>>> How about imx-coda? video-coda suggests it is part of the video subsystem, > >>>> which it isn't. > >>> > >>> I'll resend a v2 shortly with imx-coda instead. > > > > I'd be in favor of calling it "coda-vpu" instead. > > Fine by me! > > > > >> What about other vendor SoCs implementing the Coda IP block which are > >> not an imx? I'd prefer a more generic name - maybe media-coda. > > > > Right, this driver can be used on other SoCs [1]. > > Good point. OK, so I'll change it to 'media-coda'. Cheers, Anders > > Regards, > > Hans > > > > > [1] https://www.mail-archive.com/linux-media@vger.kernel.org/msg146498.html > > > > regards > > Philipp > > >
On Tue, 11 Jun 2019 at 18:18, Ezequiel Garcia <ezequiel@vanguardiasur.com.ar> wrote: > > > > On Tue, Jun 11, 2019, 1:01 PM Anders Roxell <anders.roxell@linaro.org> wrote: >> >> On Tue, 11 Jun 2019 at 10:21, Hans Verkuil <hverkuil@xs4all.nl> wrote: >> > >> > On 6/11/19 10:15 AM, Philipp Zabel wrote: >> > > Hi, >> > > >> > > On Mon, 2019-06-10 at 13:14 +0000, Matt Redfearn wrote: >> > >> >> > >> On 10/06/2019 14:03, Anders Roxell wrote: >> > >>> On Thu, 6 Jun 2019 at 12:13, Hans Verkuil <hverkuil@xs4all.nl> wrote: >> > >>>> >> > >>>> On 6/6/19 11:47 AM, Anders Roxell wrote: >> > >>>>> When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as >> > >>>>> loadable modules, we see the following warning: >> > >>>>> >> > >>>>> warning: same module names found: >> > >>>>> fs/coda/coda.ko >> > >>>>> drivers/media/platform/coda/coda.ko >> > >>>>> >> > >>>>> Rework so media coda matches the config fragment. Leaving CODA_FS as is >> > >>>>> since thats a well known module. >> > >>>>> >> > >>>>> Signed-off-by: Anders Roxell <anders.roxell@linaro.org> >> > >>>>> --- >> > >>>>> drivers/media/platform/coda/Makefile | 4 ++-- >> > >>>>> 1 file changed, 2 insertions(+), 2 deletions(-) >> > >>>>> >> > >>>>> diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile >> > >>>>> index 54e9a73a92ab..588e6bf7c190 100644 >> > >>>>> --- a/drivers/media/platform/coda/Makefile >> > >>>>> +++ b/drivers/media/platform/coda/Makefile >> > >>>>> @@ -1,6 +1,6 @@ >> > >>>>> # SPDX-License-Identifier: GPL-2.0-only >> > >>>>> >> > >>>>> -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o >> > >>>>> +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o >> > >>>>> >> > >>>>> -obj-$(CONFIG_VIDEO_CODA) += coda.o >> > >>>>> +obj-$(CONFIG_VIDEO_CODA) += video-coda.o >> > >>>> >> > >>>> How about imx-coda? video-coda suggests it is part of the video subsystem, >> > >>>> which it isn't. >> > >>> >> > >>> I'll resend a v2 shortly with imx-coda instead. >> > > >> > > I'd be in favor of calling it "coda-vpu" instead. >> > >> > Fine by me! >> > >> > > >> > >> What about other vendor SoCs implementing the Coda IP block which are >> > >> not an imx? I'd prefer a more generic name - maybe media-coda. >> > > >> > > Right, this driver can be used on other SoCs [1]. >> > >> > Good point. >> >> OK, so I'll change it to 'media-coda'. >> >> >> > > As suggested by Philipp, coda-vpu seems the most accurate name. urgh, that correct. Thanks, Anders > > Thanks, > Ezequiel > > > >> Cheers, >> Anders >> >> > >> > Regards, >> > >> > Hans >> > >> > > >> > > [1] https://www.mail-archive.com/linux-media@vger.kernel.org/msg146498.html >> > > >> > > regards >> > > Philipp >> > > >> >
diff --git a/drivers/media/platform/coda/Makefile b/drivers/media/platform/coda/Makefile index 54e9a73a92ab..588e6bf7c190 100644 --- a/drivers/media/platform/coda/Makefile +++ b/drivers/media/platform/coda/Makefile @@ -1,6 +1,6 @@ # SPDX-License-Identifier: GPL-2.0-only -coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o +video-coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-mpeg2.o coda-mpeg4.o coda-jpeg.o -obj-$(CONFIG_VIDEO_CODA) += coda.o +obj-$(CONFIG_VIDEO_CODA) += video-coda.o obj-$(CONFIG_VIDEO_IMX_VDOA) += imx-vdoa.o
When building with CONFIG_VIDEO_CODA and CONFIG_CODA_FS enabled as loadable modules, we see the following warning: warning: same module names found: fs/coda/coda.ko drivers/media/platform/coda/coda.ko Rework so media coda matches the config fragment. Leaving CODA_FS as is since thats a well known module. Signed-off-by: Anders Roxell <anders.roxell@linaro.org> --- drivers/media/platform/coda/Makefile | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)