Message ID | 20190627073615.15573-1-chris@chris-wilson.co.uk (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [i-g-t] i915/gem_pread/pwrite: Rename "basic" | expand |
On Thu, 2019-06-27 at 08:36 +0100, Chris Wilson wrote: > The "basic" subtests perform no verification that the read/write work, > only function as mere API exercisers and loose benchmarks. Rename them > to reflect that they are poor benchmarks instead. > > Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk> Reviewed-by: Simon Ser <simon.ser@intel.com> > --- > tests/i915/gem_pread.c | 2 +- > tests/i915/gem_pwrite.c | 2 +- > tests/intel-ci/fast-feedback.testlist | 2 -- > 3 files changed, 2 insertions(+), 4 deletions(-) > > diff --git a/tests/i915/gem_pread.c b/tests/i915/gem_pread.c > index c64787653..0d3e10b80 100644 > --- a/tests/i915/gem_pread.c > +++ b/tests/i915/gem_pread.c > @@ -159,7 +159,7 @@ igt_main_args("s:", NULL, help_str, opt_handler, NULL) > dst_user = malloc(object_size); > } > > - igt_subtest("basic") { > + igt_subtest("bench") { > for (count = 1; count <= 1<<17; count <<= 1) { > struct timeval start, end; > > diff --git a/tests/i915/gem_pwrite.c b/tests/i915/gem_pwrite.c > index 97703a2aa..37e978791 100644 > --- a/tests/i915/gem_pwrite.c > +++ b/tests/i915/gem_pwrite.c > @@ -286,7 +286,7 @@ igt_main_args("s:", NULL, help_str, opt_handler, NULL) > src_user = malloc(object_size); > } > > - igt_subtest("basic") { > + igt_subtest("bench") { > for (count = 1; count <= 1<<17; count <<= 1) { > struct timeval start, end; > > diff --git a/tests/intel-ci/fast-feedback.testlist b/tests/intel-ci/fast-feedback.testlist > index 8618dfd28..5fcb5e76d 100644 > --- a/tests/intel-ci/fast-feedback.testlist > +++ b/tests/intel-ci/fast-feedback.testlist > @@ -87,8 +87,6 @@ igt@gem_mmap_gtt@basic-write-gtt-no-prefault > igt@gem_mmap_gtt@basic-write-no-prefault > igt@gem_mmap_gtt@basic-write-read > igt@gem_mmap_gtt@basic-write-read-distinct > -igt@gem_pread@basic > -igt@gem_pwrite@basic > igt@gem_render_linear_blits@basic > igt@gem_render_tiled_blits@basic > igt@gem_ringfill@basic-default
On Thu, Jun 27, 2019 at 08:18:36AM +0000, Ser, Simon wrote: > On Thu, 2019-06-27 at 08:36 +0100, Chris Wilson wrote: > > The "basic" subtests perform no verification that the read/write work, > > only function as mere API exercisers and loose benchmarks. Rename them > > to reflect that they are poor benchmarks instead. > > > > Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk> > > Reviewed-by: Simon Ser <simon.ser@intel.com> you forgot to add r-b while pushing Tests are now renamed in the cibuglog, so all the existing filters (1) will apply. It's nice to CC someone handling cibuglog when renaming, otherwise we will end up with more noise and spend time on creating and deduplicating bugs later on.
On 27/06/2019 16:26, Arkadiusz Hiler wrote: > On Thu, Jun 27, 2019 at 08:18:36AM +0000, Ser, Simon wrote: >> On Thu, 2019-06-27 at 08:36 +0100, Chris Wilson wrote: >>> The "basic" subtests perform no verification that the read/write work, >>> only function as mere API exercisers and loose benchmarks. Rename them >>> to reflect that they are poor benchmarks instead. >>> >>> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk> >> >> Reviewed-by: Simon Ser <simon.ser@intel.com> > > you forgot to add r-b while pushing > > Tests are now renamed in the cibuglog, so all the existing filters (1) > will apply. It's nice to CC someone handling cibuglog when renaming, > otherwise we will end up with more noise and spend time on creating and > deduplicating bugs later on. My fault. I gave the ACK but had not done the rename yet. Sorry about that! Martin > _______________________________________________ > Intel-gfx mailing list > Intel-gfx@lists.freedesktop.org > https://lists.freedesktop.org/mailman/listinfo/intel-gfx >
diff --git a/tests/i915/gem_pread.c b/tests/i915/gem_pread.c index c64787653..0d3e10b80 100644 --- a/tests/i915/gem_pread.c +++ b/tests/i915/gem_pread.c @@ -159,7 +159,7 @@ igt_main_args("s:", NULL, help_str, opt_handler, NULL) dst_user = malloc(object_size); } - igt_subtest("basic") { + igt_subtest("bench") { for (count = 1; count <= 1<<17; count <<= 1) { struct timeval start, end; diff --git a/tests/i915/gem_pwrite.c b/tests/i915/gem_pwrite.c index 97703a2aa..37e978791 100644 --- a/tests/i915/gem_pwrite.c +++ b/tests/i915/gem_pwrite.c @@ -286,7 +286,7 @@ igt_main_args("s:", NULL, help_str, opt_handler, NULL) src_user = malloc(object_size); } - igt_subtest("basic") { + igt_subtest("bench") { for (count = 1; count <= 1<<17; count <<= 1) { struct timeval start, end; diff --git a/tests/intel-ci/fast-feedback.testlist b/tests/intel-ci/fast-feedback.testlist index 8618dfd28..5fcb5e76d 100644 --- a/tests/intel-ci/fast-feedback.testlist +++ b/tests/intel-ci/fast-feedback.testlist @@ -87,8 +87,6 @@ igt@gem_mmap_gtt@basic-write-gtt-no-prefault igt@gem_mmap_gtt@basic-write-no-prefault igt@gem_mmap_gtt@basic-write-read igt@gem_mmap_gtt@basic-write-read-distinct -igt@gem_pread@basic -igt@gem_pwrite@basic igt@gem_render_linear_blits@basic igt@gem_render_tiled_blits@basic igt@gem_ringfill@basic-default
The "basic" subtests perform no verification that the read/write work, only function as mere API exercisers and loose benchmarks. Rename them to reflect that they are poor benchmarks instead. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk> --- tests/i915/gem_pread.c | 2 +- tests/i915/gem_pwrite.c | 2 +- tests/intel-ci/fast-feedback.testlist | 2 -- 3 files changed, 2 insertions(+), 4 deletions(-)