diff mbox series

[v2] iio: light: bh1750: Resolve compiler warning and make code more readable

Message ID 20190910203814.31075-1-kw@linux.com (mailing list archive)
State New, archived
Headers show
Series [v2] iio: light: bh1750: Resolve compiler warning and make code more readable | expand

Commit Message

Krzysztof Wilczyński Sept. 10, 2019, 8:38 p.m. UTC
Separate the declaration from definition of bh1750_chip_info_tbl
to make the code more readable.  Separating the code will resolve
the following compiler warning that can be seen when building
with warnings enabled (W=1):

drivers/iio/light/bh1750.c:64:1: warning:
  ‘static’ is not at beginning of declaration [-Wold-style-declaration]

Signed-off-by: Krzysztof Wilczynski <kw@linux.com>
---
Changes in v2:
  Made definition of bh1750_chip_info_tbl separate from declaration
  as per the review feedback.  This also makes the code more readable.
  Updated wording of the subject and the commit message.

 drivers/iio/light/bh1750.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Uwe Kleine-König Sept. 10, 2019, 9:04 p.m. UTC | #1
On Tue, Sep 10, 2019 at 10:38:14PM +0200, Krzysztof Wilczynski wrote:
> Separate the declaration from definition of bh1750_chip_info_tbl
> to make the code more readable.  Separating the code will resolve
> the following compiler warning that can be seen when building
> with warnings enabled (W=1):

This commit log isn't completely accurate. Before we had a definition of
a struct that was instantly (i.e. without repeating the type name) used
as type for an array. (And not a declaration and definition of
bh1750_chip_info_tbl.)

So I'd write:

	Don't mix declaring struct bh1750_chip_info and defining
	bh1750_chip_info_tbl[] in a single statement. This is hard to
	read, with warnings enabled gcc warns about the unusual position
	of the keyword static:
	
		drivers/iio/light/bh1750.c:64:1: warning: ‘static’ is not at beginning of declaration [-Wold-style-declaration]
	
	and with the empty line this looks as if bh1750_chip_info_tbl
	had no explicit type.

If you want add

	Fixes: 3a11fbb037a1 ("iio: light: add support for ROHM BH1710/BH1715/BH1721/BH1750/BH1751 ambient light sensors")

and add Tomasz Duszynski <tduszyns@gmail.com> to Cc who authored
3a11fbb037a1.

> ---
> Changes in v2:
>   Made definition of bh1750_chip_info_tbl separate from declaration
>   as per the review feedback.  This also makes the code more readable.
>   Updated wording of the subject and the commit message.
> 
>  drivers/iio/light/bh1750.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/iio/light/bh1750.c b/drivers/iio/light/bh1750.c
> index 28347df78cff..adb5ab9e3439 100644
> --- a/drivers/iio/light/bh1750.c
> +++ b/drivers/iio/light/bh1750.c
> @@ -59,9 +59,9 @@ struct bh1750_chip_info {
>  
>  	u16 int_time_low_mask;
>  	u16 int_time_high_mask;
> -}
> +};
>  
> -static const bh1750_chip_info_tbl[] = {
> +static const struct bh1750_chip_info bh1750_chip_info_tbl[] = {
>  	[BH1710] = { 140, 1022, 300, 400,  250000000, 2, 0x001F, 0x03E0 },
>  	[BH1721] = { 140, 1020, 300, 400,  250000000, 2, 0x0010, 0x03E0 },
>  	[BH1750] = { 31,  254,  69,  1740, 57500000,  1, 0x001F, 0x00E0 },

The patch looks fine. If you adapt the commit log as suggested above
take my

Acked-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>

Best regards
Uwe
diff mbox series

Patch

diff --git a/drivers/iio/light/bh1750.c b/drivers/iio/light/bh1750.c
index 28347df78cff..adb5ab9e3439 100644
--- a/drivers/iio/light/bh1750.c
+++ b/drivers/iio/light/bh1750.c
@@ -59,9 +59,9 @@  struct bh1750_chip_info {
 
 	u16 int_time_low_mask;
 	u16 int_time_high_mask;
-}
+};
 
-static const bh1750_chip_info_tbl[] = {
+static const struct bh1750_chip_info bh1750_chip_info_tbl[] = {
 	[BH1710] = { 140, 1022, 300, 400,  250000000, 2, 0x001F, 0x03E0 },
 	[BH1721] = { 140, 1020, 300, 400,  250000000, 2, 0x0010, 0x03E0 },
 	[BH1750] = { 31,  254,  69,  1740, 57500000,  1, 0x001F, 0x00E0 },