Message ID | 20190917114457.886-1-stefanha@redhat.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | virtio-fs: rename num_queues to num_request_queues | expand |
* Stefan Hajnoczi (stefanha@redhat.com) wrote: > The final version of the virtio-fs device specification renamed the > num_queues field to num_request_queues. The semantics are unchanged but > this name is clearer. > > Use the new name in the code. > > Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com> Consistent with the latest version that's just passed the voting; (see https://lists.oasis-open.org/archives/virtio-dev/201908/msg00113.html ) so: Reviewed-by: Dr. David Alan Gilbert <dgilbert@redhat.com> > --- > Feel free to squash this patch. > --- > include/uapi/linux/virtio_fs.h | 2 +- > fs/fuse/virtio_fs.c | 12 ++++++------ > 2 files changed, 7 insertions(+), 7 deletions(-) > > diff --git a/include/uapi/linux/virtio_fs.h b/include/uapi/linux/virtio_fs.h > index b5e99c217c86..b02eb2ac3d99 100644 > --- a/include/uapi/linux/virtio_fs.h > +++ b/include/uapi/linux/virtio_fs.h > @@ -13,7 +13,7 @@ struct virtio_fs_config { > __u8 tag[36]; > > /* Number of request queues */ > - __u32 num_queues; > + __u32 num_request_queues; > } __attribute__((packed)); > > #endif /* _UAPI_LINUX_VIRTIO_FS_H */ > diff --git a/fs/fuse/virtio_fs.c b/fs/fuse/virtio_fs.c > index 392b9e7d9ddf..ccfa4f741f7f 100644 > --- a/fs/fuse/virtio_fs.c > +++ b/fs/fuse/virtio_fs.c > @@ -43,8 +43,8 @@ struct virtio_fs { > struct list_head list; /* on virtio_fs_instances */ > char *tag; > struct virtio_fs_vq *vqs; > - unsigned int nvqs; /* number of virtqueues */ > - unsigned int num_queues; /* number of request queues */ > + unsigned int nvqs; /* number of virtqueues */ > + unsigned int num_request_queues; /* number of request queues */ > }; > > struct virtio_fs_forget { > @@ -477,12 +477,12 @@ static int virtio_fs_setup_vqs(struct virtio_device *vdev, > unsigned int i; > int ret = 0; > > - virtio_cread(vdev, struct virtio_fs_config, num_queues, > - &fs->num_queues); > - if (fs->num_queues == 0) > + virtio_cread(vdev, struct virtio_fs_config, num_request_queues, > + &fs->num_request_queues); > + if (fs->num_request_queues == 0) > return -EINVAL; > > - fs->nvqs = 1 + fs->num_queues; > + fs->nvqs = 1 + fs->num_request_queues; > fs->vqs = kcalloc(fs->nvqs, sizeof(fs->vqs[VQ_HIPRIO]), GFP_KERNEL); > if (!fs->vqs) > return -ENOMEM; > -- > 2.21.0 > -- Dr. David Alan Gilbert / dgilbert@redhat.com / Manchester, UK
On Wed, Sep 18, 2019 at 6:48 PM Dr. David Alan Gilbert <dgilbert@redhat.com> wrote: > > * Stefan Hajnoczi (stefanha@redhat.com) wrote: > > The final version of the virtio-fs device specification renamed the > > num_queues field to num_request_queues. The semantics are unchanged but > > this name is clearer. > > > > Use the new name in the code. > > > > Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com> > > Consistent with the latest version that's just passed the voting; > (see > https://lists.oasis-open.org/archives/virtio-dev/201908/msg00113.html ) > so: > > > Reviewed-by: Dr. David Alan Gilbert <dgilbert@redhat.com> > > > --- > > Feel free to squash this patch. Thanks, folded this one as well. Miklos
On Wed, Sep 18, 2019 at 08:22:06PM +0200, Miklos Szeredi wrote: > On Wed, Sep 18, 2019 at 6:48 PM Dr. David Alan Gilbert > <dgilbert@redhat.com> wrote: > > > > * Stefan Hajnoczi (stefanha@redhat.com) wrote: > > > The final version of the virtio-fs device specification renamed the > > > num_queues field to num_request_queues. The semantics are unchanged but > > > this name is clearer. > > > > > > Use the new name in the code. > > > > > > Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com> > > > > Consistent with the latest version that's just passed the voting; > > (see > > https://lists.oasis-open.org/archives/virtio-dev/201908/msg00113.html ) > > so: > > > > > > Reviewed-by: Dr. David Alan Gilbert <dgilbert@redhat.com> > > > > > --- > > > Feel free to squash this patch. > > Thanks, folded this one as well. > > Miklos So what's the plan for merging all this? Doesn't look like it was sent in the merge window, nor is it in linux-next.
On Wed, Sep 25, 2019 at 4:23 PM Michael S. Tsirkin <mst@redhat.com> wrote: > > On Wed, Sep 18, 2019 at 08:22:06PM +0200, Miklos Szeredi wrote: > > On Wed, Sep 18, 2019 at 6:48 PM Dr. David Alan Gilbert > > <dgilbert@redhat.com> wrote: > > > > > > * Stefan Hajnoczi (stefanha@redhat.com) wrote: > > > > The final version of the virtio-fs device specification renamed the > > > > num_queues field to num_request_queues. The semantics are unchanged but > > > > this name is clearer. > > > > > > > > Use the new name in the code. > > > > > > > > Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com> > > > > > > Consistent with the latest version that's just passed the voting; > > > (see > > > https://lists.oasis-open.org/archives/virtio-dev/201908/msg00113.html ) > > > so: > > > > > > > > > Reviewed-by: Dr. David Alan Gilbert <dgilbert@redhat.com> > > > > > > > --- > > > > Feel free to squash this patch. > > > > Thanks, folded this one as well. > > > > Miklos > > So what's the plan for merging all this? > Doesn't look like it was sent in the merge window, nor is > it in linux-next. It should be. Sent pull request for fuse update today; this includes changes required for virtio-fs. Planning to send pull request for virtio-fs itself tomorrow. Thanks, Miklos
* Michael S. Tsirkin (mst@redhat.com) wrote: > On Wed, Sep 18, 2019 at 08:22:06PM +0200, Miklos Szeredi wrote: > > On Wed, Sep 18, 2019 at 6:48 PM Dr. David Alan Gilbert > > <dgilbert@redhat.com> wrote: > > > > > > * Stefan Hajnoczi (stefanha@redhat.com) wrote: > > > > The final version of the virtio-fs device specification renamed the > > > > num_queues field to num_request_queues. The semantics are unchanged but > > > > this name is clearer. > > > > > > > > Use the new name in the code. > > > > > > > > Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com> > > > > > > Consistent with the latest version that's just passed the voting; > > > (see > > > https://lists.oasis-open.org/archives/virtio-dev/201908/msg00113.html ) > > > so: > > > > > > > > > Reviewed-by: Dr. David Alan Gilbert <dgilbert@redhat.com> > > > > > > > --- > > > > Feel free to squash this patch. > > > > Thanks, folded this one as well. > > > > Miklos > > So what's the plan for merging all this? > Doesn't look like it was sent in the merge window, nor is > it in linux-next. It's in the version that got merged upstream over the weekend. Dave > -- > MST -- Dr. David Alan Gilbert / dgilbert@redhat.com / Manchester, UK
diff --git a/include/uapi/linux/virtio_fs.h b/include/uapi/linux/virtio_fs.h index b5e99c217c86..b02eb2ac3d99 100644 --- a/include/uapi/linux/virtio_fs.h +++ b/include/uapi/linux/virtio_fs.h @@ -13,7 +13,7 @@ struct virtio_fs_config { __u8 tag[36]; /* Number of request queues */ - __u32 num_queues; + __u32 num_request_queues; } __attribute__((packed)); #endif /* _UAPI_LINUX_VIRTIO_FS_H */ diff --git a/fs/fuse/virtio_fs.c b/fs/fuse/virtio_fs.c index 392b9e7d9ddf..ccfa4f741f7f 100644 --- a/fs/fuse/virtio_fs.c +++ b/fs/fuse/virtio_fs.c @@ -43,8 +43,8 @@ struct virtio_fs { struct list_head list; /* on virtio_fs_instances */ char *tag; struct virtio_fs_vq *vqs; - unsigned int nvqs; /* number of virtqueues */ - unsigned int num_queues; /* number of request queues */ + unsigned int nvqs; /* number of virtqueues */ + unsigned int num_request_queues; /* number of request queues */ }; struct virtio_fs_forget { @@ -477,12 +477,12 @@ static int virtio_fs_setup_vqs(struct virtio_device *vdev, unsigned int i; int ret = 0; - virtio_cread(vdev, struct virtio_fs_config, num_queues, - &fs->num_queues); - if (fs->num_queues == 0) + virtio_cread(vdev, struct virtio_fs_config, num_request_queues, + &fs->num_request_queues); + if (fs->num_request_queues == 0) return -EINVAL; - fs->nvqs = 1 + fs->num_queues; + fs->nvqs = 1 + fs->num_request_queues; fs->vqs = kcalloc(fs->nvqs, sizeof(fs->vqs[VQ_HIPRIO]), GFP_KERNEL); if (!fs->vqs) return -ENOMEM;
The final version of the virtio-fs device specification renamed the num_queues field to num_request_queues. The semantics are unchanged but this name is clearer. Use the new name in the code. Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com> --- Feel free to squash this patch. --- include/uapi/linux/virtio_fs.h | 2 +- fs/fuse/virtio_fs.c | 12 ++++++------ 2 files changed, 7 insertions(+), 7 deletions(-)