mbox series

[v6,0/3] mm, slab: Make kmalloc_info[] contain all types of names

Message ID 1569241648-26908-1-git-send-email-lpf.vector@gmail.com (mailing list archive)
Headers show
Series mm, slab: Make kmalloc_info[] contain all types of names | expand

Message

Pengfei Li Sept. 23, 2019, 12:27 p.m. UTC
Changes in v6
--
1. abandon patch 4-7 (Because there is not enough reason to explain
that they are beneficial)

Changes in v5
--
1. patch 1/7:
    - rename SET_KMALLOC_SIZE to INIT_KMALLOC_INFO
2. patch 5/7:
    - fix build errors (Reported-by: kbuild test robot)
    - make all_kmalloc_info[] static (Reported-by: kbuild test robot)
3. patch 6/7:
    - for robustness, determine kmalloc_cache is !NULL in
      new_kmalloc_cache()
4. add ack tag from David Rientjes

Changes in v4
--
1. [old] abandon patch 4/4
2. [new] patch 4/7:
    - return ZERO_SIZE_ALLOC instead 0 for zero sized requests
3. [new] patch 5/7:
    - reorder kmalloc_info[], kmalloc_caches[] (in order of size)
    - hard to split, so slightly larger
4. [new] patch 6/7:
    - initialize kmalloc_cache[] with the same size but different
      types
5. [new] patch 7/7:
    - modify kmalloc_caches[type][idx] to kmalloc_caches[idx][type]

Patch 4-7 are newly added, more information can be obtained from
commit messages.

Changes in v3
--
1. restore __initconst (patch 1/4)
2. rename patch 3/4
3. add more clarification for patch 4/4
4. add ack tag from Roman Gushchin

Changes in v2
--
1. remove __initconst (patch 1/5)
2. squash patch 2/5
3. add ack tag from Vlastimil Babka


There are three types of kmalloc, KMALLOC_NORMAL, KMALLOC_RECLAIM
and KMALLOC_DMA.

The name of KMALLOC_NORMAL is contained in kmalloc_info[].name,
but the names of KMALLOC_RECLAIM and KMALLOC_DMA are dynamically
generated by kmalloc_cache_name().

Patch1 predefines the names of all types of kmalloc to save
the time spent dynamically generating names.

These changes make sense, and the time spent by new_kmalloc_cache()
has been reduced by approximately 36.3%.

                         Time spent by new_kmalloc_cache()
                                  (CPU cycles)
5.3-rc7                              66264
5.3-rc7+patch                        42188

Pengfei Li (3):
  mm, slab: Make kmalloc_info[] contain all types of names
  mm, slab: Remove unused kmalloc_size()
  mm, slab_common: Use enum kmalloc_cache_type to iterate over kmalloc
    caches

 include/linux/slab.h | 20 -----------
 mm/slab.c            |  7 ++--
 mm/slab.h            |  2 +-
 mm/slab_common.c     | 99 ++++++++++++++++++++++++++++------------------------
 4 files changed, 58 insertions(+), 70 deletions(-)

Comments

Andrew Morton Oct. 2, 2019, 11:06 p.m. UTC | #1
On Mon, 23 Sep 2019 20:27:25 +0800 Pengfei Li <lpf.vector@gmail.com> wrote:

> Changes in v6
> --
> 1. abandon patch 4-7 (Because there is not enough reason to explain
> that they are beneficial)

So http://lkml.kernel.org/r/20190923004022.GC15734@shao2-debian can no
longer occur?

> Changes in v5
> --
> 1. patch 1/7:
>     - rename SET_KMALLOC_SIZE to INIT_KMALLOC_INFO
> 2. patch 5/7:
>     - fix build errors (Reported-by: kbuild test robot)
>     - make all_kmalloc_info[] static (Reported-by: kbuild test robot)
> 3. patch 6/7:
>     - for robustness, determine kmalloc_cache is !NULL in
>       new_kmalloc_cache()
> 4. add ack tag from David Rientjes
>
Pengfei Li Oct. 8, 2019, 2:21 p.m. UTC | #2
On Thu, Oct 3, 2019 at 7:06 AM Andrew Morton <akpm@linux-foundation.org> wrote:
>
> On Mon, 23 Sep 2019 20:27:25 +0800 Pengfei Li <lpf.vector@gmail.com> wrote:
>
> > Changes in v6
> > --
> > 1. abandon patch 4-7 (Because there is not enough reason to explain
> > that they are beneficial)
>
> So http://lkml.kernel.org/r/20190923004022.GC15734@shao2-debian can no
> longer occur?
>

Sorry for such a late reply.

Yes, it‘s caused by [patch v5 5/7]. So do not occur in v6.

> > Changes in v5
> > --
> > 1. patch 1/7:
> >     - rename SET_KMALLOC_SIZE to INIT_KMALLOC_INFO
> > 2. patch 5/7:
> >     - fix build errors (Reported-by: kbuild test robot)
> >     - make all_kmalloc_info[] static (Reported-by: kbuild test robot)
> > 3. patch 6/7:
> >     - for robustness, determine kmalloc_cache is !NULL in
> >       new_kmalloc_cache()
> > 4. add ack tag from David Rientjes
> >
>
>
>