mbox series

[0/7] BLAKE2b cleanups

Message ID cover.1573047517.git.dsterba@suse.com (mailing list archive)
Headers show
Series BLAKE2b cleanups | expand

Message

David Sterba Nov. 6, 2019, 1:48 p.m. UTC
Hi,

the patchset implements cleanups suggested by Eric in
https://lore.kernel.org/linux-crypto/20191025051550.GA103313@sol.localdomain/

The diff is the same, split into pieces with some additional comments
where it would help understand the simplifications. This is based on v7
of the BLAKE2b patchset.

The self-tests have been run for each patch on x86_64.

David Sterba (7):
  crypto: blake2b: merge _final implementation to callback
  crypto: blake2b: merge blake2 init to api callback
  crypto: blake2b: simplify key init
  crypto: blake2b: delete unused structs or members
  crypto: blake2b: open code set last block helper
  crypto: blake2b: merge _update to api callback
  crypto: blake2b: rename tfm context

 crypto/blake2b_generic.c | 267 +++++++++++----------------------------
 1 file changed, 76 insertions(+), 191 deletions(-)

Comments

Eric Biggers Nov. 8, 2019, 2:13 a.m. UTC | #1
On Wed, Nov 06, 2019 at 02:48:24PM +0100, David Sterba wrote:
> Hi,
> 
> the patchset implements cleanups suggested by Eric in
> https://lore.kernel.org/linux-crypto/20191025051550.GA103313@sol.localdomain/
> 
> The diff is the same, split into pieces with some additional comments
> where it would help understand the simplifications. This is based on v7
> of the BLAKE2b patchset.
> 

Actually the diff isn't quite the same.  Your version looks fine though, except
that I think digest_setkey() should be renamed to blake2b_setkey().  Otherwise
it's inconsistent, since all the other digest_*() functions were renamed.

Thanks!

- Eric
David Sterba Nov. 9, 2019, 11:05 p.m. UTC | #2
On Thu, Nov 07, 2019 at 06:13:29PM -0800, Eric Biggers wrote:
> On Wed, Nov 06, 2019 at 02:48:24PM +0100, David Sterba wrote:
> > the patchset implements cleanups suggested by Eric in
> > https://lore.kernel.org/linux-crypto/20191025051550.GA103313@sol.localdomain/
> > 
> > The diff is the same, split into pieces with some additional comments
> > where it would help understand the simplifications. This is based on v7
> > of the BLAKE2b patchset.
> 
> Actually the diff isn't quite the same.  Your version looks fine though, except
> that I think digest_setkey() should be renamed to blake2b_setkey().  Otherwise
> it's inconsistent, since all the other digest_*() functions were renamed.

Right, digest_* was a leftover from a working version. I'll send V2.
Thanks for the review.