Message ID | 20191218151350.19579-3-animesh.manna@intel.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | DP Phy compliance auto test | expand |
On 2019-12-18 10:13 a.m., Animesh Manna wrote: > [Why]: > Aligh with DP spec wanted to follow same naming convention. > > [How]: > Changed the macro name of the dpcd address used for getting requested > test-pattern. > Please roll this into your patch that renames the definition. All patches should compile on their own. Thanks, Harry > Cc: Harry Wentland <harry.wentland@amd.com> > Cc: Alex Deucher <alexander.deucher@amd.com> > Signed-off-by: Animesh Manna <animesh.manna@intel.com> > --- > drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c b/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c > index 42aa889fd0f5..1a6109be2fce 100644 > --- a/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c > +++ b/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c > @@ -2491,7 +2491,7 @@ static void dp_test_send_phy_test_pattern(struct dc_link *link) > /* get phy test pattern and pattern parameters from DP receiver */ > core_link_read_dpcd( > link, > - DP_TEST_PHY_PATTERN, > + DP_PHY_TEST_PATTERN, > &dpcd_test_pattern.raw, > sizeof(dpcd_test_pattern)); > core_link_read_dpcd( >
On 18-12-2019 21:12, Harry Wentland wrote: > On 2019-12-18 10:13 a.m., Animesh Manna wrote: >> [Why]: >> Aligh with DP spec wanted to follow same naming convention. >> >> [How]: >> Changed the macro name of the dpcd address used for getting requested >> test-pattern. >> > Please roll this into your patch that renames the definition. All > patches should compile on their own. Thanks Harry for review, wanted to follow similar commit-description format followed in amd-driver compare to i915 and created a separate patch. Maybe is it good idea to change the patch sequence and make it as first patch. Regards, Animesh > > Thanks, > Harry > >> Cc: Harry Wentland <harry.wentland@amd.com> >> Cc: Alex Deucher <alexander.deucher@amd.com> >> Signed-off-by: Animesh Manna <animesh.manna@intel.com> >> --- >> drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c | 2 +- >> 1 file changed, 1 insertion(+), 1 deletion(-) >> >> diff --git a/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c b/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c >> index 42aa889fd0f5..1a6109be2fce 100644 >> --- a/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c >> +++ b/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c >> @@ -2491,7 +2491,7 @@ static void dp_test_send_phy_test_pattern(struct dc_link *link) >> /* get phy test pattern and pattern parameters from DP receiver */ >> core_link_read_dpcd( >> link, >> - DP_TEST_PHY_PATTERN, >> + DP_PHY_TEST_PATTERN, >> &dpcd_test_pattern.raw, >> sizeof(dpcd_test_pattern)); >> core_link_read_dpcd( >>
On 2019-12-18 11:13 a.m., Manna, Animesh wrote: > > On 18-12-2019 21:12, Harry Wentland wrote: >> On 2019-12-18 10:13 a.m., Animesh Manna wrote: >>> [Why]: >>> Aligh with DP spec wanted to follow same naming convention. >>> >>> [How]: >>> Changed the macro name of the dpcd address used for getting requested >>> test-pattern. >>> >> Please roll this into your patch that renames the definition. All >> patches should compile on their own. > > > Thanks Harry for review, wanted to follow similar commit-description > format followed in amd-driver compare to i915 and created a separate > patch. Maybe is it good idea to change the patch sequence and make it as > first patch. > Thanks for looking to follow the commit style from the rest of the amd driver but in this case we need to combine them or you'll be left with one patch in the sequence that won't build on its own. Harry > Regards, > Animesh > >> >> Thanks, >> Harry >> >>> Cc: Harry Wentland <harry.wentland@amd.com> >>> Cc: Alex Deucher <alexander.deucher@amd.com> >>> Signed-off-by: Animesh Manna <animesh.manna@intel.com> >>> --- >>> drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c | 2 +- >>> 1 file changed, 1 insertion(+), 1 deletion(-) >>> >>> diff --git a/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c >>> b/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c >>> index 42aa889fd0f5..1a6109be2fce 100644 >>> --- a/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c >>> +++ b/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c >>> @@ -2491,7 +2491,7 @@ static void >>> dp_test_send_phy_test_pattern(struct dc_link *link) >>> /* get phy test pattern and pattern parameters from DP receiver */ >>> core_link_read_dpcd( >>> link, >>> - DP_TEST_PHY_PATTERN, >>> + DP_PHY_TEST_PATTERN, >>> &dpcd_test_pattern.raw, >>> sizeof(dpcd_test_pattern)); >>> core_link_read_dpcd( >>>
On Wed, Dec 18, 2019 at 09:43:49PM +0530, Manna, Animesh wrote: > > On 18-12-2019 21:12, Harry Wentland wrote: > >On 2019-12-18 10:13 a.m., Animesh Manna wrote: > >>[Why]: > >>Aligh with DP spec wanted to follow same naming convention. > >> > >>[How]: > >>Changed the macro name of the dpcd address used for getting requested > >>test-pattern. > >> > >Please roll this into your patch that renames the definition. All > >patches should compile on their own. > > > Thanks Harry for review, wanted to follow similar commit-description format > followed in amd-driver compare to i915 and created a separate patch. Maybe > is it good idea to change the patch sequence and make it as first patch. > > Regards, > Animesh Like Harry said, all these changes should happen in the same patch that renames the DP_TEST_PHY_PATTERN which is patch 1/9 because like you see the build still fails now since patch 1 doesnt compile. So the idea would be in patch 1 - rename, make changes in AMD and existing place where it gets used Patch 2 - get/set PHY test paarams that use this renamed value Manasi > > > > >Thanks, > >Harry > > > >>Cc: Harry Wentland <harry.wentland@amd.com> > >>Cc: Alex Deucher <alexander.deucher@amd.com> > >>Signed-off-by: Animesh Manna <animesh.manna@intel.com> > >>--- > >> drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c | 2 +- > >> 1 file changed, 1 insertion(+), 1 deletion(-) > >> > >>diff --git a/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c b/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c > >>index 42aa889fd0f5..1a6109be2fce 100644 > >>--- a/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c > >>+++ b/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c > >>@@ -2491,7 +2491,7 @@ static void dp_test_send_phy_test_pattern(struct dc_link *link) > >> /* get phy test pattern and pattern parameters from DP receiver */ > >> core_link_read_dpcd( > >> link, > >>- DP_TEST_PHY_PATTERN, > >>+ DP_PHY_TEST_PATTERN, > >> &dpcd_test_pattern.raw, > >> sizeof(dpcd_test_pattern)); > >> core_link_read_dpcd( > >>
On 19-12-2019 05:23, Manasi Navare wrote: > On Wed, Dec 18, 2019 at 09:43:49PM +0530, Manna, Animesh wrote: >> On 18-12-2019 21:12, Harry Wentland wrote: >>> On 2019-12-18 10:13 a.m., Animesh Manna wrote: >>>> [Why]: >>>> Aligh with DP spec wanted to follow same naming convention. >>>> >>>> [How]: >>>> Changed the macro name of the dpcd address used for getting requested >>>> test-pattern. >>>> >>> Please roll this into your patch that renames the definition. All >>> patches should compile on their own. >> >> Thanks Harry for review, wanted to follow similar commit-description format >> followed in amd-driver compare to i915 and created a separate patch. Maybe >> is it good idea to change the patch sequence and make it as first patch. >> >> Regards, >> Animesh > Like Harry said, all these changes should happen in the same patch that renames the DP_TEST_PHY_PATTERN > which is patch 1/9 because like you see the build still fails now since patch 1 doesnt compile. > > So the idea would be in patch 1 - rename, make changes in AMD and existing place where it gets used > Patch 2 - get/set PHY test paarams that use this renamed value Thanks Manasi. Yes, I want to mean the same. Regards, Animesh > > Manasi > >>> Thanks, >>> Harry >>> >>>> Cc: Harry Wentland <harry.wentland@amd.com> >>>> Cc: Alex Deucher <alexander.deucher@amd.com> >>>> Signed-off-by: Animesh Manna <animesh.manna@intel.com> >>>> --- >>>> drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c | 2 +- >>>> 1 file changed, 1 insertion(+), 1 deletion(-) >>>> >>>> diff --git a/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c b/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c >>>> index 42aa889fd0f5..1a6109be2fce 100644 >>>> --- a/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c >>>> +++ b/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c >>>> @@ -2491,7 +2491,7 @@ static void dp_test_send_phy_test_pattern(struct dc_link *link) >>>> /* get phy test pattern and pattern parameters from DP receiver */ >>>> core_link_read_dpcd( >>>> link, >>>> - DP_TEST_PHY_PATTERN, >>>> + DP_PHY_TEST_PATTERN, >>>> &dpcd_test_pattern.raw, >>>> sizeof(dpcd_test_pattern)); >>>> core_link_read_dpcd( >>>>
diff --git a/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c b/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c index 42aa889fd0f5..1a6109be2fce 100644 --- a/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c +++ b/drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c @@ -2491,7 +2491,7 @@ static void dp_test_send_phy_test_pattern(struct dc_link *link) /* get phy test pattern and pattern parameters from DP receiver */ core_link_read_dpcd( link, - DP_TEST_PHY_PATTERN, + DP_PHY_TEST_PATTERN, &dpcd_test_pattern.raw, sizeof(dpcd_test_pattern)); core_link_read_dpcd(
[Why]: Aligh with DP spec wanted to follow same naming convention. [How]: Changed the macro name of the dpcd address used for getting requested test-pattern. Cc: Harry Wentland <harry.wentland@amd.com> Cc: Alex Deucher <alexander.deucher@amd.com> Signed-off-by: Animesh Manna <animesh.manna@intel.com> --- drivers/gpu/drm/amd/display/dc/core/dc_link_dp.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)