Message ID | 20200213132203.23441-1-kraxel@redhat.com (mailing list archive) |
---|---|
Headers | show |
Series | drm/virtio: rework batching | expand |
Series is Reviewed-by: Chia-I Wu <olvaffe@gmail.com> After the series, virtio_gpu_cmd_* may or may not call virtio_gpu_notify. It is error-prone and should be fixed, such that virtio_gpu_cmd_* never notifies, or such that different naming conventions are used for functions that notify and for those don't. On Thu, Feb 13, 2020 at 5:22 AM Gerd Hoffmann <kraxel@redhat.com> wrote: > > v4: > - split into multiple patches. > > Gerd Hoffmann (4): > drm/virtio: rework notification for better batching > drm/virtio: batch plane updates (pageflip) > drm/virtio: batch resource creation > drm/virtio: batch display query. > > drivers/gpu/drm/virtio/virtgpu_drv.h | 6 ++-- > drivers/gpu/drm/virtio/virtgpu_display.c | 2 ++ > drivers/gpu/drm/virtio/virtgpu_ioctl.c | 1 + > drivers/gpu/drm/virtio/virtgpu_kms.c | 2 ++ > drivers/gpu/drm/virtio/virtgpu_object.c | 1 + > drivers/gpu/drm/virtio/virtgpu_plane.c | 7 ++-- > drivers/gpu/drm/virtio/virtgpu_vq.c | 41 +++++++++++++----------- > 7 files changed, 33 insertions(+), 27 deletions(-) > > -- > 2.18.2 >