Message ID | 49e90f024d89746d5955331e023231149210917c.1582845395.git.gayatri.kammela@intel.com (mailing list archive) |
---|---|
State | Superseded, archived |
Headers | show |
Series | platform/x86: intel_pmc_core: Add bug fixes or code | expand |
On Thu, Feb 27, 2020 at 03:29:14PM -0800, Gayatri Kammela wrote: > Currently pmc_core_lpm_display() uses array of struct pointers i.e., > tgl_lpm_maps for Tiger Lake directly to iterate through and to get the > number of status/live status registers which is hardcoded and cannot > be re-used for future platforms that support sub-states. To maintain > readability, make pmc_core_lpm_display() generic, so that it can re-used > for future platforms. This patch need more work, see below. That said, I would prefer to see it last in the series for next version. ... > + lpm_regs = kmalloc_array(arr_size, sizeof(*lpm_regs), GFP_KERNEL); No error check? Besides that it is obvious memory leak. > + for (index = 0; maps[index]; index++) { > lpm_regs[index] = pmc_core_reg_read(pmcdev, offset); > offset += 4; > }
> -----Original Message----- > From: Andy Shevchenko <andriy.shevchenko@linux.intel.com> > Sent: Friday, February 28, 2020 2:06 AM > To: Kammela, Gayatri <gayatri.kammela@intel.com> > Cc: platform-driver-x86@vger.kernel.org; linux-kernel@vger.kernel.org; > Somayaji, Vishwanath <vishwanath.somayaji@intel.com>; > dvhart@infradead.org; Westerberg, Mika <mika.westerberg@intel.com>; > peterz@infradead.org; Prestopine, Charles D > <charles.d.prestopine@intel.com>; Chen Zhou <chenzhou10@huawei.com>; > Box, David E <david.e.box@intel.com> > Subject: Re: [PATCH v2 2/4] platform/x86: intel_pmc_core: fix: Make > pmc_core_lpm_display() generic for platforms that support sub-states > > On Thu, Feb 27, 2020 at 03:29:14PM -0800, Gayatri Kammela wrote: > > Currently pmc_core_lpm_display() uses array of struct pointers i.e., > > tgl_lpm_maps for Tiger Lake directly to iterate through and to get the > > number of status/live status registers which is hardcoded and cannot > > be re-used for future platforms that support sub-states. To maintain > > readability, make pmc_core_lpm_display() generic, so that it can > > re-used for future platforms. > > This patch need more work, see below. > That said, I would prefer to see it last in the series for next version. Sure, I will put this patch last in the series in v3. > > ... > > > + lpm_regs = kmalloc_array(arr_size, sizeof(*lpm_regs), GFP_KERNEL); > > No error check? > Besides that it is obvious memory leak. Sorry my bad, I will put the check and free the memory. I will update this in v3 > > > + for (index = 0; maps[index]; index++) { > > lpm_regs[index] = pmc_core_reg_read(pmcdev, offset); > > offset += 4; > > } > > -- > With Best Regards, > Andy Shevchenko >
diff --git a/drivers/platform/x86/intel_pmc_core.c b/drivers/platform/x86/intel_pmc_core.c index 20b2f49726cf..3f000b6c8d8e 100644 --- a/drivers/platform/x86/intel_pmc_core.c +++ b/drivers/platform/x86/intel_pmc_core.c @@ -20,6 +20,7 @@ #include <linux/module.h> #include <linux/pci.h> #include <linux/platform_device.h> +#include <linux/slab.h> #include <linux/suspend.h> #include <linux/uaccess.h> @@ -639,15 +640,27 @@ static void pmc_core_slps0_display(struct pmc_dev *pmcdev, struct device *dev, } } +static int pmc_core_lpm_get_arr_size(const struct pmc_bit_map **maps) +{ + int idx, arr_size = 0; + + for (idx = 0; maps[idx]; idx++) + arr_size++; + + return arr_size; +} + static void pmc_core_lpm_display(struct pmc_dev *pmcdev, struct device *dev, struct seq_file *s, u32 offset, const char *str, const struct pmc_bit_map **maps) { - u32 lpm_regs[ARRAY_SIZE(tgl_lpm_maps)-1]; - int index, idx, len = 32, bit_mask; + int arr_size = pmc_core_lpm_get_arr_size(maps); + int index, idx, bit_mask, len = 32; + u32 *lpm_regs; - for (index = 0; tgl_lpm_maps[index]; index++) { + lpm_regs = kmalloc_array(arr_size, sizeof(*lpm_regs), GFP_KERNEL); + for (index = 0; maps[index]; index++) { lpm_regs[index] = pmc_core_reg_read(pmcdev, offset); offset += 4; }
Currently pmc_core_lpm_display() uses array of struct pointers i.e., tgl_lpm_maps for Tiger Lake directly to iterate through and to get the number of status/live status registers which is hardcoded and cannot be re-used for future platforms that support sub-states. To maintain readability, make pmc_core_lpm_display() generic, so that it can re-used for future platforms. Cc: Chen Zhou <chenzhou10@huawei.com> Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com> Cc: David E. Box <david.e.box@intel.com> Suggested-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com> Signed-off-by: Gayatri Kammela <gayatri.kammela@intel.com> --- drivers/platform/x86/intel_pmc_core.c | 19 ++++++++++++++++--- 1 file changed, 16 insertions(+), 3 deletions(-)