Message ID | 5e28f488a6cc8b7c1e08b536868844b586a1eaf1.1583093898.git.gayatri.kammela@intel.com (mailing list archive) |
---|---|
State | Superseded, archived |
Headers | show |
Series | platform/x86: intel_pmc_core: Add bug fixes or code | expand |
On Sun, Mar 01, 2020 at 12:44:26PM -0800, Gayatri Kammela wrote: > Currently pmc_core_lpm_display() uses array of struct pointers i.e., > tgl_lpm_maps for Tiger Lake directly to iterate through and to get the > number of status/live status registers which is hardcoded and cannot > be re-used for future platforms that support sub-states. To maintain > readability, make pmc_core_lpm_display() generic, so that it can re-used > for future platforms. My comments below. ... > +static int pmc_core_lpm_get_arr_size(const struct pmc_bit_map **maps) > +{ > + int idx, arr_size = 0; And why do you need arr_size variable at all? > + > + for (idx = 0; maps[idx]; idx++) > + arr_size++; > + > + return arr_size; > +} ... > - int index, idx, len = 32, bit_mask; > + int index, idx, bit_mask, len = 32; What's the point of shuffling this? > + int arr_size = pmc_core_lpm_get_arr_size(maps); This would be better in a split manner, i.e. int arr_size; ... arr_size = ...; ... > + lpm_regs = kmalloc_array(arr_size, sizeof(*lpm_regs), GFP_KERNEL); > + if(!lpm_regs) > + goto err; There is no point to have the label. Simple return will work. > - for (index = 0; tgl_lpm_maps[index]; index++) { > + for (index = 0; maps[index]; index++) { Why not to reuse arr_size here? > lpm_regs[index] = pmc_core_reg_read(pmcdev, offset); > offset += 4; > }
> -----Original Message----- > From: Andy Shevchenko <andriy.shevchenko@linux.intel.com> > Sent: Monday, March 2, 2020 4:54 AM > To: Kammela, Gayatri <gayatri.kammela@intel.com> > Cc: platform-driver-x86@vger.kernel.org; linux-kernel@vger.kernel.org; > Somayaji, Vishwanath <vishwanath.somayaji@intel.com>; > dvhart@infradead.org; Westerberg, Mika <mika.westerberg@intel.com>; > peterz@infradead.org; Prestopine, Charles D > <charles.d.prestopine@intel.com>; Chen Zhou <chenzhou10@huawei.com>; > Box, David E <david.e.box@intel.com> > Subject: Re: [PATCH v3 5/5] platform/x86: intel_pmc_core: fix: Make > pmc_core_lpm_display() generic for platforms that support sub-states > > On Sun, Mar 01, 2020 at 12:44:26PM -0800, Gayatri Kammela wrote: > > Currently pmc_core_lpm_display() uses array of struct pointers i.e., > > tgl_lpm_maps for Tiger Lake directly to iterate through and to get the > > number of status/live status registers which is hardcoded and cannot > > be re-used for future platforms that support sub-states. To maintain > > readability, make pmc_core_lpm_display() generic, so that it can > > re-used for future platforms. > > My comments below. Thanks Andy! for the comments. > > ... > > > +static int pmc_core_lpm_get_arr_size(const struct pmc_bit_map **maps) > > +{ > > + int idx, arr_size = 0; > > And why do you need arr_size variable at all? I could just return idx value at the end of the for loop. I will remove the arr_size variable. > > > + > > + for (idx = 0; maps[idx]; idx++) > > + arr_size++; > > + > > + return arr_size; > > +} > > ... > > > - int index, idx, len = 32, bit_mask; > > + int index, idx, bit_mask, len = 32; > > What's the point of shuffling this? Just wanted to have all uninitialized variables declared before initialized ones. I will just leave this out in v4. > > > + int arr_size = pmc_core_lpm_get_arr_size(maps); > > This would be better in a split manner, i.e. > > int arr_size; > > ... > > arr_size = ...; Sure, I will make this change in v4 > > ... > > > + lpm_regs = kmalloc_array(arr_size, sizeof(*lpm_regs), GFP_KERNEL); > > + if(!lpm_regs) > > > + goto err; > > There is no point to have the label. Simple return will work. Thought adding a label will help not to have multiple kfree() in the same function (one here at the check and one at the end of the for loop) I will add a return. > > > - for (index = 0; tgl_lpm_maps[index]; index++) { > > + for (index = 0; maps[index]; index++) { > > Why not to reuse arr_size here? Good point! I missed it. I will use the arr_size here to iterate. > > > lpm_regs[index] = pmc_core_reg_read(pmcdev, offset); > > offset += 4; > > } > > -- > With Best Regards, > Andy Shevchenko >
diff --git a/drivers/platform/x86/intel_pmc_core.c b/drivers/platform/x86/intel_pmc_core.c index 04ac058b9871..cf3aaace21d5 100644 --- a/drivers/platform/x86/intel_pmc_core.c +++ b/drivers/platform/x86/intel_pmc_core.c @@ -20,6 +20,7 @@ #include <linux/module.h> #include <linux/pci.h> #include <linux/platform_device.h> +#include <linux/slab.h> #include <linux/suspend.h> #include <linux/uaccess.h> @@ -640,15 +641,30 @@ static void pmc_core_slps0_display(struct pmc_dev *pmcdev, struct device *dev, } } +static int pmc_core_lpm_get_arr_size(const struct pmc_bit_map **maps) +{ + int idx, arr_size = 0; + + for (idx = 0; maps[idx]; idx++) + arr_size++; + + return arr_size; +} + static void pmc_core_lpm_display(struct pmc_dev *pmcdev, struct device *dev, struct seq_file *s, u32 offset, const char *str, const struct pmc_bit_map **maps) { - u32 lpm_regs[ARRAY_SIZE(tgl_lpm_maps)-1]; - int index, idx, len = 32, bit_mask; + int arr_size = pmc_core_lpm_get_arr_size(maps); + int index, idx, bit_mask, len = 32; + u32 *lpm_regs; + + lpm_regs = kmalloc_array(arr_size, sizeof(*lpm_regs), GFP_KERNEL); + if(!lpm_regs) + goto err; - for (index = 0; tgl_lpm_maps[index]; index++) { + for (index = 0; maps[index]; index++) { lpm_regs[index] = pmc_core_reg_read(pmcdev, offset); offset += 4; } @@ -672,6 +688,9 @@ static void pmc_core_lpm_display(struct pmc_dev *pmcdev, struct device *dev, lpm_regs[idx] & bit_mask ? 1 : 0); } } + +err: + kfree(lpm_regs); } #if IS_ENABLED(CONFIG_DEBUG_FS)
Currently pmc_core_lpm_display() uses array of struct pointers i.e., tgl_lpm_maps for Tiger Lake directly to iterate through and to get the number of status/live status registers which is hardcoded and cannot be re-used for future platforms that support sub-states. To maintain readability, make pmc_core_lpm_display() generic, so that it can re-used for future platforms. Cc: Chen Zhou <chenzhou10@huawei.com> Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com> Cc: David E. Box <david.e.box@intel.com> Suggested-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com> Signed-off-by: Gayatri Kammela <gayatri.kammela@intel.com> --- drivers/platform/x86/intel_pmc_core.c | 25 ++++++++++++++++++++++--- 1 file changed, 22 insertions(+), 3 deletions(-)