mbox series

[v5,00/15] Fix qla2xxx endianness annotations

Message ID 20200511200946.7675-1-bvanassche@acm.org (mailing list archive)
Headers show
Series Fix qla2xxx endianness annotations | expand

Message

Bart Van Assche May 11, 2020, 8:09 p.m. UTC
Hi Martin,

This patch series fixes the endianness annotations in the qla2xxx driver.
Please consider this patch series for the v5.8 kernel.

Thanks,

Bart.

Changes compared to v4:
- Addressed Hannes' and most of Arun's review comments.
- Suppressed a clang warning for the patch that suppresses a gcc warning.
- Included three new patches. Two of these patches compensate for recently
  introduced changes (broken C=2 build and using register offsets instead of
  register names) and one new patch to make the last patch in this series
  easier to read.

Changes compared to v3:
- Included several source code cleanup patches, e.g. to address isssues
  detected by checkpatch.

Changes compared to v2:
- Removed one BUILD_BUG_ON() statement.

Changes compared to v1:
- Left out the raw_smp_processor_id() patch because it may take time to achieve
  agreement about this patch.
- Added three patches to this series: two patches for verifying structure size
  at compile time and one patch for changing function names from upper case to
  lower case.

Bart Van Assche (15):
  qla2xxx: Fix spelling of a variable name
  qla2xxx: Suppress two recently introduced compiler warnings
  qla2xxx: Simplify the functions for dumping firmware
  qla2xxx: Sort BUILD_BUG_ON() statements alphabetically
  qla2xxx: Add more BUILD_BUG_ON() statements
  qla2xxx: Make a gap in struct qla2xxx_offld_chain explicit
  qla2xxx: Increase the size of struct qla_fcp_prio_cfg to
    FCP_PRIO_CFG_SIZE
  qla2xxx: Change two hardcoded constants into offsetof() / sizeof()
    expressions
  qla2xxx: Use register names instead of register offsets
  qla2xxx: Fix the code that reads from mailbox registers
  qla2xxx: Change {RD,WRT}_REG_*() function names from upper case into
    lower case
  qla2xxx: Cast explicitly to uint16_t / uint32_t
  qla2xxx: Use make_handle() instead of open-coding it
  qla2xxx: Fix endianness annotations in header files
  qla2xxx: Fix endianness annotations in source files

 drivers/scsi/qla2xxx/qla_attr.c    |   3 +-
 drivers/scsi/qla2xxx/qla_bsg.c     |   8 +-
 drivers/scsi/qla2xxx/qla_dbg.c     | 825 +++++++++++++----------------
 drivers/scsi/qla2xxx/qla_dbg.h     | 443 ++++++++--------
 drivers/scsi/qla2xxx/qla_def.h     | 715 +++++++++++++------------
 drivers/scsi/qla2xxx/qla_fw.h      | 768 +++++++++++++--------------
 drivers/scsi/qla2xxx/qla_gbl.h     |  21 +-
 drivers/scsi/qla2xxx/qla_init.c    | 286 +++++-----
 drivers/scsi/qla2xxx/qla_inline.h  |   8 +-
 drivers/scsi/qla2xxx/qla_iocb.c    | 133 ++---
 drivers/scsi/qla2xxx/qla_isr.c     | 237 ++++-----
 drivers/scsi/qla2xxx/qla_mbx.c     | 123 +++--
 drivers/scsi/qla2xxx/qla_mid.c     |   4 +-
 drivers/scsi/qla2xxx/qla_mr.c      | 115 ++--
 drivers/scsi/qla2xxx/qla_mr.h      |  32 +-
 drivers/scsi/qla2xxx/qla_nvme.c    |  16 +-
 drivers/scsi/qla2xxx/qla_nvme.h    |  64 +--
 drivers/scsi/qla2xxx/qla_nx.c      | 163 +++---
 drivers/scsi/qla2xxx/qla_nx.h      |  36 +-
 drivers/scsi/qla2xxx/qla_nx2.c     |  18 +-
 drivers/scsi/qla2xxx/qla_os.c      | 124 +++--
 drivers/scsi/qla2xxx/qla_sup.c     | 323 +++++------
 drivers/scsi/qla2xxx/qla_target.c  | 102 ++--
 drivers/scsi/qla2xxx/qla_target.h  | 232 ++++----
 drivers/scsi/qla2xxx/qla_tmpl.c    |  39 +-
 drivers/scsi/qla2xxx/tcm_qla2xxx.c |  14 +
 include/trace/events/qla.h         |   7 +
 27 files changed, 2447 insertions(+), 2412 deletions(-)

Comments

Martin K. Petersen May 12, 2020, 4:44 p.m. UTC | #1
Hi Bart!

> This patch series fixes the endianness annotations in the qla2xxx
> driver.  Please consider this patch series for the v5.8 kernel.

I in reading v5 I noticed that Arun's reviews were missing from patches
1, (2), 3, 5, 7, and 9. Not sure if other v4 review tags were missed.
Please verify when you repost.

Thanks!
Bart Van Assche May 13, 2020, 1:29 a.m. UTC | #2
On 2020-05-12 09:44, Martin K. Petersen wrote:
> I in reading v5 I noticed that Arun's reviews were missing from patches
> 1, (2), 3, 5, 7, and 9. Not sure if other v4 review tags were missed.
> Please verify when you repost.

That happened unintentionally. Thanks Martin for having caught this. I
will add Arun's reviewed-by tags when I repost.

Bart.