Message ID | 20200520120054.GB172354@mwanda (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | drm/amdgpu: off by on in amdgpu_device_attr_create_groups() error handling | expand |
Am 20.05.20 um 14:00 schrieb Dan Carpenter: > This loop in the error handling code should start a "i - 1" and end at > "i == 0". Currently it starts a "i" and ends at "i == 1". The result > is that it removes one attribute that wasn't created yet, and leaks the > zeroeth attribute. > > Fixes: 4e01847c38f7 ("drm/amdgpu: optimize amdgpu device attribute code") > Signed-off-by: Dan Carpenter <dan.carpenter@oracle.com> > --- > drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c | 5 ++--- > 1 file changed, 2 insertions(+), 3 deletions(-) > > diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c > index b75362bf0742..ee4a8e44fbeb 100644 > --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c > +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c > @@ -1931,7 +1931,7 @@ static int amdgpu_device_attr_create_groups(struct amdgpu_device *adev, > uint32_t mask) > { > int ret = 0; > - uint32_t i = 0; > + int i; > > for (i = 0; i < counts; i++) { > ret = amdgpu_device_attr_create(adev, &attrs[i], mask); > @@ -1942,9 +1942,8 @@ static int amdgpu_device_attr_create_groups(struct amdgpu_device *adev, > return 0; > > failed: > - for (; i > 0; i--) { > + while (--i >= 0) As far as I know the common idiom for this is while (i--) which even works without changing the type of i to signed. Christian. > amdgpu_device_attr_remove(adev, &attrs[i]); > - } > > return ret; > }
On Wed, May 20, 2020 at 02:05:19PM +0200, Christian König wrote: > Am 20.05.20 um 14:00 schrieb Dan Carpenter: > > This loop in the error handling code should start a "i - 1" and end at > > "i == 0". Currently it starts a "i" and ends at "i == 1". The result > > is that it removes one attribute that wasn't created yet, and leaks the > > zeroeth attribute. > > > > Fixes: 4e01847c38f7 ("drm/amdgpu: optimize amdgpu device attribute code") > > Signed-off-by: Dan Carpenter <dan.carpenter@oracle.com> > > --- > > drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c | 5 ++--- > > 1 file changed, 2 insertions(+), 3 deletions(-) > > > > diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c > > index b75362bf0742..ee4a8e44fbeb 100644 > > --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c > > +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c > > @@ -1931,7 +1931,7 @@ static int amdgpu_device_attr_create_groups(struct amdgpu_device *adev, > > uint32_t mask) > > { > > int ret = 0; > > - uint32_t i = 0; > > + int i; > > for (i = 0; i < counts; i++) { > > ret = amdgpu_device_attr_create(adev, &attrs[i], mask); > > @@ -1942,9 +1942,8 @@ static int amdgpu_device_attr_create_groups(struct amdgpu_device *adev, > > return 0; > > failed: > > - for (; i > 0; i--) { > > + while (--i >= 0) > > As far as I know the common idiom for this is while (i--) which even works > without changing the type of i to signed. It's about 50/50, one way or the other. To me --i >= 0 seems far more readable. I've been trying to figure out which tool tells people to make iterators unsigned so I can help them avoid it. :/ I understand how in theory iterators could go above INT_MAX but if we're going above INT_MAX then probably we should use a 64 bit type. There are very few times where 2 billion iterations is not enough but in those situations probably 4 billion is not enough either. So unsigned int iterators never or seldom solve real life bugs but they regularly cause them. regards, dan carpenter
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c index b75362bf0742..ee4a8e44fbeb 100644 --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c @@ -1931,7 +1931,7 @@ static int amdgpu_device_attr_create_groups(struct amdgpu_device *adev, uint32_t mask) { int ret = 0; - uint32_t i = 0; + int i; for (i = 0; i < counts; i++) { ret = amdgpu_device_attr_create(adev, &attrs[i], mask); @@ -1942,9 +1942,8 @@ static int amdgpu_device_attr_create_groups(struct amdgpu_device *adev, return 0; failed: - for (; i > 0; i--) { + while (--i >= 0) amdgpu_device_attr_remove(adev, &attrs[i]); - } return ret; }
This loop in the error handling code should start a "i - 1" and end at "i == 0". Currently it starts a "i" and ends at "i == 1". The result is that it removes one attribute that wasn't created yet, and leaks the zeroeth attribute. Fixes: 4e01847c38f7 ("drm/amdgpu: optimize amdgpu device attribute code") Signed-off-by: Dan Carpenter <dan.carpenter@oracle.com> --- drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-)