diff mbox series

[v2,5/5] ARM: mstar: Add dts for 70mai midrive d08

Message ID 20200610090421.3428945-6-daniel@0x0f.com (mailing list archive)
State New, archived
Headers show
Series Initial MStar/Sigmastar ARMv7 SoC support | expand

Commit Message

Daniel Palmer June 10, 2020, 9:04 a.m. UTC
Adds inital support for the 70mai midrive d08 dash camera.

Signed-off-by: Daniel Palmer <daniel@0x0f.com>
---
 arch/arm/boot/dts/Makefile                    |  3 ++-
 .../boot/dts/mercury5-ssc8336n-midrive08.dts  | 25 +++++++++++++++++++
 2 files changed, 27 insertions(+), 1 deletion(-)
 create mode 100644 arch/arm/boot/dts/mercury5-ssc8336n-midrive08.dts

Comments

Andreas Färber June 11, 2020, 1:54 p.m. UTC | #1
BTW I think the subject convention has been "ARM: dts: ...", with "ARM: 
mstar: ..." more for mach-mstar.

Am 10.06.20 um 11:04 schrieb Daniel Palmer:
> Adds inital support for the 70mai midrive d08 dash camera.
> 
> Signed-off-by: Daniel Palmer <daniel@0x0f.com>
> ---
>   arch/arm/boot/dts/Makefile                    |  3 ++-
>   .../boot/dts/mercury5-ssc8336n-midrive08.dts  | 25 +++++++++++++++++++
>   2 files changed, 27 insertions(+), 1 deletion(-)
>   create mode 100644 arch/arm/boot/dts/mercury5-ssc8336n-midrive08.dts
> 
> diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
> index 4a5f8075a4f6..35c7ecc52c60 100644
> --- a/arch/arm/boot/dts/Makefile
> +++ b/arch/arm/boot/dts/Makefile
> @@ -1344,7 +1344,8 @@ dtb-$(CONFIG_ARCH_MEDIATEK) += \
>   dtb-$(CONFIG_ARCH_MILBEAUT) += milbeaut-m10v-evb.dtb
>   dtb-$(CONFIG_ARCH_MSTARV7) += \
>   	infinity-msc313-breadbee_crust.dtb \
> -	infinity3-msc313e-breadbee.dtb
> +	infinity3-msc313e-breadbee.dtb \
> +	mercury5-ssc8336n-midrive08.dtb
>   dtb-$(CONFIG_ARCH_ZX) += zx296702-ad1.dtb
>   dtb-$(CONFIG_ARCH_ASPEED) += \
>   	aspeed-ast2500-evb.dtb \
> diff --git a/arch/arm/boot/dts/mercury5-ssc8336n-midrive08.dts b/arch/arm/boot/dts/mercury5-ssc8336n-midrive08.dts
> new file mode 100644
> index 000000000000..4ee50ecf6ab1
> --- /dev/null
> +++ b/arch/arm/boot/dts/mercury5-ssc8336n-midrive08.dts
> @@ -0,0 +1,25 @@
> +// SPDX-License-Identifier: GPL-2.0
> +/*
> + * Copyright (c) 2019 thingy.jp.
> + * Author: Daniel Palmer <daniel@thingy.jp>
> + */
> +
> +/dts-v1/;
> +#include "mercury5-ssc8336n.dtsi"
> +
> +/ {
> +	model = "midrive d08";

Couldn't find this on their website. Should this be "70mai midrive ..." 
or is "midrive" a different brand?

> +	compatible = "70mai,midrived08", "mstar,mercury5";

Have you considered naming it "70mai,midrive-d08" for better 
readability? (affects 1/5)

> +
> +	aliases {
> +		serial0 = &pm_uart;
> +	};
> +
> +	chosen {
> +		stdout-path = "serial0:115200n8";
> +	};
> +};
> +
> +&pm_uart {
> +	status = "okay";

clock-frequency?

> +};

Regards,
Andreas
Daniel Palmer June 11, 2020, 2:38 p.m. UTC | #2
Hi Andreas,

On Thu, 11 Jun 2020 at 22:54, Andreas Färber <afaerber@suse.de> wrote:
>
> BTW I think the subject convention has been "ARM: dts: ...", with "ARM:
> mstar: ..." more for mach-mstar.

I noticed this after sending out this series. I've fixed up the
subjects in line with convention for the next try.

> > diff --git a/arch/arm/boot/dts/mercury5-ssc8336n-midrive08.dts b/arch/arm/boot/dts/mercury5-ssc8336n-midrive08.dts
> > new file mode 100644
> > index 000000000000..4ee50ecf6ab1
> > --- /dev/null
> > +++ b/arch/arm/boot/dts/mercury5-ssc8336n-midrive08.dts
> > @@ -0,0 +1,25 @@
> > +// SPDX-License-Identifier: GPL-2.0
> > +/*
> > + * Copyright (c) 2019 thingy.jp.
> > + * Author: Daniel Palmer <daniel@thingy.jp>
> > + */
> > +
> > +/dts-v1/;
> > +#include "mercury5-ssc8336n.dtsi"
> > +
> > +/ {
> > +     model = "midrive d08";
>
> Couldn't find this on their website. Should this be "70mai midrive ..."
> or is "midrive" a different brand?

I think it should be 70mai Midrive D08 based on your comments on the
other model names.
On their site this camera is now called "Dash Cam Lite".
Midrive D08 is the name I bought it under and the name that was used
for it's FCC approval (https://fccid.io/2AOK9-MIDRIVED08) so that's
what I went
with.

> > +     compatible = "70mai,midrived08", "mstar,mercury5";
>
> Have you considered naming it "70mai,midrive-d08" for better
> readability? (affects 1/5)

I went with midrived08 as that's what was used for the FCC and from
what I remember was written on the casing.

Thanks,

Daniel
diff mbox series

Patch

diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 4a5f8075a4f6..35c7ecc52c60 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -1344,7 +1344,8 @@  dtb-$(CONFIG_ARCH_MEDIATEK) += \
 dtb-$(CONFIG_ARCH_MILBEAUT) += milbeaut-m10v-evb.dtb
 dtb-$(CONFIG_ARCH_MSTARV7) += \
 	infinity-msc313-breadbee_crust.dtb \
-	infinity3-msc313e-breadbee.dtb
+	infinity3-msc313e-breadbee.dtb \
+	mercury5-ssc8336n-midrive08.dtb
 dtb-$(CONFIG_ARCH_ZX) += zx296702-ad1.dtb
 dtb-$(CONFIG_ARCH_ASPEED) += \
 	aspeed-ast2500-evb.dtb \
diff --git a/arch/arm/boot/dts/mercury5-ssc8336n-midrive08.dts b/arch/arm/boot/dts/mercury5-ssc8336n-midrive08.dts
new file mode 100644
index 000000000000..4ee50ecf6ab1
--- /dev/null
+++ b/arch/arm/boot/dts/mercury5-ssc8336n-midrive08.dts
@@ -0,0 +1,25 @@ 
+// SPDX-License-Identifier: GPL-2.0
+/*
+ * Copyright (c) 2019 thingy.jp.
+ * Author: Daniel Palmer <daniel@thingy.jp>
+ */
+
+/dts-v1/;
+#include "mercury5-ssc8336n.dtsi"
+
+/ {
+	model = "midrive d08";
+	compatible = "70mai,midrived08", "mstar,mercury5";
+
+	aliases {
+		serial0 = &pm_uart;
+	};
+
+	chosen {
+		stdout-path = "serial0:115200n8";
+	};
+};
+
+&pm_uart {
+	status = "okay";
+};