Message ID | 20200629225454.22863-1-bvanassche@acm.org (mailing list archive) |
---|---|
Headers | show |
Series | qla2xxx patches for kernel v5.9 | expand |
Hi Bart, > On Jun 29, 2020, at 5:54 PM, Bart Van Assche <bvanassche@acm.org> wrote: > > Hi Martin, > > This patch series includes cleanup patches and also patches that address > complaints from several static source code analyzers. Please consider these > patches for kernel v5.9. > > Thanks, > > Bart. > > Changes compared to v1: > - Rewrote patch "Fix a Coverity complaint in qla2100_fw_dump()" > > Bart Van Assche (9): > qla2xxx: Check the size of struct fcp_hdr at compile time > qla2xxx: Remove the __packed annotation from struct fcp_hdr and > fcp_hdr_le > qla2xxx: Make qla82xx_flash_wait_write_finish() easier to read > qla2xxx: Initialize 'n' before using it > qla2xxx: Remove a superfluous cast > qla2xxx: Make __qla2x00_alloc_iocbs() initialize 32 bits of > request_t.handle > qla2xxx: Fix a Coverity complaint in qla2100_fw_dump() > qla2xxx: Make qla2x00_restart_isp() easier to read > qla2xxx: Introduce a function for computing the debug message prefix > > drivers/scsi/qla2xxx/qla_bsg.c | 3 +- > drivers/scsi/qla2xxx/qla_dbg.c | 98 ++++++++++-------------------- > drivers/scsi/qla2xxx/qla_dbg.h | 1 + > drivers/scsi/qla2xxx/qla_init.c | 39 ++++++------ > drivers/scsi/qla2xxx/qla_iocb.c | 4 +- > drivers/scsi/qla2xxx/qla_nx.c | 20 +++--- > drivers/scsi/qla2xxx/qla_target.h | 4 +- > drivers/scsi/qla2xxx/tcm_qla2xxx.c | 1 + > 8 files changed, 70 insertions(+), 100 deletions(-) > I had reviewed this series earlier and provided Reviewed-by tag. https://lore.kernel.org/linux-scsi/EAC19A51-7256-4D5D-9DBB-D30CEF8551E9@oracle.com/ -- Himanshu Madhani Oracle Linux Engineering
On Mon, 29 Jun 2020 15:54:45 -0700, Bart Van Assche wrote: > This patch series includes cleanup patches and also patches that address > complaints from several static source code analyzers. Please consider these > patches for kernel v5.9. > > Thanks, > > Bart. > > [...] Applied to 5.9/scsi-queue, thanks! [1/9] scsi: qla2xxx: Check the size of struct fcp_hdr at compile time https://git.kernel.org/mkp/scsi/c/a7f474542ea3 [2/9] scsi: qla2xxx: Remove the __packed annotation from struct fcp_hdr and fcp_hdr_le https://git.kernel.org/mkp/scsi/c/f1e12bee55e6 [3/9] scsi: qla2xxx: Make qla82xx_flash_wait_write_finish() easier to read https://git.kernel.org/mkp/scsi/c/2f91a0a03c2d [4/9] scsi: qla2xxx: Initialize 'n' before using it https://git.kernel.org/mkp/scsi/c/67668b5b13c7 [5/9] scsi: qla2xxx: Remove a superfluous cast https://git.kernel.org/mkp/scsi/c/9bb013584a5e [6/9] scsi: qla2xxx: Make __qla2x00_alloc_iocbs() initialize 32 bits of request_t.handle https://git.kernel.org/mkp/scsi/c/f8f12bda53ea [7/9] scsi: qla2xxx: Fix a Coverity complaint in qla2100_fw_dump() https://git.kernel.org/mkp/scsi/c/57fec9f24e58 [8/9] scsi: qla2xxx: Make qla2x00_restart_isp() easier to read https://git.kernel.org/mkp/scsi/c/f85a299f5ec5 [9/9] scsi: qla2xxx: Introduce a function for computing the debug message prefix https://git.kernel.org/mkp/scsi/c/e7019c95c40d
On 2020-06-29 16:26, Himanshu Madhani wrote: > I had reviewed this series earlier and provided Reviewed-by tag. > > https://lore.kernel.org/linux-scsi/EAC19A51-7256-4D5D-9DBB-D30CEF8551E9@oracle.com/ Thank you Himanshu for the reviews. I appreciate this. I promise to check Reviewed-by tags more carefully in the future when reposting a patch series. Bart.