diff mbox series

iomap: Don't opencode SECTOR_SIZE macro

Message ID 20200910152949.3227-1-nborisov@suse.com (mailing list archive)
State New, archived
Headers show
Series iomap: Don't opencode SECTOR_SIZE macro | expand

Commit Message

Nikolay Borisov Sept. 10, 2020, 3:29 p.m. UTC
Signed-off-by: Nikolay Borisov <nborisov@suse.com>
---
 fs/iomap/buffered-io.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Darrick J. Wong Sept. 10, 2020, 3:36 p.m. UTC | #1
On Thu, Sep 10, 2020 at 06:29:49PM +0300, Nikolay Borisov wrote:
> Signed-off-by: Nikolay Borisov <nborisov@suse.com>
> ---
>  fs/iomap/buffered-io.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/fs/iomap/buffered-io.c b/fs/iomap/buffered-io.c
> index 31eb680d8c64..4c688682236f 100644
> --- a/fs/iomap/buffered-io.c
> +++ b/fs/iomap/buffered-io.c
> @@ -29,7 +29,7 @@ struct iomap_page {
>  	atomic_t		read_count;
>  	atomic_t		write_count;
>  	spinlock_t		uptodate_lock;
> -	DECLARE_BITMAP(uptodate, PAGE_SIZE / 512);
> +	DECLARE_BITMAP(uptodate, PAGE_SIZE / SECTOR_SIZE);

FYI, Matthew Wilcox is (probably) going to replace this with a VLA in
5.10 as part of refactorings for THP support ("THP iomap patches for
5.10"), so I think I'll take that series instead.

--D

>  };
>  
>  static inline struct iomap_page *to_iomap_page(struct page *page)
> -- 
> 2.17.1
>
diff mbox series

Patch

diff --git a/fs/iomap/buffered-io.c b/fs/iomap/buffered-io.c
index 31eb680d8c64..4c688682236f 100644
--- a/fs/iomap/buffered-io.c
+++ b/fs/iomap/buffered-io.c
@@ -29,7 +29,7 @@  struct iomap_page {
 	atomic_t		read_count;
 	atomic_t		write_count;
 	spinlock_t		uptodate_lock;
-	DECLARE_BITMAP(uptodate, PAGE_SIZE / 512);
+	DECLARE_BITMAP(uptodate, PAGE_SIZE / SECTOR_SIZE);
 };
 
 static inline struct iomap_page *to_iomap_page(struct page *page)