Message ID | 20200920132548.196452-1-jic23@kernel.org (mailing list archive) |
---|---|
Headers | show |
Series | iio:trigger: Remove re-poll logic. | expand |
On 9/20/20 3:25 PM, Jonathan Cameron wrote: > From: Jonathan Cameron <Jonathan.Cameron@huawei.com> > > This code isn't used by any current mainline drivers (except > via error handling routes that shouldn't exist). The original > user is long gone. It is causing issues, so let's drop it. > > The main bulk of this mini-series is renaming the function to account > for the change in what it does. > > Lars, what impact does doing this have on your patches to mark hrtimer > and irq_work as expiring in hardirq context? I got a bit lost in the > discussion of that series, beyond figuring out his corner needed cleaning up. I think no impact. This is an issue that is orthogonal. I think the patches should still be applied as they are. For this series: Reviewed-by: Lars-Peter Clausen <lars@metafoo.de>
On Sun, 20 Sep 2020 17:02:32 +0200 Lars-Peter Clausen <lars@metafoo.de> wrote: > On 9/20/20 3:25 PM, Jonathan Cameron wrote: > > From: Jonathan Cameron <Jonathan.Cameron@huawei.com> > > > > This code isn't used by any current mainline drivers (except > > via error handling routes that shouldn't exist). The original > > user is long gone. It is causing issues, so let's drop it. > > > > The main bulk of this mini-series is renaming the function to account > > for the change in what it does. > > > > Lars, what impact does doing this have on your patches to mark hrtimer > > and irq_work as expiring in hardirq context? I got a bit lost in the > > discussion of that series, beyond figuring out his corner needed cleaning up. > > I think no impact. This is an issue that is orthogonal. I think the > patches should still be applied as they are. > > For this series: > > Reviewed-by: Lars-Peter Clausen <lars@metafoo.de> > Great. Hopefully resolving this one will get us acks on that series. I've just posted a quick note in that thread to point at this one as resolving the latter part of that discussion. Thanks, Jonathan
On Sun, 20 Sep 2020 19:18:14 +0100 Jonathan Cameron <jic23@kernel.org> wrote: > On Sun, 20 Sep 2020 17:02:32 +0200 > Lars-Peter Clausen <lars@metafoo.de> wrote: > > > On 9/20/20 3:25 PM, Jonathan Cameron wrote: > > > From: Jonathan Cameron <Jonathan.Cameron@huawei.com> > > > > > > This code isn't used by any current mainline drivers (except > > > via error handling routes that shouldn't exist). The original > > > user is long gone. It is causing issues, so let's drop it. > > > > > > The main bulk of this mini-series is renaming the function to account > > > for the change in what it does. > > > > > > Lars, what impact does doing this have on your patches to mark hrtimer > > > and irq_work as expiring in hardirq context? I got a bit lost in the > > > discussion of that series, beyond figuring out his corner needed cleaning up. > > > > I think no impact. This is an issue that is orthogonal. I think the > > patches should still be applied as they are. > > > > For this series: > > > > Reviewed-by: Lars-Peter Clausen <lars@metafoo.de> > > > Great. Hopefully resolving this one will get us acks on that series. > I've just posted a quick note in that thread to point at this one as resolving > the latter part of that discussion. I sat on this one far longer than I should no basis I was planning to also sort out issues around calling iio_trigger_notify_done from an interrupt handler. However, it stands on it's own even if it doesn't clean up all the problems around this code so better to apply this now than forget about it! I'll get to the iio_trigger_notify_done sometime soonish hopefully :( Thanks, Jonathan > > Thanks, > > Jonathan > >
From: Jonathan Cameron <Jonathan.Cameron@huawei.com> This code isn't used by any current mainline drivers (except via error handling routes that shouldn't exist). The original user is long gone. It is causing issues, so let's drop it. The main bulk of this mini-series is renaming the function to account for the change in what it does. Lars, what impact does doing this have on your patches to mark hrtimer and irq_work as expiring in hardirq context? I got a bit lost in the discussion of that series, beyond figuring out his corner needed cleaning up. Jonathan Cameron (2): iio: Fix: Do not poll the driver again if try_reenable() callback returns non 0. iio:trigger: rename try_reenable() to reenable() plus return void drivers/iio/accel/bma180.c | 9 ++++++--- drivers/iio/accel/bmc150-accel-core.c | 12 ++++-------- drivers/iio/accel/kxcjk-1013.c | 10 +++------- drivers/iio/accel/mxc4005.c | 16 ++++++---------- drivers/iio/adc/at91-sama5d2_adc.c | 8 +++----- drivers/iio/gyro/adxrs290.c | 6 ++---- drivers/iio/gyro/bmg160_core.c | 12 ++++-------- drivers/iio/imu/kmx61.c | 10 +++------- drivers/iio/industrialio-trigger.c | 6 ++---- drivers/iio/magnetometer/bmc150_magn.c | 10 +++++----- include/linux/iio/trigger.h | 4 ++-- 11 files changed, 40 insertions(+), 63 deletions(-)