Message ID | 20201009195033.3208459-58-ira.weiny@intel.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | PMEM: Introduce stray write protection for PMEM | expand |
On 10/9/20 12:50 PM, ira.weiny@intel.com wrote: > From: Ira Weiny <ira.weiny@intel.com> > > The pmem driver uses a cached virtual address to access its memory > directly. Because the nvdimm driver is well aware of the special > protections it has mapped memory with, we call dev_access_[en|dis]able() > around the direct pmem->virt_addr (pmem_addr) usage instead of the > unnecessary overhead of trying to get a page to kmap. > > Signed-off-by: Ira Weiny <ira.weiny@intel.com> > --- > drivers/nvdimm/pmem.c | 4 ++++ > 1 file changed, 4 insertions(+) > > diff --git a/drivers/nvdimm/pmem.c b/drivers/nvdimm/pmem.c > index fab29b514372..e4dc1ae990fc 100644 > --- a/drivers/nvdimm/pmem.c > +++ b/drivers/nvdimm/pmem.c > @@ -148,7 +148,9 @@ static blk_status_t pmem_do_read(struct pmem_device *pmem, > if (unlikely(is_bad_pmem(&pmem->bb, sector, len))) > return BLK_STS_IOERR; > > + dev_access_enable(false); > rc = read_pmem(page, page_off, pmem_addr, len); > + dev_access_disable(false); Hi Ira! The APIs should be tweaked to use a symbol (GLOBAL, PER_THREAD), instead of true/false. Try reading the above and you'll see that it sounds like it's doing the opposite of what it is ("enable_this(false)" sounds like a clumsy API design to *disable*, right?). And there is no hint about the scope. And it *could* be so much more readable like this: dev_access_enable(DEV_ACCESS_THIS_THREAD); thanks,
On Fri, Oct 09, 2020 at 07:53:07PM -0700, John Hubbard wrote: > On 10/9/20 12:50 PM, ira.weiny@intel.com wrote: > > From: Ira Weiny <ira.weiny@intel.com> > > > > The pmem driver uses a cached virtual address to access its memory > > directly. Because the nvdimm driver is well aware of the special > > protections it has mapped memory with, we call dev_access_[en|dis]able() > > around the direct pmem->virt_addr (pmem_addr) usage instead of the > > unnecessary overhead of trying to get a page to kmap. > > > > Signed-off-by: Ira Weiny <ira.weiny@intel.com> > > --- > > drivers/nvdimm/pmem.c | 4 ++++ > > 1 file changed, 4 insertions(+) > > > > diff --git a/drivers/nvdimm/pmem.c b/drivers/nvdimm/pmem.c > > index fab29b514372..e4dc1ae990fc 100644 > > --- a/drivers/nvdimm/pmem.c > > +++ b/drivers/nvdimm/pmem.c > > @@ -148,7 +148,9 @@ static blk_status_t pmem_do_read(struct pmem_device *pmem, > > if (unlikely(is_bad_pmem(&pmem->bb, sector, len))) > > return BLK_STS_IOERR; > > + dev_access_enable(false); > > rc = read_pmem(page, page_off, pmem_addr, len); > > + dev_access_disable(false); > > Hi Ira! > > The APIs should be tweaked to use a symbol (GLOBAL, PER_THREAD), instead of > true/false. Try reading the above and you'll see that it sounds like it's > doing the opposite of what it is ("enable_this(false)" sounds like a clumsy > API design to *disable*, right?). And there is no hint about the scope. Sounds reasonable. > > And it *could* be so much more readable like this: > > dev_access_enable(DEV_ACCESS_THIS_THREAD); I'll think about the flag name. I'm not liking 'this thread'. Maybe DEV_ACCESS_[GLOBAL|THREAD] Ira
diff --git a/drivers/nvdimm/pmem.c b/drivers/nvdimm/pmem.c index fab29b514372..e4dc1ae990fc 100644 --- a/drivers/nvdimm/pmem.c +++ b/drivers/nvdimm/pmem.c @@ -148,7 +148,9 @@ static blk_status_t pmem_do_read(struct pmem_device *pmem, if (unlikely(is_bad_pmem(&pmem->bb, sector, len))) return BLK_STS_IOERR; + dev_access_enable(false); rc = read_pmem(page, page_off, pmem_addr, len); + dev_access_disable(false); flush_dcache_page(page); return rc; } @@ -180,11 +182,13 @@ static blk_status_t pmem_do_write(struct pmem_device *pmem, * after clear poison. */ flush_dcache_page(page); + dev_access_enable(false); write_pmem(pmem_addr, page, page_off, len); if (unlikely(bad_pmem)) { rc = pmem_clear_poison(pmem, pmem_off, len); write_pmem(pmem_addr, page, page_off, len); } + dev_access_disable(false); return rc; }