Message ID | 20201124193208.74fe4mticgkbxou3@safonso-t430 (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
Series | [v2] crendential-store: use timeout when locking file | expand |
Simão Afonso <simao.afonso@powertools-tech.com> writes: > +credentialStore.fileTimeout:: > + The length of time, in milliseconds, for git-credential-store to retry > + when trying to lock the credentials file. Value 0 means not to retry at > + all; -1 means to try indefinitely. Default is 1000 (i.e., retry for > + 1s). I do not remember what was said in the first round of the review, but I wonder if this is the best name for users. I think it is good enough, but do ".lockTimeout" or ".lockTimeoutMS" make it even easier to grok, perhaps? > diff --git a/builtin/credential-store.c b/builtin/credential-store.c > index 5331ab151..82284176e 100644 > --- a/builtin/credential-store.c > +++ b/builtin/credential-store.c > @@ -1,4 +1,5 @@ > #include "builtin.h" > +#include "config.h" > #include "lockfile.h" > #include "credential.h" > #include "string-list.h" > @@ -58,8 +59,11 @@ static void print_line(struct strbuf *buf) > static void rewrite_credential_file(const char *fn, struct credential *c, > struct strbuf *extra) > { > - if (hold_lock_file_for_update(&credential_lock, fn, 0) < 0) > - die_errno("unable to get credential storage lock"); > + int timeout_ms = 1000; > + git_config_get_int("credentialstore.filetimeout", &timeout_ms); Please have a blank line before the first statement. > + > + if (hold_lock_file_for_update_timeout(&credential_lock, fn, 0, timeout_ms) < 0) > + die_errno("unable to get credential storage lock in %d ms", timeout_ms); Should this be die_errno()? Looking at lock_file_timeout(), I am not sure if the value of errno is valid in all codepaths that return failure. In any case, the message should be markd with _() for translation. Other than that, it looks good. Thanks. > if (extra) > print_line(extra); > parse_credential_file(fn, c, NULL, print_line);
On Tue, Nov 24, 2020 at 02:08:01PM -0800, Junio C Hamano wrote: > Simão Afonso <simao.afonso@powertools-tech.com> writes: > > > +credentialStore.fileTimeout:: > > + The length of time, in milliseconds, for git-credential-store to retry > > + when trying to lock the credentials file. Value 0 means not to retry at > > + all; -1 means to try indefinitely. Default is 1000 (i.e., retry for > > + 1s). > > I do not remember what was said in the first round of the review, > but I wonder if this is the best name for users. I think it is good > enough, but do ".lockTimeout" or ".lockTimeoutMS" make it even > easier to grok, perhaps? Yeah, I think those are a bit more obvious. > > + > > + if (hold_lock_file_for_update_timeout(&credential_lock, fn, 0, timeout_ms) < 0) > > + die_errno("unable to get credential storage lock in %d ms", timeout_ms); > > Should this be die_errno()? Looking at lock_file_timeout(), I am > not sure if the value of errno is valid in all codepaths that return > failure. I think it's the right thing here. Inside hold_lock_file_for_update_timeout(), we'd pass errno to unable_to_lock_die(), etc. So if there is a code path in lock_file_timeout() that isn't setting errno properly, we should probably be fixing that. Another option would be to just pass LOCK_DIE_ON_ERROR here, but I think for this use I prefer the smaller "unable to lock" to the big "another git process may have crashed" advice message we'd give in that case. -Peff
diff --git a/Documentation/config/credential.txt b/Documentation/config/credential.txt index 9d01641c2..132e04b47 100644 --- a/Documentation/config/credential.txt +++ b/Documentation/config/credential.txt @@ -28,3 +28,9 @@ credential.<url>.*:: credentialCache.ignoreSIGHUP:: Tell git-credential-cache--daemon to ignore SIGHUP, instead of quitting. + +credentialStore.fileTimeout:: + The length of time, in milliseconds, for git-credential-store to retry + when trying to lock the credentials file. Value 0 means not to retry at + all; -1 means to try indefinitely. Default is 1000 (i.e., retry for + 1s). diff --git a/builtin/credential-store.c b/builtin/credential-store.c index 5331ab151..82284176e 100644 --- a/builtin/credential-store.c +++ b/builtin/credential-store.c @@ -1,4 +1,5 @@ #include "builtin.h" +#include "config.h" #include "lockfile.h" #include "credential.h" #include "string-list.h" @@ -58,8 +59,11 @@ static void print_line(struct strbuf *buf) static void rewrite_credential_file(const char *fn, struct credential *c, struct strbuf *extra) { - if (hold_lock_file_for_update(&credential_lock, fn, 0) < 0) - die_errno("unable to get credential storage lock"); + int timeout_ms = 1000; + git_config_get_int("credentialstore.filetimeout", &timeout_ms); + + if (hold_lock_file_for_update_timeout(&credential_lock, fn, 0, timeout_ms) < 0) + die_errno("unable to get credential storage lock in %d ms", timeout_ms); if (extra) print_line(extra); parse_credential_file(fn, c, NULL, print_line);
When holding the lock for rewriting the credential file, use a timeout to avoid race conditions when the credentials file needs to be updated in parallel. An example would be doing `fetch --all` on a repository with several remotes that need credentials, using parallel fetching. The timeout can be configured using "credentialStore.fileTimeout", defaulting to 1 second. Signed-off-by: Simão Afonso <simao.afonso@powertools-tech.com> --- Thanks for the review. I got stuck with work and only got around to tweak this now. I added a configurable timeout with the old value as default. I think that txt file is the only documentation that requires update for a new configuration value. Documentation/config/credential.txt | 6 ++++++ builtin/credential-store.c | 8 ++++++-- 2 files changed, 12 insertions(+), 2 deletions(-)