Message ID | 20201218201633.2735367-1-jonathan.lemon@gmail.com (mailing list archive) |
---|---|
Headers | show |
Series | Generic zcopy_* functions | expand |
On Fri, Dec 18, 2020 at 3:23 PM Jonathan Lemon <jonathan.lemon@gmail.com> wrote: > > From: Jonathan Lemon <bsd@fb.com> > > This is set of cleanup patches for zerocopy which are intended > to allow a introduction of a different zerocopy implementation. Can you describe in more detail what exactly is lacking in the current zerocopy interface for this this different implementation? Or point to a github tree with the feature patches attached, perhaps. I think it's good to split into multiple smaller patchsets, starting with core stack support. But find it hard to understand which of these changes are truly needed to support a new use case. If anything, eating up the last 8 bits in skb_shared_info should be last resort. I'll take a look at the individual patches in more detail later.
On Fri, Dec 18, 2020 at 03:49:44PM -0500, Willem de Bruijn wrote: > On Fri, Dec 18, 2020 at 3:23 PM Jonathan Lemon <jonathan.lemon@gmail.com> wrote: > > > > From: Jonathan Lemon <bsd@fb.com> > > > > This is set of cleanup patches for zerocopy which are intended > > to allow a introduction of a different zerocopy implementation. > > Can you describe in more detail what exactly is lacking in the current > zerocopy interface for this this different implementation? Or point to > a github tree with the feature patches attached, perhaps. I'll get the zctap features up into a github tree. Essentially, I need different behavior from ubuf_info: - no refcounts on RX packets (static ubuf) - access to the skb on RX skb free (for page handling) - no page pinning on TX/tx completion - marking the skb data as inaccessible so skb_condense() and skb_zeroocopy_clone() leave it alone. > I think it's good to split into multiple smaller patchsets, starting > with core stack support. But find it hard to understand which of these > changes are truly needed to support a new use case. Agree - kind of hard to see why this is done without a use case. These patches are purely restructuring, and don't introduce any new features. > If anything, eating up the last 8 bits in skb_shared_info should be last resort. I would like to add 2 more bits in the future, which is why I moved them. Is there a compelling reason to leave the bits alone? -- Jonathan
On Fri, Dec 18, 2020 at 4:27 PM Jonathan Lemon <jonathan.lemon@gmail.com> wrote: > > On Fri, Dec 18, 2020 at 03:49:44PM -0500, Willem de Bruijn wrote: > > On Fri, Dec 18, 2020 at 3:23 PM Jonathan Lemon <jonathan.lemon@gmail.com> wrote: > > > > > > From: Jonathan Lemon <bsd@fb.com> > > > > > > This is set of cleanup patches for zerocopy which are intended > > > to allow a introduction of a different zerocopy implementation. > > > > Can you describe in more detail what exactly is lacking in the current > > zerocopy interface for this this different implementation? Or point to > > a github tree with the feature patches attached, perhaps. > > I'll get the zctap features up into a github tree. > > Essentially, I need different behavior from ubuf_info: > - no refcounts on RX packets (static ubuf) That is already the case for vhost and tpacket zerocopy use cases. > - access to the skb on RX skb free (for page handling) To refers only to patch 9, moving the callback earlier in skb_release_data, right? > - no page pinning on TX/tx completion That is not part of the skb zerocopy infrastructure? > - marking the skb data as inaccessible so skb_condense() > and skb_zeroocopy_clone() leave it alone. Yep. Skipping content access on the Rx path will be interesting. I wonder if that should be a separate opaque skb feature, independent from whether the data is owned by userspace, peripheral memory, the page cache or anything else. > > I think it's good to split into multiple smaller patchsets, starting > > with core stack support. But find it hard to understand which of these > > changes are truly needed to support a new use case. > > Agree - kind of hard to see why this is done without a use case. > These patches are purely restructuring, and don't introduce any > new features. > > > > If anything, eating up the last 8 bits in skb_shared_info should be last resort. > > I would like to add 2 more bits in the future, which is why I > moved them. Is there a compelling reason to leave the bits alone? Opportunity cost. We cannot grow skb_shared_info due to colocation with MTU sized linear skbuff's in half a page. It took me quite some effort to free up a few bytes in commit 4d276eb6a478 ("net: remove deprecated syststamp timestamp"). If we are very frugal, we could shadow some bits to have different meaning in different paths. SKBTX_IN_PROGRESS is transmit only, I think. But otherwise we'll have to just dedicate the byte to more flags. Yours are likely not to be the last anyway.
On Sat, Dec 19, 2020 at 02:00:55PM -0500, Willem de Bruijn wrote: > On Fri, Dec 18, 2020 at 4:27 PM Jonathan Lemon <jonathan.lemon@gmail.com> wrote: > > > > On Fri, Dec 18, 2020 at 03:49:44PM -0500, Willem de Bruijn wrote: > > > On Fri, Dec 18, 2020 at 3:23 PM Jonathan Lemon <jonathan.lemon@gmail.com> wrote: > > > > > > > > From: Jonathan Lemon <bsd@fb.com> > > > > > > > > This is set of cleanup patches for zerocopy which are intended > > > > to allow a introduction of a different zerocopy implementation. > > > > > > Can you describe in more detail what exactly is lacking in the current > > > zerocopy interface for this this different implementation? Or point to > > > a github tree with the feature patches attached, perhaps. > > > > I'll get the zctap features up into a github tree. > > > > Essentially, I need different behavior from ubuf_info: > > - no refcounts on RX packets (static ubuf) > > That is already the case for vhost and tpacket zerocopy use cases. > > > - access to the skb on RX skb free (for page handling) > > To refers only to patch 9, moving the callback earlier in > skb_release_data, right? Yes. > > - no page pinning on TX/tx completion > > That is not part of the skb zerocopy infrastructure? That's specific to msg_zerocopy. zctap uses the same network stack paths, but pins the pages during setup, not during each each system call. > > - marking the skb data as inaccessible so skb_condense() > > and skb_zeroocopy_clone() leave it alone. > > Yep. Skipping content access on the Rx path will be interesting. I > wonder if that should be a separate opaque skb feature, independent > from whether the data is owned by userspace, peripheral memory, the > page cache or anything else. Would that be indicated by a bit on the skb (like pfmemalloc), or a bit in the skb_shared structure, as I'm leaning towards doing here? > > > I think it's good to split into multiple smaller patchsets, starting > > > with core stack support. But find it hard to understand which of these > > > changes are truly needed to support a new use case. > > > > Agree - kind of hard to see why this is done without a use case. > > These patches are purely restructuring, and don't introduce any > > new features. > > > > > > > If anything, eating up the last 8 bits in skb_shared_info should be last resort. > > > > I would like to add 2 more bits in the future, which is why I > > moved them. Is there a compelling reason to leave the bits alone? > > Opportunity cost. > > We cannot grow skb_shared_info due to colocation with MTU sized linear > skbuff's in half a page. > > It took me quite some effort to free up a few bytes in commit > 4d276eb6a478 ("net: remove deprecated syststamp timestamp"). > > If we are very frugal, we could shadow some bits to have different > meaning in different paths. SKBTX_IN_PROGRESS is transmit only, I > think. But otherwise we'll have to just dedicate the byte to more > flags. Yours are likely not to be the last anyway. The zerocopy/enable flags could be encoded in one of the lower 3 bits in the destructor_arg, (similar to nouarg) but that seems messy.
> > > - marking the skb data as inaccessible so skb_condense() > > > and skb_zeroocopy_clone() leave it alone. > > > > Yep. Skipping content access on the Rx path will be interesting. I > > wonder if that should be a separate opaque skb feature, independent > > from whether the data is owned by userspace, peripheral memory, the > > page cache or anything else. > > Would that be indicated by a bit on the skb (like pfmemalloc), or > a bit in the skb_shared structure, as I'm leaning towards doing here? I would guide it in part by avoiding cold cacheline accesses. That might be hard if using skb_shinfo. OTOH, you don't have to worry about copying the bit during clone operations. > > > > If anything, eating up the last 8 bits in skb_shared_info should be last resort. > > > > > > I would like to add 2 more bits in the future, which is why I > > > moved them. Is there a compelling reason to leave the bits alone? > > > > Opportunity cost. > > > > We cannot grow skb_shared_info due to colocation with MTU sized linear > > skbuff's in half a page. > > > > It took me quite some effort to free up a few bytes in commit > > 4d276eb6a478 ("net: remove deprecated syststamp timestamp"). > > > > If we are very frugal, we could shadow some bits to have different > > meaning in different paths. SKBTX_IN_PROGRESS is transmit only, I > > think. But otherwise we'll have to just dedicate the byte to more > > flags. Yours are likely not to be the last anyway. > > The zerocopy/enable flags could be encoded in one of the lower 3 bits > in the destructor_arg, (similar to nouarg) but that seems messy. Agreed :) Let's just expand the flags for now. It may be better to have one general purpose 16 bit flags bitmap, rather than reserving 8 bits specifically to zerocopy features.
On Mon, Dec 21, 2020 at 05:52:08PM -0500, Willem de Bruijn wrote: > > > > - marking the skb data as inaccessible so skb_condense() > > > > and skb_zeroocopy_clone() leave it alone. > > > > > > Yep. Skipping content access on the Rx path will be interesting. I > > > wonder if that should be a separate opaque skb feature, independent > > > from whether the data is owned by userspace, peripheral memory, the > > > page cache or anything else. > > > > Would that be indicated by a bit on the skb (like pfmemalloc), or > > a bit in the skb_shared structure, as I'm leaning towards doing here? > > I would guide it in part by avoiding cold cacheline accesses. That > might be hard if using skb_shinfo. OTOH, you don't have to worry about > copying the bit during clone operations. > > > > > > If anything, eating up the last 8 bits in skb_shared_info should be last resort. > > > > > > > > I would like to add 2 more bits in the future, which is why I > > > > moved them. Is there a compelling reason to leave the bits alone? > > > > > > Opportunity cost. > > > > > > We cannot grow skb_shared_info due to colocation with MTU sized linear > > > skbuff's in half a page. > > > > > > It took me quite some effort to free up a few bytes in commit > > > 4d276eb6a478 ("net: remove deprecated syststamp timestamp"). > > > > > > If we are very frugal, we could shadow some bits to have different > > > meaning in different paths. SKBTX_IN_PROGRESS is transmit only, I > > > think. But otherwise we'll have to just dedicate the byte to more > > > flags. Yours are likely not to be the last anyway. > > > > The zerocopy/enable flags could be encoded in one of the lower 3 bits > > in the destructor_arg, (similar to nouarg) but that seems messy. > > Agreed :) > > Let's just expand the flags for now. It may be better to have one > general purpose 16 bit flags bitmap, rather than reserving 8 bits > specifically to zerocopy features. I was considering doing that also, but that would need to rearrange the flags in skb_shared_info. Then I realized that there are currently only TX flags and ZC flags, so went with that. I have no objections to doing it either way. My motivation here is when MSG_ZCTAP is added to tcp_sendmsg_locked(), it the returned uarg is self-contained for the rest of the function.
From: Jonathan Lemon <bsd@fb.com> This is set of cleanup patches for zerocopy which are intended to allow a introduction of a different zerocopy implementation. The top level api will use the skb_zcopy_*() functions, while the current TCP specific zerocopy would use the sock_zerocopy_*() calls. There should be no functional changes from these patches. Patch 1: Move zerocopy bits from tx_flags into zc_flags for clarity. These bits will be used in the RX path in the future. Patch 2: remove dead function Patch 3: Replace sock_zerocopy_put() with skb_zcopy_put(), moving the zerocopy logic into sock_zerocopy_callback(). Push the refcounting into the callback, since not all implemenetations will have a refcount. Patch 4: rename sock_zerocopy_get for consistency. Patch 5: Add an optional skb parameter to callback, allowing access to the attached skb from the callback. Patch 6: Add skb_zcopy_put_abort, and move zerocopy logic into the callback function. There unfortunately is still a check against the callback type here. Patch 7: Set the skb zc_flags from the ubuf being attached, instead of a fixed value, allowing different initialization types. Patch 8: Replace open-coded assignments Patch 9: Relocate skb_zcopy_clear() in skb_release_data() Jonathan Lemon (9): net: group skb_shinfo zerocopy related bits together. skbuff: remove unused skb_zcopy_abort function skbuff: replace sock_zerocopy_put() with skb_zcopy_put() skbuff: replace sock_zerocopy_get with skb_zcopy_get skbuff: Add skb parameter to the ubuf zerocopy callback skbuff: Call sock_zerocopy_put_abort from skb_zcopy_put_abort skbuff: add zc_flags to ubuf_info for ubuf setup tap/tun: use skb_zcopy_set() instead of open coded assignment skbuff: Call skb_zcopy_clear() before unref'ing fragments drivers/net/tap.c | 6 +-- drivers/net/tun.c | 6 +-- drivers/net/xen-netback/common.h | 3 +- drivers/net/xen-netback/interface.c | 4 +- drivers/net/xen-netback/netback.c | 7 +-- drivers/vhost/net.c | 4 +- include/linux/skbuff.h | 77 +++++++++++++++-------------- net/core/skbuff.c | 48 +++++++++--------- net/ipv4/ip_output.c | 3 +- net/ipv4/tcp.c | 6 +-- net/ipv6/ip6_output.c | 3 +- net/kcm/kcmsock.c | 4 +- 12 files changed, 85 insertions(+), 86 deletions(-)