diff mbox series

hugetlbfs: correct obsolete function name hugetlbfs_read_iter()

Message ID 20210116093245.47472-1-linmiaohe@huawei.com (mailing list archive)
State New, archived
Headers show
Series hugetlbfs: correct obsolete function name hugetlbfs_read_iter() | expand

Commit Message

Miaohe Lin Jan. 16, 2021, 9:32 a.m. UTC
The func do_generic_mapping_read() is killed by commit 36e789144267 ("kill
do_generic_mapping_read"). So replace it with do_generic_mapping_read to
keep comment uptodate.

Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>
---
 fs/hugetlbfs/inode.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Souptick Joarder Jan. 16, 2021, 9:36 a.m. UTC | #1
On Sat, Jan 16, 2021 at 3:03 PM Miaohe Lin <linmiaohe@huawei.com> wrote:
>
> The func do_generic_mapping_read() is killed by commit 36e789144267 ("kill
> do_generic_mapping_read"). So replace it with do_generic_mapping_read to
> keep comment uptodate.

s/func/function

replace it with generic_file_buffered_read()  ?

>
> Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>
> ---
>  fs/hugetlbfs/inode.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c
> index 23ad6ed8b75f..d02616513b43 100644
> --- a/fs/hugetlbfs/inode.c
> +++ b/fs/hugetlbfs/inode.c
> @@ -310,7 +310,7 @@ hugetlbfs_read_actor(struct page *page, unsigned long offset,
>
>  /*
>   * Support for read() - Find the page attached to f_mapping and copy out the
> - * data. Its *very* similar to do_generic_mapping_read(), we can't use that
> + * data. Its *very* similar to generic_file_buffered_read(), we can't use that
>   * since it has PAGE_SIZE assumptions.
>   */
>  static ssize_t hugetlbfs_read_iter(struct kiocb *iocb, struct iov_iter *to)
> --
> 2.19.1
>
>
Miaohe Lin Jan. 16, 2021, 9:44 a.m. UTC | #2
Hi:

On 2021/1/16 17:36, Souptick Joarder wrote:
> On Sat, Jan 16, 2021 at 3:03 PM Miaohe Lin <linmiaohe@huawei.com> wrote:
>>
>> The func do_generic_mapping_read() is killed by commit 36e789144267 ("kill
>> do_generic_mapping_read"). So replace it with do_generic_mapping_read to
>> keep comment uptodate.
> 
> s/func/function
> 
> replace it with generic_file_buffered_read()  ?
> 

Many thanks for your review. I'am going to resend this patch as I forgot to mention the
second commit that rename do_generic_file_read to generic_file_buffered_read. But it looks
I should send a v2 now to fix above comment.

Thanks again.

>>
>> Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>
>> ---
>>  fs/hugetlbfs/inode.c | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c
>> index 23ad6ed8b75f..d02616513b43 100644
>> --- a/fs/hugetlbfs/inode.c
>> +++ b/fs/hugetlbfs/inode.c
>> @@ -310,7 +310,7 @@ hugetlbfs_read_actor(struct page *page, unsigned long offset,
>>
>>  /*
>>   * Support for read() - Find the page attached to f_mapping and copy out the
>> - * data. Its *very* similar to do_generic_mapping_read(), we can't use that
>> + * data. Its *very* similar to generic_file_buffered_read(), we can't use that
>>   * since it has PAGE_SIZE assumptions.
>>   */
>>  static ssize_t hugetlbfs_read_iter(struct kiocb *iocb, struct iov_iter *to)
>> --
>> 2.19.1
>>
>>
> .
>
diff mbox series

Patch

diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c
index 23ad6ed8b75f..d02616513b43 100644
--- a/fs/hugetlbfs/inode.c
+++ b/fs/hugetlbfs/inode.c
@@ -310,7 +310,7 @@  hugetlbfs_read_actor(struct page *page, unsigned long offset,
 
 /*
  * Support for read() - Find the page attached to f_mapping and copy out the
- * data. Its *very* similar to do_generic_mapping_read(), we can't use that
+ * data. Its *very* similar to generic_file_buffered_read(), we can't use that
  * since it has PAGE_SIZE assumptions.
  */
 static ssize_t hugetlbfs_read_iter(struct kiocb *iocb, struct iov_iter *to)