mbox series

[V2,net-next,00/11] net: hns3: some cleanups for -next

Message ID 1612838521-59915-1-git-send-email-tanhuazhong@huawei.com (mailing list archive)
Headers show
Series net: hns3: some cleanups for -next | expand

Message

Huazhong Tan Feb. 9, 2021, 2:41 a.m. UTC
There are some cleanups for the HNS3 ethernet driver.

change log:
V2: remove previous #3 which should target net.

previous version:
V1: https://patchwork.kernel.org/project/netdevbpf/cover/1612784382-27262-1-git-send-email-tanhuazhong@huawei.com/

Huazhong Tan (2):
  net: hns3: remove redundant return value of hns3_uninit_all_ring()
  net: hns3: remove an unused parameter in hclge_vf_rate_param_check()

Jian Shen (2):
  net: hns3: remove redundant client_setup_tc handle
  net: hns3: cleanup for endian issue for VF RSS

Jiaran Zhang (1):
  net: hns3: modify some unmacthed types print parameter

Peng Li (4):
  net: hns3: remove the shaper param magic number
  net: hns3: change hclge_parse_speed() param type
  net: hns3: change hclge_query_bd_num() param type
  net: hns3: remove unused macro definition

Yonglong Liu (1):
  net: hns3: clean up some incorrect variable types in
    hclge_dbg_dump_tm_map()

Yufeng Mo (1):
  net: hns3: clean up unnecessary parentheses in macro definitions

 drivers/net/ethernet/hisilicon/hns3/hnae3.h        |  7 +++--
 drivers/net/ethernet/hisilicon/hns3/hns3_debugfs.c |  2 +-
 drivers/net/ethernet/hisilicon/hns3/hns3_enet.c    | 31 ++++------------------
 drivers/net/ethernet/hisilicon/hns3/hns3_enet.h    | 11 ++++----
 drivers/net/ethernet/hisilicon/hns3/hns3_ethtool.c |  2 +-
 .../net/ethernet/hisilicon/hns3/hns3pf/hclge_cmd.h |  4 +--
 .../net/ethernet/hisilicon/hns3/hns3pf/hclge_dcb.c | 27 -------------------
 .../ethernet/hisilicon/hns3/hns3pf/hclge_debugfs.c | 11 ++++----
 .../net/ethernet/hisilicon/hns3/hns3pf/hclge_err.c |  4 +--
 .../ethernet/hisilicon/hns3/hns3pf/hclge_main.c    | 14 +++++-----
 .../ethernet/hisilicon/hns3/hns3pf/hclge_main.h    |  5 +---
 .../net/ethernet/hisilicon/hns3/hns3pf/hclge_mbx.c |  2 +-
 .../net/ethernet/hisilicon/hns3/hns3pf/hclge_tm.c  | 14 +++++-----
 .../net/ethernet/hisilicon/hns3/hns3pf/hclge_tm.h  |  6 ++---
 .../ethernet/hisilicon/hns3/hns3vf/hclgevf_cmd.h   | 11 ++++----
 .../ethernet/hisilicon/hns3/hns3vf/hclgevf_main.c  | 19 ++++++++-----
 16 files changed, 61 insertions(+), 109 deletions(-)

Comments

Jakub Kicinski Feb. 9, 2021, 2:49 a.m. UTC | #1
On Tue, 9 Feb 2021 10:41:50 +0800 Huazhong Tan wrote:
> There are some cleanups for the HNS3 ethernet driver.
> 
> change log:
> V2: remove previous #3 which should target net.
> 
> previous version:
> V1: https://patchwork.kernel.org/project/netdevbpf/cover/1612784382-27262-1-git-send-email-tanhuazhong@huawei.com/

Thank you!

Acked-by: Jakub Kicinski <kuba@kernel.org>
patchwork-bot+netdevbpf@kernel.org Feb. 9, 2021, 11:50 p.m. UTC | #2
Hello:

This series was applied to netdev/net-next.git (refs/heads/master):

On Tue, 9 Feb 2021 10:41:50 +0800 you wrote:
> There are some cleanups for the HNS3 ethernet driver.
> 
> change log:
> V2: remove previous #3 which should target net.
> 
> previous version:
> V1: https://patchwork.kernel.org/project/netdevbpf/cover/1612784382-27262-1-git-send-email-tanhuazhong@huawei.com/
> 
> [...]

Here is the summary with links:
  - [V2,net-next,01/11] net: hns3: clean up some incorrect variable types in hclge_dbg_dump_tm_map()
    https://git.kernel.org/netdev/net-next/c/0256844d0f32
  - [V2,net-next,02/11] net: hns3: remove redundant client_setup_tc handle
    https://git.kernel.org/netdev/net-next/c/ae9e492a3664
  - [V2,net-next,03/11] net: hns3: remove the shaper param magic number
    https://git.kernel.org/netdev/net-next/c/9d2a1cea6997
  - [V2,net-next,04/11] net: hns3: clean up unnecessary parentheses in macro definitions
    https://git.kernel.org/netdev/net-next/c/9393eb5034a0
  - [V2,net-next,05/11] net: hns3: modify some unmacthed types print parameter
    https://git.kernel.org/netdev/net-next/c/c5aaf1761883
  - [V2,net-next,06/11] net: hns3: change hclge_parse_speed() param type
    https://git.kernel.org/netdev/net-next/c/6e7f109ee9d8
  - [V2,net-next,07/11] net: hns3: change hclge_query_bd_num() param type
    https://git.kernel.org/netdev/net-next/c/cad8dfe82a9e
  - [V2,net-next,08/11] net: hns3: remove redundant return value of hns3_uninit_all_ring()
    https://git.kernel.org/netdev/net-next/c/64749c9c38a9
  - [V2,net-next,09/11] net: hns3: remove an unused parameter in hclge_vf_rate_param_check()
    https://git.kernel.org/netdev/net-next/c/11ef971f5a6a
  - [V2,net-next,10/11] net: hns3: remove unused macro definition
    https://git.kernel.org/netdev/net-next/c/7ceb40b8207e
  - [V2,net-next,11/11] net: hns3: cleanup for endian issue for VF RSS
    https://git.kernel.org/netdev/net-next/c/55ff3ed57b50

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html