Message ID | af1511df953fe49f95953cbc23d86fb7cdaff58d.1614355914.git.skhan@linuxfoundation.org (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
Series | Add lockdep_assert_not_held() | expand |
Context | Check | Description |
---|---|---|
netdev/tree_selection | success | Not a local patch |
> @@ -5475,7 +5476,7 @@ noinstr int lock_is_held_type(const struct lockdep_map *lock, int read) > /* avoid false negative lockdep_assert_not_held() > * and lockdep_assert_held() > */ > - return -1; > + return LOCK_STATE_UNKNOWN; I'd argue that then the other two return places here should also be changed. johannes
On 2/26/21 11:03 AM, Johannes Berg wrote: > >> @@ -5475,7 +5476,7 @@ noinstr int lock_is_held_type(const struct lockdep_map *lock, int read) >> /* avoid false negative lockdep_assert_not_held() >> * and lockdep_assert_held() >> */ >> - return -1; >> + return LOCK_STATE_UNKNOWN; > > I'd argue that then the other two return places here should also be > changed. > Makes sense. Since lock_is_held_type() simply returns what __lock_is_held() for the other cases, __lock_is_held() is the one that needs changes to use these defines. thanks, -- Shuah
diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h index 93eb5f797fc1..7c2622854152 100644 --- a/include/linux/lockdep.h +++ b/include/linux/lockdep.h @@ -261,6 +261,11 @@ extern void lock_acquire(struct lockdep_map *lock, unsigned int subclass, extern void lock_release(struct lockdep_map *lock, unsigned long ip); +/* lock_is_held_type() returns */ +#define LOCK_STATE_UNKNOWN -1 +#define LOCK_STATE_NOT_HELD 0 +#define LOCK_STATE_HELD 1 + /* * Same "read" as for lock_acquire(), except -1 means any. */ @@ -295,11 +300,13 @@ extern void lock_unpin_lock(struct lockdep_map *lock, struct pin_cookie); #define lockdep_depth(tsk) (debug_locks ? (tsk)->lockdep_depth : 0) #define lockdep_assert_held(l) do { \ - WARN_ON(debug_locks && lockdep_is_held(l) == 0); \ + WARN_ON(debug_locks && \ + lockdep_is_held(l) == LOCK_STATE_NOT_HELD); \ } while (0) #define lockdep_assert_not_held(l) do { \ - WARN_ON(debug_locks && lockdep_is_held(l) == 1); \ + WARN_ON(debug_locks && \ + lockdep_is_held(l) == LOCK_STATE_HELD); \ } while (0) #define lockdep_assert_held_write(l) do { \ diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c index d3299fd85c4a..e3898c888ad2 100644 --- a/kernel/locking/lockdep.c +++ b/kernel/locking/lockdep.c @@ -54,6 +54,7 @@ #include <linux/nmi.h> #include <linux/rcupdate.h> #include <linux/kprobes.h> +#include <linux/lockdep.h> #include <asm/sections.h> @@ -5475,7 +5476,7 @@ noinstr int lock_is_held_type(const struct lockdep_map *lock, int read) /* avoid false negative lockdep_assert_not_held() * and lockdep_assert_held() */ - return -1; + return LOCK_STATE_UNKNOWN; raw_local_irq_save(flags); check_flags(flags);
Adds defines for lock state returns from lock_is_held_type() based on Johannes Berg's suggestions as it make it easier to read and maintain the lock states. These are defines and a enum to avoid changes to lock_is_held_type() and lockdep_is_held() return types. Link: https://lore.kernel.org/lkml/37a29c383bff2fb1605241ee6c7c9be3784fb3c6.1613171185.git.skhan@linuxfoundation.org/ Link: https://lore.kernel.org/linux-wireless/871rdmu9z9.fsf@codeaurora.org/ Signed-off-by: Shuah Khan <skhan@linuxfoundation.org> --- include/linux/lockdep.h | 11 +++++++++-- kernel/locking/lockdep.c | 3 ++- 2 files changed, 11 insertions(+), 3 deletions(-)