mbox series

[v5,0/3] s390/kvm: fix MVPG when in VSIE

Message ID 20210302174443.514363-1-imbrenda@linux.ibm.com (mailing list archive)
Headers show
Series s390/kvm: fix MVPG when in VSIE | expand

Message

Claudio Imbrenda March 2, 2021, 5:44 p.m. UTC
The current handling of the MVPG instruction when executed in a nested
guest is wrong, and can lead to the nested guest hanging.

This patchset fixes the behaviour to be more architecturally correct,
and fixes the hangs observed.

v4->v5
* split kvm_s390_logical_to_effective so it can be reused for vSIE
* fix existing comments and add some more comments
* use the new split _kvm_s390_logical_to_effective in vsie_handle_mvpg

v3->v4
* added PEI_ prefix to DAT_PROT and NOT_PTE macros
* added small comment to explain what they are about

v2->v3
* improved some comments
* improved some variable and parameter names for increased readability
* fixed missing handling of page faults in the MVPG handler
* small readability improvements

v1->v2
* complete rewrite

Claudio Imbrenda (3):
  s390/kvm: split kvm_s390_logical_to_effective
  s390/kvm: extend kvm_s390_shadow_fault to return entry pointer
  s390/kvm: VSIE: correctly handle MVPG when in VSIE

 arch/s390/kvm/gaccess.c |  30 ++++++++++--
 arch/s390/kvm/gaccess.h |  35 ++++++++++---
 arch/s390/kvm/vsie.c    | 106 ++++++++++++++++++++++++++++++++++++----
 3 files changed, 151 insertions(+), 20 deletions(-)

Comments

Christian Borntraeger March 8, 2021, 3:19 p.m. UTC | #1
On 02.03.21 18:44, Claudio Imbrenda wrote:
> The current handling of the MVPG instruction when executed in a nested
> guest is wrong, and can lead to the nested guest hanging.
> 
> This patchset fixes the behaviour to be more architecturally correct,
> and fixes the hangs observed.
> 
> v4->v5
> * split kvm_s390_logical_to_effective so it can be reused for vSIE
> * fix existing comments and add some more comments
> * use the new split _kvm_s390_logical_to_effective in vsie_handle_mvpg
> 
> v3->v4
> * added PEI_ prefix to DAT_PROT and NOT_PTE macros
> * added small comment to explain what they are about
> 
> v2->v3
> * improved some comments
> * improved some variable and parameter names for increased readability
> * fixed missing handling of page faults in the MVPG handler
> * small readability improvements
> 
> v1->v2
> * complete rewrite


queued (with small fixups) for kvms390. Still not sure if this will land in master or next.
Opinions?
> 
> Claudio Imbrenda (3):
>    s390/kvm: split kvm_s390_logical_to_effective
>    s390/kvm: extend kvm_s390_shadow_fault to return entry pointer
>    s390/kvm: VSIE: correctly handle MVPG when in VSIE
> 
>   arch/s390/kvm/gaccess.c |  30 ++++++++++--
>   arch/s390/kvm/gaccess.h |  35 ++++++++++---
>   arch/s390/kvm/vsie.c    | 106 ++++++++++++++++++++++++++++++++++++----
>   3 files changed, 151 insertions(+), 20 deletions(-)
>
Janosch Frank March 8, 2021, 3:26 p.m. UTC | #2
On 3/8/21 4:19 PM, Christian Borntraeger wrote:
> On 02.03.21 18:44, Claudio Imbrenda wrote:
>> The current handling of the MVPG instruction when executed in a nested
>> guest is wrong, and can lead to the nested guest hanging.
>>
>> This patchset fixes the behaviour to be more architecturally correct,
>> and fixes the hangs observed.
>>
>> v4->v5
>> * split kvm_s390_logical_to_effective so it can be reused for vSIE
>> * fix existing comments and add some more comments
>> * use the new split _kvm_s390_logical_to_effective in vsie_handle_mvpg
>>
>> v3->v4
>> * added PEI_ prefix to DAT_PROT and NOT_PTE macros
>> * added small comment to explain what they are about
>>
>> v2->v3
>> * improved some comments
>> * improved some variable and parameter names for increased readability
>> * fixed missing handling of page faults in the MVPG handler
>> * small readability improvements
>>
>> v1->v2
>> * complete rewrite
> 
> 
> queued (with small fixups) for kvms390. Still not sure if this will land in master or next.
> Opinions?

I'd go for the next merge window

>>
>> Claudio Imbrenda (3):
>>    s390/kvm: split kvm_s390_logical_to_effective
>>    s390/kvm: extend kvm_s390_shadow_fault to return entry pointer
>>    s390/kvm: VSIE: correctly handle MVPG when in VSIE
>>
>>   arch/s390/kvm/gaccess.c |  30 ++++++++++--
>>   arch/s390/kvm/gaccess.h |  35 ++++++++++---
>>   arch/s390/kvm/vsie.c    | 106 ++++++++++++++++++++++++++++++++++++----
>>   3 files changed, 151 insertions(+), 20 deletions(-)
>>
Claudio Imbrenda March 8, 2021, 3:30 p.m. UTC | #3
On Mon, 8 Mar 2021 16:26:58 +0100
Janosch Frank <frankja@linux.ibm.com> wrote:

> On 3/8/21 4:19 PM, Christian Borntraeger wrote:
> > On 02.03.21 18:44, Claudio Imbrenda wrote:  
> >> The current handling of the MVPG instruction when executed in a
> >> nested guest is wrong, and can lead to the nested guest hanging.
> >>
> >> This patchset fixes the behaviour to be more architecturally
> >> correct, and fixes the hangs observed.
> >>
> >> v4->v5
> >> * split kvm_s390_logical_to_effective so it can be reused for vSIE
> >> * fix existing comments and add some more comments
> >> * use the new split _kvm_s390_logical_to_effective in
> >> vsie_handle_mvpg
> >>
> >> v3->v4
> >> * added PEI_ prefix to DAT_PROT and NOT_PTE macros
> >> * added small comment to explain what they are about
> >>
> >> v2->v3
> >> * improved some comments
> >> * improved some variable and parameter names for increased
> >> readability
> >> * fixed missing handling of page faults in the MVPG handler
> >> * small readability improvements
> >>
> >> v1->v2
> >> * complete rewrite  
> > 
> > 
> > queued (with small fixups) for kvms390. Still not sure if this will
> > land in master or next. Opinions?  
> 
> I'd go for the next merge window

I agree

> >>
> >> Claudio Imbrenda (3):
> >>    s390/kvm: split kvm_s390_logical_to_effective
> >>    s390/kvm: extend kvm_s390_shadow_fault to return entry pointer
> >>    s390/kvm: VSIE: correctly handle MVPG when in VSIE
> >>
> >>   arch/s390/kvm/gaccess.c |  30 ++++++++++--
> >>   arch/s390/kvm/gaccess.h |  35 ++++++++++---
> >>   arch/s390/kvm/vsie.c    | 106
> >> ++++++++++++++++++++++++++++++++++++---- 3 files changed, 151
> >> insertions(+), 20 deletions(-) 
>