diff mbox series

[PATCHv2,01/38] ARM: dts: motorola-cpcap-mapphone: Prepare for dtbs_check parsing

Message ID 20210317134904.80737-2-sebastian.reichel@collabora.com (mailing list archive)
State New, archived
Headers show
Series [PATCHv2,01/38] ARM: dts: motorola-cpcap-mapphone: Prepare for dtbs_check parsing | expand

Commit Message

Sebastian Reichel March 17, 2021, 1:48 p.m. UTC
'<&gpio1 parameters &gpio2 parameters>' and '<&gpio1 parameters>,
<&gpio2 parameters>' result in the same DTB, but second format has
better source code readability. Also 'dtbs_check' currently uses
this format to determine the amount of items specified, so using
this syntax is needed to successfully verify the devicetree source
against a DT schema format.

Cc: Tony Lindgren <tony@atomide.com>
Cc: linux-omap@vger.kernel.org
Signed-off-by: Sebastian Reichel <sebastian.reichel@collabora.com>
---
 .../arm/boot/dts/motorola-cpcap-mapphone.dtsi | 59 +++++++++----------
 1 file changed, 28 insertions(+), 31 deletions(-)

Comments

Tony Lindgren March 17, 2021, 2:29 p.m. UTC | #1
* Sebastian Reichel <sebastian.reichel@collabora.com> [210317 13:50]:
> '<&gpio1 parameters &gpio2 parameters>' and '<&gpio1 parameters>,
> <&gpio2 parameters>' result in the same DTB, but second format has
> better source code readability. Also 'dtbs_check' currently uses
> this format to determine the amount of items specified, so using
> this syntax is needed to successfully verify the devicetree source
> against a DT schema format.

Looks good to me:

Acked-by: Tony Lindgren <tony@atomide.com>
Sebastian Reichel March 23, 2021, 12:51 p.m. UTC | #2
Hi Tony,

On Wed, Mar 17, 2021 at 04:29:19PM +0200, Tony Lindgren wrote:
> * Sebastian Reichel <sebastian.reichel@collabora.com> [210317 13:50]:
> > '<&gpio1 parameters &gpio2 parameters>' and '<&gpio1 parameters>,
> > <&gpio2 parameters>' result in the same DTB, but second format has
> > better source code readability. Also 'dtbs_check' currently uses
> > this format to determine the amount of items specified, so using
> > this syntax is needed to successfully verify the devicetree source
> > against a DT schema format.
> 
> Looks good to me:
> 
> Acked-by: Tony Lindgren <tony@atomide.com>

Please take this patch via your tree. I will take the other ones
through the power-supply tree.

Thanks,

-- Sebastian
Tony Lindgren March 23, 2021, 12:56 p.m. UTC | #3
* Sebastian Reichel <sebastian.reichel@collabora.com> [210323 12:52]:
> Hi Tony,
> 
> On Wed, Mar 17, 2021 at 04:29:19PM +0200, Tony Lindgren wrote:
> > * Sebastian Reichel <sebastian.reichel@collabora.com> [210317 13:50]:
> > > '<&gpio1 parameters &gpio2 parameters>' and '<&gpio1 parameters>,
> > > <&gpio2 parameters>' result in the same DTB, but second format has
> > > better source code readability. Also 'dtbs_check' currently uses
> > > this format to determine the amount of items specified, so using
> > > this syntax is needed to successfully verify the devicetree source
> > > against a DT schema format.
> > 
> > Looks good to me:
> > 
> > Acked-by: Tony Lindgren <tony@atomide.com>
> 
> Please take this patch via your tree. I will take the other ones
> through the power-supply tree.

OK will do.

Thanks,

Tony
diff mbox series

Patch

diff --git a/arch/arm/boot/dts/motorola-cpcap-mapphone.dtsi b/arch/arm/boot/dts/motorola-cpcap-mapphone.dtsi
index 08a7d3ce383f..ea02fd403a9b 100644
--- a/arch/arm/boot/dts/motorola-cpcap-mapphone.dtsi
+++ b/arch/arm/boot/dts/motorola-cpcap-mapphone.dtsi
@@ -27,16 +27,14 @@  cpcap_adc: adc {
 
 		cpcap_battery: battery {
 			compatible = "motorola,cpcap-battery";
-			interrupts-extended = <
-				&cpcap 6 0 &cpcap 5 0 &cpcap 3 0
-				&cpcap 20 0 &cpcap 54 0 &cpcap 57 0
-			>;
+			interrupts-extended =
+				<&cpcap 6 0>, <&cpcap 5 0>, <&cpcap 3 0>,
+				<&cpcap 20 0>, <&cpcap 54 0>, <&cpcap 57 0>;
 			interrupt-names =
 				"eol", "lowbph", "lowbpl",
-				"chrgcurr1", "battdetb",
-				"cccal";
-			io-channels = <&cpcap_adc 0 &cpcap_adc 1
-				       &cpcap_adc 5 &cpcap_adc 6>;
+				"chrgcurr1", "battdetb", "cccal";
+			io-channels = <&cpcap_adc 0>, <&cpcap_adc 1>,
+				      <&cpcap_adc 5>, <&cpcap_adc 6>;
 			io-channel-names = "battdetb", "battp",
 					   "chg_isense", "batti";
 			power-supplies = <&cpcap_charger>;
@@ -44,20 +42,19 @@  &cpcap 20 0 &cpcap 54 0 &cpcap 57 0
 
 		cpcap_charger: charger {
 			compatible = "motorola,mapphone-cpcap-charger";
-			interrupts-extended = <
-				&cpcap 13 0 &cpcap 12 0 &cpcap 29 0 &cpcap 28 0
-				&cpcap 22 0 &cpcap 21 0 &cpcap 20 0 &cpcap 19 0
-				&cpcap 54 0
-			>;
+			interrupts-extended =
+				<&cpcap 13 0>, <&cpcap 12 0>, <&cpcap 29 0>,
+				<&cpcap 28 0>, <&cpcap 22 0>, <&cpcap 21 0>,
+				<&cpcap 20 0>, <&cpcap 19 0>, <&cpcap 54 0>;
 			interrupt-names =
-				"chrg_det", "rvrs_chrg", "chrg_se1b", "se0conn",
-				"rvrs_mode", "chrgcurr2", "chrgcurr1", "vbusvld",
-				"battdetb";
-			mode-gpios = <&gpio3 29 GPIO_ACTIVE_LOW
-				      &gpio3 23 GPIO_ACTIVE_LOW>;
-			io-channels = <&cpcap_adc 0 &cpcap_adc 1
-				       &cpcap_adc 2 &cpcap_adc 5
-				       &cpcap_adc 6>;
+				"chrg_det", "rvrs_chrg", "chrg_se1b",
+				"se0conn", "rvrs_mode", "chrgcurr2",
+				"chrgcurr1", "vbusvld", "battdetb";
+			mode-gpios = <&gpio3 29 GPIO_ACTIVE_LOW>,
+				     <&gpio3 23 GPIO_ACTIVE_LOW>;
+			io-channels = <&cpcap_adc 0>, <&cpcap_adc 1>,
+				      <&cpcap_adc 2>, <&cpcap_adc 5>,
+				      <&cpcap_adc 6>;
 			io-channel-names = "battdetb", "battp",
 					   "vbus", "chg_isense",
 					   "batti";
@@ -98,22 +95,22 @@  power_button: button {
 
 		cpcap_usb2_phy: phy {
 			compatible = "motorola,mapphone-cpcap-usb-phy";
-			pinctrl-0 = <&usb_gpio_mux_sel1 &usb_gpio_mux_sel2>;
+			pinctrl-0 = <&usb_gpio_mux_sel1>, <&usb_gpio_mux_sel2>;
 			pinctrl-1 = <&usb_ulpi_pins>;
 			pinctrl-2 = <&usb_utmi_pins>;
 			pinctrl-3 = <&uart3_pins>;
 			pinctrl-names = "default", "ulpi", "utmi", "uart";
 			#phy-cells = <0>;
-			interrupts-extended = <
-				&cpcap 15 0 &cpcap 14 0 &cpcap 28 0 &cpcap 19 0
-				&cpcap 18 0 &cpcap 17 0 &cpcap 16 0 &cpcap 49 0
-				&cpcap 48 0
-			>;
+			interrupts-extended =
+				<&cpcap 15 0>, <&cpcap 14 0>, <&cpcap 28 0>,
+				<&cpcap 19 0>, <&cpcap 18 0>, <&cpcap 17 0>,
+				<&cpcap 16 0>, <&cpcap 49 0>, <&cpcap 48 0>;
 			interrupt-names =
-				"id_ground", "id_float", "se0conn", "vbusvld",
-				"sessvld", "sessend", "se1", "dm", "dp";
-			mode-gpios = <&gpio2 28 GPIO_ACTIVE_HIGH
-				      &gpio1 0 GPIO_ACTIVE_HIGH>;
+				"id_ground", "id_float", "se0conn",
+				"vbusvld", "sessvld", "sessend",
+				"se1", "dm", "dp";
+			mode-gpios = <&gpio2 28 GPIO_ACTIVE_HIGH>,
+				     <&gpio1 0 GPIO_ACTIVE_HIGH>;
 			io-channels = <&cpcap_adc 2>, <&cpcap_adc 7>;
 			io-channel-names = "vbus", "id";
 			vusb-supply = <&vusb>;