diff mbox series

[5/9] send-email: use function syntax instead of barewords

Message ID patch-5.9-8846d40fc0-20210512T132955Z-avarab@gmail.com (mailing list archive)
State Superseded
Headers show
Series send-email: various optimizations to speed up by >2x | expand

Commit Message

Ævar Arnfjörð Bjarmason May 12, 2021, 1:48 p.m. UTC
Change calls like "__ 'foo'" to "__('foo')" so the Perl compiler
doesn't have to guess that "__" is a function. This makes the code
more readable.

Signed-off-by: Ævar Arnfjörð Bjarmason <avarab@gmail.com>
---
 git-send-email.perl | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Jeff King May 12, 2021, 11:11 p.m. UTC | #1
On Wed, May 12, 2021 at 03:48:21PM +0200, Ævar Arnfjörð Bjarmason wrote:

> Change calls like "__ 'foo'" to "__('foo')" so the Perl compiler
> doesn't have to guess that "__" is a function. This makes the code
> more readable.

I think this is a good change. And while you do qualify it as "more"
readable, I think the main issue with readability here:

> diff --git a/git-send-email.perl b/git-send-email.perl
> index 9ff315f775..da46925aa0 100755
> --- a/git-send-email.perl
> +++ b/git-send-email.perl
> @@ -678,7 +678,7 @@ sub is_format_patch_arg {
>  		if (defined($format_patch)) {
>  			return $format_patch;
>  		}
> -		die sprintf(__ <<EOF, $f, $f);
> +		die sprintf(__(<<EOF), $f, $f);
>  File '%s' exists but it could also be the range of commits
>  to produce patches for.  Please disambiguate by...

is how far the "EOF" marker is from the actual here-doc, syntactically
(plus the ugly indentation). I suspect this and other places might be
nicer to assign from the here-doc into a well-named variable.

But I think it's fine to leave for now (and I worry a bit that it may
turn into a rabbit hole, so we might be better to just leave it alone
anyway).

-Peff
diff mbox series

Patch

diff --git a/git-send-email.perl b/git-send-email.perl
index 9ff315f775..da46925aa0 100755
--- a/git-send-email.perl
+++ b/git-send-email.perl
@@ -678,7 +678,7 @@  sub is_format_patch_arg {
 		if (defined($format_patch)) {
 			return $format_patch;
 		}
-		die sprintf(__ <<EOF, $f, $f);
+		die sprintf(__(<<EOF), $f, $f);
 File '%s' exists but it could also be the range of commits
 to produce patches for.  Please disambiguate by...
 
@@ -764,7 +764,7 @@  sub get_patch_subject {
 	my $tpl_in_reply_to = $initial_in_reply_to || '';
 	my $tpl_reply_to = $reply_to || '';
 
-	print $c <<EOT1, Git::prefix_lines("GIT: ", __ <<EOT2), <<EOT3;
+	print $c <<EOT1, Git::prefix_lines("GIT: ", __(<<EOT2)), <<EOT3;
 From $tpl_sender # This line is ignored.
 EOT1
 Lines beginning in "GIT:" will be removed.