Message ID | 20210520134116.36872-1-yuehaibing@huawei.com (mailing list archive) |
---|---|
State | Accepted |
Commit | 7567d603b3f1c5ee799e311d0e48932bfc449028 |
Headers | show |
Series | [net-next] net: usb: hso: use DEVICE_ATTR_RO macro | expand |
Hello: This patch was applied to netdev/net-next.git (refs/heads/master): On Thu, 20 May 2021 21:41:16 +0800 you wrote: > Use DEVICE_ATTR_RO helper instead of plain DEVICE_ATTR, > which makes the code a bit shorter and easier to read. > > Signed-off-by: YueHaibing <yuehaibing@huawei.com> > --- > drivers/net/usb/hso.c | 7 +++---- > 1 file changed, 3 insertions(+), 4 deletions(-) Here is the summary with links: - [net-next] net: usb: hso: use DEVICE_ATTR_RO macro https://git.kernel.org/netdev/net-next/c/7567d603b3f1 You are awesome, thank you! -- Deet-doot-dot, I am a bot. https://korg.docs.kernel.org/patchwork/pwbot.html
diff --git a/drivers/net/usb/hso.c b/drivers/net/usb/hso.c index 63e394cafc17..d84258c70d0c 100644 --- a/drivers/net/usb/hso.c +++ b/drivers/net/usb/hso.c @@ -457,9 +457,8 @@ static const struct usb_device_id hso_ids[] = { MODULE_DEVICE_TABLE(usb, hso_ids); /* Sysfs attribute */ -static ssize_t hso_sysfs_show_porttype(struct device *dev, - struct device_attribute *attr, - char *buf) +static ssize_t hsotype_show(struct device *dev, + struct device_attribute *attr, char *buf) { struct hso_device *hso_dev = dev_get_drvdata(dev); char *port_name; @@ -505,7 +504,7 @@ static ssize_t hso_sysfs_show_porttype(struct device *dev, return sprintf(buf, "%s\n", port_name); } -static DEVICE_ATTR(hsotype, 0444, hso_sysfs_show_porttype, NULL); +static DEVICE_ATTR_RO(hsotype); static struct attribute *hso_serial_dev_attrs[] = { &dev_attr_hsotype.attr,
Use DEVICE_ATTR_RO helper instead of plain DEVICE_ATTR, which makes the code a bit shorter and easier to read. Signed-off-by: YueHaibing <yuehaibing@huawei.com> --- drivers/net/usb/hso.c | 7 +++---- 1 file changed, 3 insertions(+), 4 deletions(-)