diff mbox series

ARM: bL_switcher: use IS_ERR_OR_NULL() to simplify code

Message ID 20210624074223.11372-1-tangbin@cmss.chinamobile.com (mailing list archive)
State New, archived
Headers show
Series ARM: bL_switcher: use IS_ERR_OR_NULL() to simplify code | expand

Commit Message

Tang Bin June 24, 2021, 7:42 a.m. UTC
Use IS_ERR_OR_NULL() instead of IS_ERR() to simplify code.

Signed-off-by: Tang Bin <tangbin@cmss.chinamobile.com>
---
 arch/arm/common/bL_switcher.c | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)

Comments

Russell King (Oracle) June 24, 2021, 9:23 a.m. UTC | #1
On Thu, Jun 24, 2021 at 03:42:23PM +0800, Tang Bin wrote:
> diff --git a/arch/arm/common/bL_switcher.c b/arch/arm/common/bL_switcher.c
> index 9a9aa5354..b8e8e2567 100644
> --- a/arch/arm/common/bL_switcher.c
> +++ b/arch/arm/common/bL_switcher.c
> @@ -352,11 +352,9 @@ int bL_switch_request_cb(unsigned int cpu, unsigned int new_cluster_id,
>  
>  	t = &bL_threads[cpu];
>  
> -	if (IS_ERR(t->task))
> -		return PTR_ERR(t->task);
> -	if (!t->task)
> -		return -ESRCH;
> -
> +	if (IS_ERR_OR_NULL(t->task))
> +		return t->task ? PTR_ERR(t->task) : -ESRCH;
> +
>  	spin_lock(&t->lock);
>  	if (t->completer) {
>  		spin_unlock(&t->lock);

I don't think this improves the code. The original is more readable, and
readability is what we care about rather than code compactness.
diff mbox series

Patch

diff --git a/arch/arm/common/bL_switcher.c b/arch/arm/common/bL_switcher.c
index 9a9aa5354..b8e8e2567 100644
--- a/arch/arm/common/bL_switcher.c
+++ b/arch/arm/common/bL_switcher.c
@@ -352,11 +352,9 @@  int bL_switch_request_cb(unsigned int cpu, unsigned int new_cluster_id,
 
 	t = &bL_threads[cpu];
 
-	if (IS_ERR(t->task))
-		return PTR_ERR(t->task);
-	if (!t->task)
-		return -ESRCH;
-
+	if (IS_ERR_OR_NULL(t->task))
+		return t->task ? PTR_ERR(t->task) : -ESRCH;
+
 	spin_lock(&t->lock);
 	if (t->completer) {
 		spin_unlock(&t->lock);