Message ID | 20210901205722.7328-1-peterx@redhat.com (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | mm: A few cleanup patches around zap, shmem and uffd | expand |
On 01.09.21 22:57, Peter Xu wrote: > Instead of trying to introduce one variable for every new zap_details fields, > let's introduce a flag so that it can start to encode true/false informations. > > Let's start to use this flag first to clean up the only check_mapping variable. > Firstly, the name "check_mapping" implies this is a "boolean", but actually it > stores the mapping inside, just in a way that it won't be set if we don't want > to check the mapping. > > To make things clearer, introduce the 1st zap flag ZAP_FLAG_CHECK_MAPPING, so > that we only check against the mapping if this bit set. At the same time, we > can rename check_mapping into zap_mapping and set it always. > > Since at it, introduce another helper zap_check_mapping_skip() and use it in > zap_pte_range() properly. > > Some old comments have been removed in zap_pte_range() because they're > duplicated, and since now we're with ZAP_FLAG_CHECK_MAPPING flag, it'll be very > easy to grep this information by simply grepping the flag. > > It'll also make life easier when we want to e.g. pass in zap_flags into the > callers like unmap_mapping_pages() (instead of adding new booleans besides the > even_cows parameter). > > Signed-off-by: Peter Xu <peterx@redhat.com> > --- > include/linux/mm.h | 19 ++++++++++++++++++- > mm/memory.c | 34 ++++++++++------------------------ > 2 files changed, 28 insertions(+), 25 deletions(-) > > diff --git a/include/linux/mm.h b/include/linux/mm.h > index 69259229f090..fcbc1c4f8e8e 100644 > --- a/include/linux/mm.h > +++ b/include/linux/mm.h > @@ -1716,14 +1716,31 @@ static inline bool can_do_mlock(void) { return false; } > extern int user_shm_lock(size_t, struct ucounts *); > extern void user_shm_unlock(size_t, struct ucounts *); > > +/* Whether to check page->mapping when zapping */ > +#define ZAP_FLAG_CHECK_MAPPING BIT(0) So we want to go full way, like: typedef int __bitwise zap_flags_t; #define ZAP_FLAG_CHECK_MAPPING ((__force zap_flags_t)BIT(0)) > + > /* > * Parameter block passed down to zap_pte_range in exceptional cases. > */ > struct zap_details { > - struct address_space *check_mapping; /* Check page->mapping if set */ > + struct address_space *zap_mapping; > struct page *single_page; /* Locked page to be unmapped */ > + unsigned long zap_flags; Why call it "zap_*" if everything in the structure is related to zapping? IOW, simply "mapping", "flags" would be good enough. > }; > > +/* Return true if skip zapping this page, false otherwise */ > +static inline bool > +zap_skip_check_mapping(struct zap_details *details, struct page *page) > +{ > + if (!details || !page) > + return false; > + > + if (!(details->zap_flags & ZAP_FLAG_CHECK_MAPPING)) > + return false; > + > + return details->zap_mapping != page_rmapping(page); > +} I'm confused, why isn't "!details->zap_mapping" vs. "details->zap_mapping" sufficient? I can see that you may need flags for other purposes (next patch), but why do we need it here? Factoring it out into this helper is a nice cleanup, though. But I'd just not introduce ZAP_FLAG_CHECK_MAPPING.
On Thu, Sep 02, 2021 at 09:28:42AM +0200, David Hildenbrand wrote: > On 01.09.21 22:57, Peter Xu wrote: > > Instead of trying to introduce one variable for every new zap_details fields, > > let's introduce a flag so that it can start to encode true/false informations. > > > > Let's start to use this flag first to clean up the only check_mapping variable. > > Firstly, the name "check_mapping" implies this is a "boolean", but actually it > > stores the mapping inside, just in a way that it won't be set if we don't want > > to check the mapping. > > > > To make things clearer, introduce the 1st zap flag ZAP_FLAG_CHECK_MAPPING, so > > that we only check against the mapping if this bit set. At the same time, we > > can rename check_mapping into zap_mapping and set it always. > > > > Since at it, introduce another helper zap_check_mapping_skip() and use it in > > zap_pte_range() properly. > > > > Some old comments have been removed in zap_pte_range() because they're > > duplicated, and since now we're with ZAP_FLAG_CHECK_MAPPING flag, it'll be very > > easy to grep this information by simply grepping the flag. > > > > It'll also make life easier when we want to e.g. pass in zap_flags into the > > callers like unmap_mapping_pages() (instead of adding new booleans besides the > > even_cows parameter). > > > > Signed-off-by: Peter Xu <peterx@redhat.com> > > --- > > include/linux/mm.h | 19 ++++++++++++++++++- > > mm/memory.c | 34 ++++++++++------------------------ > > 2 files changed, 28 insertions(+), 25 deletions(-) > > > > diff --git a/include/linux/mm.h b/include/linux/mm.h > > index 69259229f090..fcbc1c4f8e8e 100644 > > --- a/include/linux/mm.h > > +++ b/include/linux/mm.h > > @@ -1716,14 +1716,31 @@ static inline bool can_do_mlock(void) { return false; } > > extern int user_shm_lock(size_t, struct ucounts *); > > extern void user_shm_unlock(size_t, struct ucounts *); > > +/* Whether to check page->mapping when zapping */ > > +#define ZAP_FLAG_CHECK_MAPPING BIT(0) > > So we want to go full way, like: > > typedef int __bitwise zap_flags_t; > > #define ZAP_FLAG_CHECK_MAPPING ((__force zap_flags_t)BIT(0)) Sure. > > > + > > /* > > * Parameter block passed down to zap_pte_range in exceptional cases. > > */ > > struct zap_details { > > - struct address_space *check_mapping; /* Check page->mapping if set */ > > + struct address_space *zap_mapping; > > struct page *single_page; /* Locked page to be unmapped */ > > + unsigned long zap_flags; > > Why call it "zap_*" if everything in the structure is related to zapping? > IOW, simply "mapping", "flags" would be good enough. Not sure if it's a good habit or bad - it's just for tagging system to be able to identify other "mapping" variables, or a simple grep with the name. So I normally prefix fields with some special wording to avoid collisions. > > > }; > > +/* Return true if skip zapping this page, false otherwise */ > > +static inline bool > > +zap_skip_check_mapping(struct zap_details *details, struct page *page) > > +{ > > + if (!details || !page) > > + return false; > > + > > + if (!(details->zap_flags & ZAP_FLAG_CHECK_MAPPING)) > > + return false; > > + > > + return details->zap_mapping != page_rmapping(page); > > +} > > I'm confused, why isn't "!details->zap_mapping" vs. "details->zap_mapping" > sufficient? I can see that you may need flags for other purposes (next > patch), but why do we need it here? > > Factoring it out into this helper is a nice cleanup, though. But I'd just > not introduce ZAP_FLAG_CHECK_MAPPING. Yes I think it's okay. I wanted to separate them as they're fundamentall two things to me. Example: what if the mapping we want to check is NULL itself (remove private pages only; though it may not have a real user at least so far)? In that case one variable won't be able to cover it. But indeed Matthew raised similar comment, so it seems to be a common preference. No strong opinion on my side, let me coordinate with it. Thanks for looking,
diff --git a/include/linux/mm.h b/include/linux/mm.h index 69259229f090..fcbc1c4f8e8e 100644 --- a/include/linux/mm.h +++ b/include/linux/mm.h @@ -1716,14 +1716,31 @@ static inline bool can_do_mlock(void) { return false; } extern int user_shm_lock(size_t, struct ucounts *); extern void user_shm_unlock(size_t, struct ucounts *); +/* Whether to check page->mapping when zapping */ +#define ZAP_FLAG_CHECK_MAPPING BIT(0) + /* * Parameter block passed down to zap_pte_range in exceptional cases. */ struct zap_details { - struct address_space *check_mapping; /* Check page->mapping if set */ + struct address_space *zap_mapping; struct page *single_page; /* Locked page to be unmapped */ + unsigned long zap_flags; }; +/* Return true if skip zapping this page, false otherwise */ +static inline bool +zap_skip_check_mapping(struct zap_details *details, struct page *page) +{ + if (!details || !page) + return false; + + if (!(details->zap_flags & ZAP_FLAG_CHECK_MAPPING)) + return false; + + return details->zap_mapping != page_rmapping(page); +} + struct page *vm_normal_page(struct vm_area_struct *vma, unsigned long addr, pte_t pte); struct page *vm_normal_page_pmd(struct vm_area_struct *vma, unsigned long addr, diff --git a/mm/memory.c b/mm/memory.c index 3b860f6a51ac..05ccacda4fe9 100644 --- a/mm/memory.c +++ b/mm/memory.c @@ -1333,16 +1333,8 @@ static unsigned long zap_pte_range(struct mmu_gather *tlb, struct page *page; page = vm_normal_page(vma, addr, ptent); - if (unlikely(details) && page) { - /* - * unmap_shared_mapping_pages() wants to - * invalidate cache without truncating: - * unmap shared but keep private pages. - */ - if (details->check_mapping && - details->check_mapping != page_rmapping(page)) - continue; - } + if (unlikely(zap_skip_check_mapping(details, page))) + continue; ptent = ptep_get_and_clear_full(mm, addr, pte, tlb->fullmm); tlb_remove_tlb_entry(tlb, pte, addr); @@ -1375,17 +1367,8 @@ static unsigned long zap_pte_range(struct mmu_gather *tlb, is_device_exclusive_entry(entry)) { struct page *page = pfn_swap_entry_to_page(entry); - if (unlikely(details && details->check_mapping)) { - /* - * unmap_shared_mapping_pages() wants to - * invalidate cache without truncating: - * unmap shared but keep private pages. - */ - if (details->check_mapping != - page_rmapping(page)) - continue; - } - + if (unlikely(zap_skip_check_mapping(details, page))) + continue; pte_clear_not_present_full(mm, addr, pte, tlb->fullmm); rss[mm_counter(page)]--; @@ -3369,8 +3352,9 @@ void unmap_mapping_page(struct page *page) first_index = page->index; last_index = page->index + thp_nr_pages(page) - 1; - details.check_mapping = mapping; + details.zap_mapping = mapping; details.single_page = page; + details.zap_flags = ZAP_FLAG_CHECK_MAPPING; i_mmap_lock_write(mapping); if (unlikely(!RB_EMPTY_ROOT(&mapping->i_mmap.rb_root))) @@ -3395,9 +3379,11 @@ void unmap_mapping_pages(struct address_space *mapping, pgoff_t start, pgoff_t nr, bool even_cows) { pgoff_t first_index = start, last_index = start + nr - 1; - struct zap_details details = { }; + struct zap_details details = { .zap_mapping = mapping }; + + if (!even_cows) + details.zap_flags |= ZAP_FLAG_CHECK_MAPPING; - details.check_mapping = even_cows ? NULL : mapping; if (last_index < first_index) last_index = ULONG_MAX;
Instead of trying to introduce one variable for every new zap_details fields, let's introduce a flag so that it can start to encode true/false informations. Let's start to use this flag first to clean up the only check_mapping variable. Firstly, the name "check_mapping" implies this is a "boolean", but actually it stores the mapping inside, just in a way that it won't be set if we don't want to check the mapping. To make things clearer, introduce the 1st zap flag ZAP_FLAG_CHECK_MAPPING, so that we only check against the mapping if this bit set. At the same time, we can rename check_mapping into zap_mapping and set it always. Since at it, introduce another helper zap_check_mapping_skip() and use it in zap_pte_range() properly. Some old comments have been removed in zap_pte_range() because they're duplicated, and since now we're with ZAP_FLAG_CHECK_MAPPING flag, it'll be very easy to grep this information by simply grepping the flag. It'll also make life easier when we want to e.g. pass in zap_flags into the callers like unmap_mapping_pages() (instead of adding new booleans besides the even_cows parameter). Signed-off-by: Peter Xu <peterx@redhat.com> --- include/linux/mm.h | 19 ++++++++++++++++++- mm/memory.c | 34 ++++++++++------------------------ 2 files changed, 28 insertions(+), 25 deletions(-)