Message ID | 7b4984f87a23369f9e4896d959945d01289a721d.1631610729.git.geliangtang@gmail.com (mailing list archive) |
---|---|
State | Superseded, archived |
Headers | show |
Series | The infinite mapping support | expand |
On Tue, 2021-09-14 at 17:19 +0800, Geliang Tang wrote: > This patch added a new member named start_seq to the msk to keep track of > the beginning of the last fully-acked data segment. This would be updated > in __mptcp_clean_una. > > Signed-off-by: Geliang Tang <geliangtang@gmail.com> > --- > net/mptcp/protocol.c | 3 +++ > net/mptcp/protocol.h | 1 + > 2 files changed, 4 insertions(+) > > diff --git a/net/mptcp/protocol.c b/net/mptcp/protocol.c > index 71a5427609a9..e804ca0ac9e1 100644 > --- a/net/mptcp/protocol.c > +++ b/net/mptcp/protocol.c > @@ -1071,6 +1071,7 @@ static void __mptcp_clean_una(struct sock *sk) > WRITE_ONCE(msk->first_pending, mptcp_send_next(sk)); > } > > + msk->start_seq = dfrag->data_seq; > dfrag_clear(sk, dfrag); > cleaned = true; > } > @@ -2891,6 +2892,7 @@ struct sock *mptcp_sk_clone(const struct sock *sk, > msk->wnd_end = msk->snd_nxt + req->rsk_rcv_wnd; > msk->setsockopt_seq = mptcp_sk(sk)->setsockopt_seq; > msk->last_retrans_seq = subflow_req->idsn - 1; > + msk->start_seq = 0; I think 'start_seq' should be initialized to 'subflow_req->idsn - 1'. The field name itself is a bit unclear to me. Something like 'last_fully_acked_dss_start_seq' would be more expressive, but it would not be a better name at all ;) Any suggestion for a good alternative name more than welcome! (otherwise we could add some more verbose comment nearby the field definition) /P
diff --git a/net/mptcp/protocol.c b/net/mptcp/protocol.c index 71a5427609a9..e804ca0ac9e1 100644 --- a/net/mptcp/protocol.c +++ b/net/mptcp/protocol.c @@ -1071,6 +1071,7 @@ static void __mptcp_clean_una(struct sock *sk) WRITE_ONCE(msk->first_pending, mptcp_send_next(sk)); } + msk->start_seq = dfrag->data_seq; dfrag_clear(sk, dfrag); cleaned = true; } @@ -2891,6 +2892,7 @@ struct sock *mptcp_sk_clone(const struct sock *sk, msk->wnd_end = msk->snd_nxt + req->rsk_rcv_wnd; msk->setsockopt_seq = mptcp_sk(sk)->setsockopt_seq; msk->last_retrans_seq = subflow_req->idsn - 1; + msk->start_seq = 0; if (mp_opt->suboptions & OPTIONS_MPTCP_MPC) { msk->can_ack = true; @@ -3148,6 +3150,7 @@ void mptcp_finish_connect(struct sock *ssk) WRITE_ONCE(msk->can_ack, 1); WRITE_ONCE(msk->snd_una, msk->write_seq); WRITE_ONCE(msk->last_retrans_seq, subflow->idsn - 1); + WRITE_ONCE(msk->start_seq, 0); mptcp_pm_new_connection(msk, ssk, 0); diff --git a/net/mptcp/protocol.h b/net/mptcp/protocol.h index eb3473d128d4..5e07264ba62b 100644 --- a/net/mptcp/protocol.h +++ b/net/mptcp/protocol.h @@ -224,6 +224,7 @@ struct mptcp_sock { u64 remote_key; u64 write_seq; u64 snd_nxt; + u64 start_seq; u64 ack_seq; u64 rcv_wnd_sent; u64 rcv_data_fin_seq;
This patch added a new member named start_seq to the msk to keep track of the beginning of the last fully-acked data segment. This would be updated in __mptcp_clean_una. Signed-off-by: Geliang Tang <geliangtang@gmail.com> --- net/mptcp/protocol.c | 3 +++ net/mptcp/protocol.h | 1 + 2 files changed, 4 insertions(+)