Message ID | 20211015132643.1621913-26-hch@lst.de (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [01/30] block: move the SECTOR_SIZE related definitions to blk_types.h | expand |
On Fri, Oct 15, 2021 at 03:26:38PM +0200, Christoph Hellwig wrote: > Add a helper to return the size of sb->s_bdev in sb->s_blocksize_bits > based unites. Note that SECTOR_SHIFT has to be open coded due to > include dependency issues for now, but I have a plan to sort that out > eventually. > > Signed-off-by: Christoph Hellwig <hch@lst.de> You can adjust this changelog to remove the note about SECTOR_SHIFT now. :) Reviewed-by: Kees Cook <keescook@chromium.org>
On 10/15/21 06:26, Christoph Hellwig wrote: > Add a helper to return the size of sb->s_bdev in sb->s_blocksize_bits > based unites. Note that SECTOR_SHIFT has to be open coded due to > include dependency issues for now, but I have a plan to sort that out > eventually. > > Signed-off-by: Christoph Hellwig <hch@lst.de> Looks good. Reviewed-by: Chiatanya Kulkarni <kch@nvidia.com>
diff --git a/include/linux/genhd.h b/include/linux/genhd.h index f67db3c5a04b3..70b4ac47e693c 100644 --- a/include/linux/genhd.h +++ b/include/linux/genhd.h @@ -250,6 +250,12 @@ static inline sector_t get_capacity(struct gendisk *disk) return bdev_nr_sectors(disk->part0); } +static inline u64 sb_bdev_nr_blocks(struct super_block *sb) +{ + return bdev_nr_sectors(sb->s_bdev) >> + (sb->s_blocksize_bits - SECTOR_SHIFT); +} + int bdev_disk_changed(struct gendisk *disk, bool invalidate); void blk_drop_partitions(struct gendisk *disk);
Add a helper to return the size of sb->s_bdev in sb->s_blocksize_bits based unites. Note that SECTOR_SHIFT has to be open coded due to include dependency issues for now, but I have a plan to sort that out eventually. Signed-off-by: Christoph Hellwig <hch@lst.de> --- include/linux/genhd.h | 6 ++++++ 1 file changed, 6 insertions(+)