Message ID | 20211023125722.125933-1-kaartic.sivaraam@gmail.com (mailing list archive) |
---|---|
Headers | show |
Series | submodule: correct an incorrectly formatted error message | expand |
Kaartic Sivaraam <kaartic.sivaraam@gmail.com> writes: > Hi Atharva, > > Sorry for the delay in sending this. Got held up with other work. > > On 21/09/21 10:17 pm, Atharva Raykar wrote: >>> >>> diff --git a/builtin/submodule--helper.c b/builtin/submodule--helper.c >>> index 414fcb63ea..236da214c6 100644 >>> --- a/builtin/submodule--helper.c >>> +++ b/builtin/submodule--helper.c >>> @@ -2775,7 +2775,7 @@ struct add_data { >>> }; >>> #define ADD_DATA_INIT { .depth = -1 } >>> >>> -static void show_fetch_remotes(FILE *output, const char *sm_name, const char *git_dir_path) >>> +static void show_fetch_remotes(struct strbuf *msg, const char *sm_name, const char *git_dir_path) >> >> I like the change from using a strbuf instead of passing the output >> stream and printing to it. But maybe we should rename this function, now >> that it doesn't really 'show' anything? Probably something like >> 'append_fetch_remotes()'? > > That's a good point. I've taken your suggestion into account in this v3. > > Find the details of the v3 of this patch below. Looking good. Let's declare victory and merge it down to 'next' and then to 'master'. Thanks, both. Will replace.