mbox series

[net-next,0/3] tcp: tcp_stream_alloc_skb() changes

Message ID 20211025221342.806029-1-eric.dumazet@gmail.com (mailing list archive)
Headers show
Series tcp: tcp_stream_alloc_skb() changes | expand

Message

Eric Dumazet Oct. 25, 2021, 10:13 p.m. UTC
From: Eric Dumazet <edumazet@google.com>

sk_stream_alloc_skb() is only used by TCP.

Rename it to tcp_stream_alloc_skb() and apply small
optimizations.

Eric Dumazet (3):
  tcp: rename sk_stream_alloc_skb
  tcp: use MAX_TCP_HEADER in tcp_stream_alloc_skb
  tcp: remove unneeded code from tcp_stream_alloc_skb()

 include/net/sock.h    |  3 ---
 include/net/tcp.h     |  2 ++
 net/ipv4/tcp.c        | 19 ++++++++-----------
 net/ipv4/tcp_output.c | 10 +++++-----
 4 files changed, 15 insertions(+), 19 deletions(-)

Comments

patchwork-bot+netdevbpf@kernel.org Oct. 26, 2021, 2 p.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (master)
by David S. Miller <davem@davemloft.net>:

On Mon, 25 Oct 2021 15:13:39 -0700 you wrote:
> From: Eric Dumazet <edumazet@google.com>
> 
> sk_stream_alloc_skb() is only used by TCP.
> 
> Rename it to tcp_stream_alloc_skb() and apply small
> optimizations.
> 
> [...]

Here is the summary with links:
  - [net-next,1/3] tcp: rename sk_stream_alloc_skb
    https://git.kernel.org/netdev/net-next/c/f8dd3b8d7020
  - [net-next,2/3] tcp: use MAX_TCP_HEADER in tcp_stream_alloc_skb
    https://git.kernel.org/netdev/net-next/c/8a794df69300
  - [net-next,3/3] tcp: remove unneeded code from tcp_stream_alloc_skb()
    https://git.kernel.org/netdev/net-next/c/c4322884ed21

You are awesome, thank you!