Message ID | 20220214101404.4074026-1-cezary.rojewski@intel.com (mailing list archive) |
---|---|
Headers | show |
Series | ALSA: hda: Expose codec organization functions | expand |
On 2022-02-14 11:14 AM, Cezary Rojewski wrote: > Changes expose several function that are currently unavailable for > HDA-DSP drivers for use. Those functions are: > > snd_hda_codec_cleanup_for_unbind() > snd_hda_codec_set_power_save() > snd_hda_codec_register() > snd_hda_codec_unregister() > snd_hda_codec_device_init() > > This allows upcoming AVS driver [1] to re-use even mode of HDA related > code that is currently available in sound/pci/hda and sound/hda and > prevent any code duplication within avs-driver that would otherwise had > to happen. > > Last patch in the series provides snd_hdac_ext_bus_link_at() - a helper > function which allows for retrieval of HDA segment (link) based on codec > address directly. This is simpler than parsing codec-name first to > extract the address what is the case for snd_hdac_ext_bus_get_link(). > The latter function is updated to re-use newly added one so core logic > is not duplicated after the addition. > > > Changes v1 -> v2: > - snd_hda_codec_new() now calls snd_hda_codec_device_new() with > 'snddev_managed' param set to 'true', reported by Kai Hello Takashi, Is there anything else I could help with or explain to help get this series merged? Regards, Czarek
On Mon, 21 Feb 2022 10:51:25 +0100, Cezary Rojewski wrote: > > On 2022-02-14 11:14 AM, Cezary Rojewski wrote: > > Changes expose several function that are currently unavailable for > > HDA-DSP drivers for use. Those functions are: > > > > snd_hda_codec_cleanup_for_unbind() > > snd_hda_codec_set_power_save() > > snd_hda_codec_register() > > snd_hda_codec_unregister() > > snd_hda_codec_device_init() > > > > This allows upcoming AVS driver [1] to re-use even mode of HDA related > > code that is currently available in sound/pci/hda and sound/hda and > > prevent any code duplication within avs-driver that would otherwise had > > to happen. > > > > Last patch in the series provides snd_hdac_ext_bus_link_at() - a helper > > function which allows for retrieval of HDA segment (link) based on codec > > address directly. This is simpler than parsing codec-name first to > > extract the address what is the case for snd_hdac_ext_bus_get_link(). > > The latter function is updated to re-use newly added one so core logic > > is not duplicated after the addition. > > > > > > Changes v1 -> v2: > > - snd_hda_codec_new() now calls snd_hda_codec_device_new() with > > 'snddev_managed' param set to 'true', reported by Kai > > Hello Takashi, > > Is there anything else I could help with or explain to help get this > series merged? I merged all patches now to for-next branch. thanks, Takashi